Battery problem ? Bootloop when battery unplugged, flash LED when plugged, fastboot ok

Search This thread

xla1

New member
Dec 27, 2021
2
0
Hello everybody,

I have a problem with my Xiaomi Mi A2 Lite (with bootloader unlocked but stock ROM) : I changed the screen and digitizer, the phone being okay after a repair and working for a few days. Then it stopped turning on when I press power button (the screen does not turn on). When I plug charger I have the white LED flashing but nothing (even after hours of charging with different chargers and USB cables). I can not go to fastboot by pressing power button down.
I disconnected the battery, the phone starts when plugged into charger but bootloops (with "Your device software can not be checked" and the fixed "android one unlocked" screen). When I replug battery in the bootloop stops and we get back to the black screen/flashing LED state.
I can go to fastboot mode when pressing volume down with battery disconnected, I tried flash_all from the official daisy_images package with no success. I also tried to fastboot boot to TWRP but I get a black screen (with bootloop if battery is unplugged).
I also tried QDL flashing of the official ROM using the guide on the forum, no success either.
I tried swapping the battery for a new one, still doesn't work.
When I dump fastboot vars I have amongst other "battery-soc-ok: no" (with and without battery plugged) and a reported battery voltage of 1000 with battery, 0 without.

I measured (with a voltmeter) the voltage between + and - pins of the battery I have 4.13V.

Would you have any idea of something to try ?

Thank you for your help,
 
Last edited:

mahnemjeff

New member
Nov 3, 2018
2
0
any updates on this?, my unit is stock no reimage or what not but while charging one time it wouldnt turn on white LED flashing also but no display, so i let be , then after awhile i discovered it wont boot up, after several times trying ,i got to boot but went to be stuck on "android one unlocked" screen, i tried draining the battery same results , wtf is wrong with this phone now it works perfectly for the past 3-4 years