Question Battery stuck at some percentage

Search This thread

JackDCalloway

Senior Member
Hello there fellow xda members!

My battery percentage is stuck with 85% at this very moment.
It is charging, but not depleting.
The long story:

It's been a long time since flashing ROMs like a maniac, but finally I decided to unlock that nice Redmi Note 10 pro and give it a shot.

I started with classic problems like a total noob, but I managed to get along and crDroid was the first ROM this week. I wasn't happy with the battery drainage, some 20% overnight, even with airplane mode and all.
So I decided to switch to EliteROM, managed all that and made a mistake, but also backups. I lost data during switch to EliteRom, so I made a EliteRom backup, restored the crDroid, was hoping to recover data and restore EliteROM again.
Yes, this is very very very very, very dirty flashing and I'm aware I have sinned.
Since then, the battery won't deplete.

I'm using the phone, tethering, surfing the web, etc. you name it. 85%.
At the moment I formatted and flashed, hoping a new Rom may fix the issue, but ArrowOS wasn't helping, so I clean flashed to EliteRom and here I am now, stuck at 85%, trying to get some drainage and a better reading. Actually using Betterbatterystats to get a reading of the drainage.

Anyone with a good Idea?
Maybe flashing firmware and where to get it from?
 

Sheist!

Senior Member
Oct 7, 2009
250
59
Redmi Note 10 Pro
Redmi Note 11
Hello there fellow xda members!

My battery percentage is stuck with 85% at this very moment.
It is charging, but not depleting.
The long story:

It's been a long time since flashing ROMs like a maniac, but finally I decided to unlock that nice Redmi Note 10 pro and give it a shot.

I started with classic problems like a total noob, but I managed to get along and crDroid was the first ROM this week. I wasn't happy with the battery drainage, some 20% overnight, even with airplane mode and all.
So I decided to switch to EliteROM, managed all that and made a mistake, but also backups. I lost data during switch to EliteRom, so I made a EliteRom backup, restored the crDroid, was hoping to recover data and restore EliteROM again.
Yes, this is very very very very, very dirty flashing and I'm aware I have sinned.
Since then, the battery won't deplete.

I'm using the phone, tethering, surfing the web, etc. you name it. 85%.
At the moment I formatted and flashed, hoping a new Rom may fix the issue, but ArrowOS wasn't helping, so I clean flashed to EliteRom and here I am now, stuck at 85%, trying to get some drainage and a better reading. Actually using Betterbatterystats to get a reading of the drainage.

Anyone with a good Idea?
Maybe flashing firmware and where to get it from?

Seriously, start from scratch and format, reboot into TWRP again and then wipe data, and flash fresh again. Good luck! You already know about the firmware and ROM links in this forum.
 

Attachments

  • t4x1o.jpg
    t4x1o.jpg
    175.3 KB · Views: 4

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Yeah I found all the stuff. The fix was to wipe and format it all and flash a stock rom.
    Got decent battery life and realistic battery drain. Thanks for the attention.