"Because an app is obscuring a permission request..."

Aug 4, 2015
12
7
0
Hey guys. Searched around and couldn't find another thread addressing this particular issue.

When I try to give an app accessibility access (in this particular case, it's the app Dashlane) it shows me the message "because an app is obscuring a permissions request, Settings can't verify your responses." Could anyone tell me what exactly this means and/or what I should be looking for to solve the problem?

Running Cosmic OSv.1.3 based off of Nougat 7.1.1
OpenGapps nano package
Magisk
No Xposed

Any help would be appreciated!
 

Mr.Ak

Senior Member
Jan 14, 2015
4,411
1,969
253
21
*RESTRICTED AREA*
Hey guys. Searched around and couldn't find another thread addressing this particular issue.

When I try to give an app accessibility access (in this particular case, it's the app Dashlane) it shows me the message "because an app is obscuring a permissions request, Settings can't verify your responses." Could anyone tell me what exactly this means and/or what I should be looking for to solve the problem?

Running Cosmic OSv.1.3 based off of Nougat 7.1.1
OpenGapps nano package
Magisk
No Xposed

Any help would be appreciated!
Go to app setting and grant all permissions.
 
  • Like
Reactions: [email protected]

[email protected]

New member
Oct 31, 2017
4
0
0
Pune
Regarding Your App Permission Issue

Hi

Welcome to the XDA Help Forum.

Regarding your permission issue on your phone, the problem may be caused by an app called "File manager" (or "Gestionnaire de fichiers" in french). Either you can uninstall it, or if you want to keep it, go in "Settings -> Applications -> Settings -> Draw over other apps" and set the value to "No" for "File manager".
If you don't find still...Go to settings and search 'draw over other apps'.

Let me know if this info is helpful in resolving this issue or not.

Regards,
Ashwin Nanaware
 

raviranveer

New member
Nov 14, 2017
1
1
0
I m using moto g5 s plus..unable to activate accessibility for app like nova launcher

Hi

Welcome to the XDA Help Forum.

Regarding your permission issue on your phone, the problem may be caused by an app called "File manager" (or "Gestionnaire de fichiers" in french). Either you can uninstall it, or if you want to keep it, go in "Settings -> Applications -> Settings -> Draw over other apps" and set the value to "No" for "File manager".
If you don't find still...Go to settings and search 'draw over other apps'.

Let me know if this info is helpful in resolving this issue or not.

Regards,
Ashwin Nanaware
No its not working... Plz help
Thank you,☺
 
  • Like
Reactions: [email protected]

[email protected]

New member
Mar 4, 2018
1
6
0
If it can help... Same issue with Huawei P8 Lite 2017. No way to autorise USB debugging, failing with "An app is obscuring a permission request".

I solved this as follows:
- Go to Settings > Apps > Settings icon (at the bottom).
- Then Advanced > Special access > Draw over the other apps.
- At the top right, in the scrolling menu, choose "Show system processes".
- Select "Floating dock" and disable "Permit drawing over other apps".

Si ca peut aider... Meme probleme avec Huawei P8 Lite 2017. Impossible d'autoriser le debogage USB, erreur "Une application dissimule la demande d'autorisation".

Probleme resolu de la maniere suivante:
- Aller dans Parametres > Applications > Icone Parametres (en bas).
- Ensuite Parametres Avances > Autorisations speciales des applications > Se superposer aux autres appli.
- En haut a droite, dans le menu deroulant, selectionner "Montrer les processus systeme".
- Selectionner "Menu flottant" et desactiver "Autorisation de superposition".
 
Last edited:

Monte_Christo

New member
Mar 10, 2018
1
1
0
Worked for me

Great tip. Worked like a charm. Thanks!

If it can help... Same issue with Huawei P8 Lite 2017. No way to autorise USB debugging, failing with "An app is obscuring a permission request".

I solved this as follows:
- Go to Settings > Apps > Settings icon (at the bottom).
- Then Advanced > Special access > Draw over the other apps.
- At the top right, in the scrolling menu, choose "Show system processes".
- Select "Floating dock" and disable "Permit drawing over other apps".
 
  • Like
Reactions: hosseinpv

Nathanxda

New member
Feb 14, 2018
3
1
0
Try this↓
Check whether there is other app that request accessibility service, then turn it off.

Some apps like fooview or easytouch may casusing this after you granted accessibility service permission to them.
(Worked for me after i disabled the fooview accessibility service when i was requesting adb permission from a PC)
 
Last edited:
  • Like
Reactions: mariobello

egandt

Senior Member
Mar 25, 2008
400
132
63
I can not turn off every draw over other apps there and dozens of them, same with modify system settings, is there a way to turn off all of that crap temporarily as I need to use Andorid debugging and it will not tell me what app is blocking the OK, but turning off all of these apps is not practical as I may need to enable multiple computers.

ERIC
 

wolf-ccc-grey

New member
Feb 6, 2018
2
0
0
désactive ton lanceur et remet celui d’origine. pour moi c'est bon.

Hey guys. Searched around and couldn't find another thread addressing this particular issue.

When I try to give an app accessibility access (in this particular case, it's the app Dashlane) it shows me the message "because an app is obscuring a permissions request, Settings can't verify your responses." Could anyone tell me what exactly this means and/or what I should be looking for to solve the problem?

Running Cosmic OSv.1.3 based off of Nougat 7.1.1
OpenGapps nano package
Magisk
No Xposed

Any help would be appreciated!
désactive ton lanceur et remet celui du smartphone d’origine pou. pour moi c'est bon.
 

sunnytn

New member
Mar 3, 2012
3
0
1
Hi

Welcome to the XDA Help Forum.

Regarding your permission issue on your phone, the problem may be caused by an app called "File manager" (or "Gestionnaire de fichiers" in french). Either you can uninstall it, or if you want to keep it, go in "Settings -> Applications -> Settings -> Draw over other apps" and set the value to "No" for "File manager".
If you don't find still...Go to settings and search 'draw over other apps'.

Let me know if this info is helpful in resolving this issue or not.

Regards,
Ashwin Nanaware
Thanks a lot it worked for me , go in "Settings -> Applications -> Settings -> Draw over other apps" and set the value to "No" for "File manager".
 

broslav

Member
May 3, 2018
7
4
0
One of the things that I had to do on my (S9+) phone is to temporarily disable my edge(s) in "Edge Gestures" app. No need to force close it.
Haven't tried, but maybe just clearing all the apps from RAM that draw over-the screen could solve the issue.
(I did also uninstall Sesame Shortcuts and all Substratum overlays and rebooted but that was not enough until I disabled Edge Gestures.)
 

Orlando T

New member
May 21, 2018
1
0
0
Hi guys i have a Samsung galaxy s7 and i having the same problem to conect a HDMI cable to the tv it said that some app is obscuring permission what can i do i need help before i go crazy
 

HeathenMan

Senior Member
Oct 8, 2011
489
95
58
getbtc.de.tl
If someone gets this while disabled all overlay over settings, try alert window checker and force close all user apps that it shows. Worked for me.
Btw i was only able to get a pairing question on my device with samsung kies driver reinstall and pdanet lol