beta program

Search This thread

fiffan86

Senior Member
Dec 2, 2010
734
198
Las Vegas, NV
With DP1 and now DP2 I select Gear S3 Frontier and I get the passkey on my phone and watch and then the app just force closes. Can't get it to finish the setup process.


So, you're on dp2 and your frontier works? We're you on dp1? Dirty/clean flash?

I was on Oreo when I setup my watch, I took the beta ota since I'm Verizon locked bootloader.
 

Rocket_Man_

Member
Oct 19, 2017
7
0
Android P got me

I was looking around Android p and I noticed that the "AI" had noticed that I use incognito window often.

---------- Post added at 02:40 AM ---------- Previous post was at 02:39 AM ----------

I couldn't post the screenshot but it's in the app drawer
 

imucarmen

Senior Member
May 28, 2012
1,727
706
I'm running it on my Verizon P2XL but think I might go back to Oreo. I'm not really liking the UI of P. The quick toggles are ugly, the new nav bar is ugly (yes I know the Oreo style can be used) the status bar looks strange and the new LTE and 3G icons are ugly, the old style AOD was better, and so far, overall, I'm not really a fan. I do like the new animations, it seems to run a bit more fluid, swiping on the lockscreen is 10 times better (it's so bad on Oreo) but other than that I'm not seeing much I like about it. I might run it a few days and see if it grows on me but I have a feeling I'll go back to Oreo because I'm already missing Mono Substratum theme.
 

danielrod

Senior Member
Dec 21, 2010
427
85
I was looking around Android p and I noticed that the "AI" had noticed that I use incognito window often.

---------- Post added at 02:40 AM ---------- Previous post was at 02:39 AM ----------

I couldn't post the screenshot but it's in the app drawer

hahaha Google knows all!
 

dragonstalker

Senior Member
Jan 1, 2008
1,914
1,303
Fort Myers, Fla
Hello my XDA world. Been a while since I've been active on here helping out. But here are some beta things to know.

Most of these I have submitted tickets for on android P support page already.

Android Auto does not work.
Google home does not work.
Using Notification window to text pushes the text down. So after about 3 or 4 text the entry window is hidden behind the keyboard. / if already in android messenger, the new notification pops up over the window you are texting in causing a redundant screen.

If for any reason you have to wipe your phone or choose to do a clean image install, android backup is not available for anything after 7.0. So you will lose the backup you made prior to flashing the android p tamien img.
The only fix is to opt out of android beta p program, which should send you an ota for android O stable. ( This may be a single issue. I still had no backup after opting out of Beta)

Magisk 16.4 is supposed to work for rooting android P, although I could not get it to patch stock img. others have said they had success.

IMHO. This initial beta had more wrong than right, but it was fun to play with to see how it will function. Too many of the things I need to work are still glitchy so this is def not a daily driver that you can work with unless you are extremely patient.
 
Last edited:

AndrasLOHF

Senior Member
Jan 7, 2013
2,875
2,065
IMHO. This initial beta had more wrong than right, but it was fun to play with to see how it will function. Too many of the things I need to work are still glitchy so this is def not a daily driver that you can work with unless you are extremely patient.

That's what kept me off of it. Anything broken now could be broken for 5 more months. I've seen more stable alpha/beta versions of ROMs before than what Google pushes though the program. There is always some critical function I use that is broken.
 

cbasse

Senior Member
Jul 31, 2010
755
87
South of Boston, MA
Just wanted to chime in...

Google Pay and Android Auto working here fine. Flashed the May 8.1 image, then entered the beta program for the OTA update to P. I've seen others having issues with Pay & Auto, but it appears to be something on their end, not inherent in P.
 

fliptwister

Senior Member
May 12, 2010
72
10
Android Auto working for me as well. That is good news because I use a lot and I'm liking beta. I have found nothing that does not work currently.
 

uicnren

Senior Member
Jun 19, 2007
1,254
447
Google Nexus 5
Google Pixel 2 XL
just my $0.02.

No issue with android auto
no issue with google home
Still have my backups available in google drive. actually had to restore them several times as I did have an issue when flashing the factory images for P and then restoring said backups. WiFi for some reason would lose internet. So, I went back to 8.1 factory image, restored from same backup made prior to P release, then updated via OTA. All is fine.

Only thing I have really had any 'issue' with is disappearing weather on ambient display, but seems many others are as well. Though its hardly anything critical.
To this point both DPs have worked well for daily use for me.
DP1 had a strange issue with system volumes after connecting and disconnecting from bluetooth, but was fixable by a reboot. Seems to be fixed in DP2 for me.
 

danielrod

Senior Member
Dec 21, 2010
427
85
just my $0.02.

No issue with android auto
no issue with google home
Still have my backups available in google drive. actually had to restore them several times as I did have an issue when flashing the factory images for P and then restoring said backups. WiFi for some reason would lose internet. So, I went back to 8.1 factory image, restored from same backup made prior to P release, then updated via OTA. All is fine.

Only thing I have really had any 'issue' with is disappearing weather on ambient display, but seems many others are as well. Though its hardly anything critical.
To this point both DPs have worked well for daily use for me.
DP1 had a strange issue with system volumes after connecting and disconnecting from bluetooth, but was fixable by a reboot. Seems to be fixed in DP2 for me.

Hmm...I'm actually still having that bluetooth problem in DP2 and my "Automatically Turn on Wi-Fi" feature stopped working as well and I always have to end up turning it on manually. Did you do a full wipe to DP2?
 
Last edited:

uicnren

Senior Member
Jun 19, 2007
1,254
447
Google Nexus 5
Google Pixel 2 XL
Hmm...I'm actually still having that bluetooth problem in DP2 and my "Automatically Turn on Wi-Fi" feature stopped working as well and I always have to end up turning it on manually. Did you do a full wipe to DP2?

My last attempt to DP2 was full wipe, return to 8.1 w/May sec. patch, restore from backup, enroll in beta program, update to DP2 via OTA. When I used factory images, I could not restore from a backup, as something in backup would corrupt WiFi to the point of it having no internet connection. If I set up as new it worked fine, so was definitely something from my backup. When I did as above and restored same backup to 8.1 and updated via OTA, WiFi still worked fine.

I keep bootloader locked so I can use Google Pay, so device was wiped several times in the process as well as me doing factory reset from recovery. Im sure it is overkill, but finally got to fully working DP2.

---------- Post added at 10:08 AM ---------- Previous post was at 10:08 AM ----------

Google Pay not working.... Can anyone verify?

working for me.
 
  • Like
Reactions: danielrod

cbasse

Senior Member
Jul 31, 2010
755
87
South of Boston, MA
My last attempt to DP2 was full wipe, return to 8.1 w/May sec. patch, restore from backup, enroll in beta program, update to DP2 via OTA. When I used factory images, I could not restore from a backup, as something in backup would corrupt WiFi to the point of it having no internet connection. If I set up as new it worked fine, so was definitely something from my backup. When I did as above and restored same backup to 8.1 and updated via OTA, WiFi still worked fine.

I keep bootloader locked so I can use Google Pay, so device was wiped several times in the process as well as me doing factory reset from recovery. Im sure it is overkill, but finally got to fully working DP2.

---------- Post added at 10:08 AM ---------- Previous post was at 10:08 AM ----------



working for me.

FYI - Google Pay is working for me even with bootloader unlocked. I have not rooted since going to P, and still on stock kernel and recovery.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    From what I've read, NFC is not functional, so no it would not work if that's true.

    Tested Android Pay at lunch for my subway - no issues.
    2
    Do not need to unlock

    I don't know if this question has been asked and I've combed the threads. When the Android P beta program starts (hopefully tomorrow) will I need an unlocked bootloader for that? I'm currently on VZW's stupid locked bootloader.


    I apologize in advance if this has already been answered. I know how you guys hate repeating yourselves.
    You can flash the OTA firmware in recovery mode. and use adb sideload command to update Android P beta. download OTA firmware in developers.android.com/preview/download-ota.html
    2
    Yeah I was just assuming. It's always better to tell people the safer truth than the actual truth until it all is confirmed.

    EDIT: It's easier for those people that don't know a lot about how things work and panic if something goes wrong.

    As honorable intention that seems, spreading misinformation on these forums is not a good thing.
    1
    Hmm...I'm actually still having that bluetooth problem in DP2 and my "Automatically Turn on Wi-Fi" feature stopped working as well and I always have to end up turning it on manually. Did you do a full wipe to DP2?

    My last attempt to DP2 was full wipe, return to 8.1 w/May sec. patch, restore from backup, enroll in beta program, update to DP2 via OTA. When I used factory images, I could not restore from a backup, as something in backup would corrupt WiFi to the point of it having no internet connection. If I set up as new it worked fine, so was definitely something from my backup. When I did as above and restored same backup to 8.1 and updated via OTA, WiFi still worked fine.

    I keep bootloader locked so I can use Google Pay, so device was wiped several times in the process as well as me doing factory reset from recovery. Im sure it is overkill, but finally got to fully working DP2.

    ---------- Post added at 10:08 AM ---------- Previous post was at 10:08 AM ----------

    Google Pay not working.... Can anyone verify?

    working for me.
    1
    U should be fine. My first Pixel XL was locked still able to get Android O at the time
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone