• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

BlackView BV9600 Pro + LineageOS?

Search This thread

joe tigercat

Member
Feb 21, 2014
10
5
can someone provide insight with a problem. i once had havoc is on my 9600 pro (p60 version), but could not hget 4g and volte to work with it, so went back to stock. i now have a second 9600 pro (p70 version), and am trying again.
so i flash stock rom with sp flash tools. boot to unlock the bootloader (have the red letter in right corner for some reason). go to fastboot unlock bootloader, unlock flashing, flash recovery, boot to recovery, flash havoc 3.8 arm 64 AB gapps. flash magisk. wipe, and reboot. every single time it boots back to fastboot (says factory on phone. ) i've tried a couple different roms. same result. after flashing, it boots to fastboot.
any ideas?
ok, so serge's 'fix start' patch might have done the trick
 

joe tigercat

Member
Feb 21, 2014
10
5
BlackView BV9600 Pro + LineageOS?
I can’t understand why this topic has such a name??
For example, today I installed LineageOS_17.1 firmware on my bv9600Pro
Surprisingly, almost everything works ... but I honestly don't like LineageOS
Now there are a lot of lineageOS-based firmware updates that are much more interesting!
For example Havoc-OS 3.6 it’s much more interesting and also, without problems, it runs on bv9600Pro
PS/
Ссылка:
Serge, thanks for your hard work on this phone. I've enjoyed your 4pda.rom, as well as havoc os for the 9600. We're you able to get volte working for any GSI Rom? Seems almost impossible on MediaTek chips
 

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    can you explain how did you get root? or give me a guide, all the internet guides i tried failed!
    thanks

    simply follow this guide -> LINK

    - allow OEM unlock in the dev-settings (hit 5 times build number to see)
    - allow usb debugging
    - reboot to fastboot
    - send "fastboot devices" command
    - send "fastboot oem unlock" -> acknowledge
    - send "fastboot flashing unlock" -> acknowledge
    - flash the twrp image "fastboot flash recovery name_of_the_image.img"
    - reboot into twrp by power of the device
    - after that press vol+ up and power button (if i remember correct.. :p ) to get into twrp
    - now u need a sd-card (micro) put no verity opt encrypt on it and magisk
    - Backup all partitions u find.
    - format data partition to get the size
    - install magisk
    - install no verity opt...
    reboot

    BV9600 should be rooted. Took me serveral times to get it working, because u need directly after "Flashing unlock command" to get the twrp stuff done.

    Credits
    The TWRP.img comes from www.unofficialtwrp.com
    The encryption disabler comes from @Zackptg5 all credits to him. THANKS -> his site LINK

    Enjoy :cowboy:
    1
    Well, someone need to compile it for our bv9600 - i also would appreciate it, but i don't have thoose skills...
    1
    i am not even not able to root my device (blackview bv9600 pro) i don't think that you will be able to have any lineage rom also...

    have anyone success to root this device?

    jup, runs root - magisk
    1
    I don’t understand why unblock the bootloader at all if everything is installed on the MTK platform using the SP Flash Tool !?
    Why these dances with adb and fastboot? if a everything is done much easier ...
    You do not install the factory software using adb ? not ?? so why can't TWRP be installed and installed using the SP Flash Tool!? Why complicate things?