Bluetooth OBD Adapter not connecting after malaysk rom

Search This thread

dannyboy223

Member
Feb 29, 2016
16
5
Hi everyone, I have a joying rk3188 1024x600 head unit and recently flashed the most recent malaysk rom. Before the flash, obd dongle would pair fine. Now I cannot get out to connect. I can connect my phone to the headunit, can connect my phone to the obd dongle, but cannot connect the obd dongle to my headunit whatsoever. It shows up in "available devices" and can be clicked then click "yes" to connect, but it doesn't connect.

I've tried to play around with xposedmtc but no luck.

Anyone have any ideas?

Thanks!
 

tw0119

Member
Jan 14, 2016
14
4
Malaysk‘s rom Dec.2015 on my JY-HU clould pair fine ,but Feb.2016&Jan.2016 roms could not.
So i try disalbe all Xposed modules ONLY enable Xposed mtc ,OBD dongle works after roboot
 
  • Like
Reactions: dannyboy223

dannyboy223

Member
Feb 29, 2016
16
5
Tw0119, perfect, works now. Did you go back and reactivate the modules again or no?

Thank you so much btw!
 

pa.ko

Senior Member
Dec 4, 2010
523
156
NO,if you reactive the XposedManager module it would be down.
So i think somethings wrong with the Framework,maybe Malaysk could TEST for it
No XposedBT whit OBD.

Prob is that there are number of overlapping Xposed modules, conflicting with each other and even underlying ROM features.

Until Malaysk and module devs coordinate their activities you have to experiment and make compromises. In order to get something you have to drop something.
 
  • Like
Reactions: tw0119

cheatman

Senior Member
May 21, 2007
589
2,161
Migration Institute
I had the same problem: my bluetooth OBD2 / OBD adapter were being detected, but I could not pair them. My OBD2 adapter has a pin number and I was never asked for the pin to pair. Also, the device was being scanned and shown with the phone icon instead of the OBD icon. Had this problem with March and January 2016 versions of Malaysk ROM (which is awesome, btw!). How I solved the problem:

1. Opened the stock bluetooth app, removed the device which already appeared paired
2. Set the default pairing PIN to the PIN of my device
3. Disabled XposedMTC and XposedBT in the Xposed module manager
4. Rebooted
5. Scanned for the device, checked that it appears as OBD (icon) and paired again. No pin was requested, but it paired correctly and it works.

Hope this helps! Cheers,
C.
 

iateshaggy

Senior Member
Oct 7, 2013
82
6
i have 2 adapters and neither will work for me. one will not pair no matter what combination of things i choose in xposed but works great with my phone. the other adapter works so good i don't even have to put in the pass code when using my deck, but it will not communicate with my 2001 fords ecu.
 

alcatraz06

Member
Apr 27, 2014
6
0
Hi
Not working bluetooth. Not scaning anything

Which BT chip sellected? WQ BC5 ,WQ BC6, IvtBt,Sd bt, WQ BC6B. My sytem rk3066 arm vortex 1.6 dual core .
April 2016 malaysk rom.
I tryed xposed disable combination but not working bluetooth
Help pls

Sytem starting i see pop-up bt connecting,version2
 
Last edited:

spirosme

Senior Member
Dec 27, 2015
62
11
OBD adapter

Unfortunately I have the same problem with the OBD adapter are connected may not apply to find and get information...
The machine is KLD2-RK3188 1024x600 machine with the latest of Rom Malaysk 21/1/2017 (21 version)
I have tried all the above solutions but still not the OBD program works.
 

prolecs

Member
Aug 28, 2014
6
0
Brisbane
OBD connection Joying

Can somebody tell me where to get to "Xposed module manager" in Joying system please? For OBD bluetooth issue
 

B3rt

Senior Member
Sep 27, 2008
215
16
Deurne
i had same problem but solved it.

Don't use the bluetooth menu in system settings but use the bluetooth app instead (which came with the rom (android 6)).
Using the bluetooth app search here and here pairing worked without any problems for me, after pairing it worked as normal again.
 

pa.ko

Senior Member
Dec 4, 2010
523
156
I had the same problem: my bluetooth OBD2 / OBD adapter were being detected, but I could not pair them. My OBD2 adapter has a pin number and I was never asked for the pin to pair. Also, the device was being scanned and shown with the phone icon instead of the OBD icon. Had this problem with March and January 2016 versions of Malaysk ROM (which is awesome, btw!). How I solved the problem:

1. Opened the stock bluetooth app, removed the device which already appeared paired
2. Set the default pairing PIN to the PIN of my device
3. Disabled XposedMTC and XposedBT in the Xposed module manager
4. Rebooted
5. Scanned for the device, checked that it appears as OBD (icon) and paired again. No pin was requested, but it paired correctly and it works.

Hope this helps! Cheers,
C.

That worked for me. But found also additional tips are needed to check:
1. If adapter name is not OBDII per default then in BT app settings (last tab) set exact name. This option is available in modded BT apps in Malaysk ROM (4.4.4), dunno for other ROMs. So there is no need for any exposed modules, just change adapter name in app.
2. Adapter with correct name can pair even if pin code is incorrect! Looks like paired but will not work in apps. So check that pin code in BT app settings is correct for your adapter.
3. In Torque, if you had any other adapter used before, clean all app data (in Android app info). Also noticed that even after app data cleaning, old Mac address is shown instead of new one paired in BT app. Looks like MCU somehow wrongly saves and provides old, even removed from BT app, adapter Mac address. But new paired adapter is working. So there is some mess with MCU and BT and Torque... Not sure where is the issue, but noticed that latest Torque ver listed something about 'improved listing of BT devices'. So it may be known issue on Torque side....
 

AngusMacG

New member
Aug 14, 2018
1
0
I had the same problem (obd bluetooth not working) using Pumpkin Android 7.1.2 with malaysk ROM 4.1 and found the following solution:

Go to app settings, select "show system apps" an delete data+cache of all (4 in my case) apps regarding bluetooth.
Then connect your devices again. Enjoy
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    I had the same problem: my bluetooth OBD2 / OBD adapter were being detected, but I could not pair them. My OBD2 adapter has a pin number and I was never asked for the pin to pair. Also, the device was being scanned and shown with the phone icon instead of the OBD icon. Had this problem with March and January 2016 versions of Malaysk ROM (which is awesome, btw!). How I solved the problem:

    1. Opened the stock bluetooth app, removed the device which already appeared paired
    2. Set the default pairing PIN to the PIN of my device
    3. Disabled XposedMTC and XposedBT in the Xposed module manager
    4. Rebooted
    5. Scanned for the device, checked that it appears as OBD (icon) and paired again. No pin was requested, but it paired correctly and it works.

    Hope this helps! Cheers,
    C.
    1
    TRY disable xposed-bt or manager in xposed
    and roboot will be done
    1
    Malaysk‘s rom Dec.2015 on my JY-HU clould pair fine ,but Feb.2016&Jan.2016 roms could not.
    So i try disalbe all Xposed modules ONLY enable Xposed mtc ,OBD dongle works after roboot
    1
    NO,if you reactive the XposedManager module it would be down.
    So i think somethings wrong with the Framework,maybe Malaysk could TEST for it
    No XposedBT whit OBD.

    Prob is that there are number of overlapping Xposed modules, conflicting with each other and even underlying ROM features.

    Until Malaysk and module devs coordinate their activities you have to experiment and make compromises. In order to get something you have to drop something.