• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Bluetooth turns off by itself

Search This thread

donpipino

Member
Mar 17, 2015
17
0
Hello! I got my XZ Premium this Friday, and I got this problem almost right away.

I have a Huawei Watch connected to my phone, the problem is that Bluetooth on the phone turns itself off quite often. Sometimes it happens after 30 minutes, another time it happens after 2 hours.

I have to activate Bluetooth on the phone again when it happens, so it's not that the watch is disconnecting by itself.

Is anyone else having this problem? This might not be specific to the XZ Premium, it might be a bug in Android.
 

admad

Senior Member
Dec 27, 2010
136
57
Hello! I got my XZ Premium this Friday, and I got this problem almost right away.

I have a Huawei Watch connected to my phone, the problem is that Bluetooth on the phone turns itself off quite often. Sometimes it happens after 30 minutes, another time it happens after 2 hours.

I have to activate Bluetooth on the phone again when it happens, so it's not that the watch is disconnecting by itself.

Is anyone else having this problem? This might not be specific to the XZ Premium, it might be a bug in Android.

I have the same problem, it looks like bluetooth got serious issues on Android 7. I have problems with bluetooth song information not being updated on my car radio, so I decided to create a bug report. "Luckily" the bluetooth turned off about 20 sec after I turned it on. So my bug report should contain necessary data to fix this issue, I've sent it over to Sony support.
 
  • Like
Reactions: charlatan01

donpipino

Member
Mar 17, 2015
17
0
I solved this problem! I went into the Network settings and there was a choice called Reset Network Settings (I think, my phone is in Swedish). I lost all my Bluetooth connections and every Wifi I had connected to, but after that reset the Bluetooth works! :)
 

Cryosx

Senior Member
Jul 19, 2010
997
192
I have the same problem, it looks like bluetooth got serious issues on Android 7. I have problems with bluetooth song information not being updated on my car radio, so I decided to create a bug report. "Luckily" the bluetooth turned off about 20 sec after I turned it on. So my bug report should contain necessary data to fix this issue, I've sent it over to Sony support.

I have the U11 which is also on 7.1.1. I have this annoying problem too :/

Car just won't work correctly. Apparently 7.1.2 might have the fixes in it but I don't know when the U11 will get that.
 
Last edited:

jaseman

Senior Member
Aug 27, 2012
699
192
Spring
Personally I don't care if it's an Android or Sony problem. I know I am SICK AND TIRED of buying expensive phone(s) from many OEM's only to discover that we are receiving units that do not function as advertised!! It is time that these OEM's start improving their quality control to make sure that these things work. These are not $20.00 items but several hundred dollars each. TIme for the lawyers!
I also wish those who review these things would STOP with all the camera crap and put these things through their paces in the area's that are most important.... like signal quality.... all signals. There is too much emphasis on gaming, VR, and how well the camera can take pictures in the dark. Who cares if you cannot connect to anything??? Get a DSLR if you must take pictures with the lights off. So stupid!
 

ScorpioViking

New member
Dec 14, 2014
3
0
I solved this problem! I went into the Network settings and there was a choice called Reset Network Settings (I think, my phone is in Swedish). I lost all my Bluetooth connections and every Wifi I had connected to, but after that reset the Bluetooth works! :)
Question now is for how long does fix last. Mine goes in and out daily as well as periodically and really creates havoc with my SWR12, (SmartBand 2), vibrates something wicked as well as draining the battery. Tried your suggestion on my own and in no time problem reappeared. Ultimately, is this an Android 7 problem or Sony jinx?
 

donpipino

Member
Mar 17, 2015
17
0
Question now is for how long does fix last. Mine goes in and out daily as well as periodically and really creates havoc with my SWR12, (SmartBand 2), vibrates something wicked as well as draining the battery. Tried your suggestion on my own and in no time problem reappeared. Ultimately, is this an Android 7 problem or Sony jinx?

Good to know I'm not the only one with this problem (or not good, but you know what I mean)

Yeah I spoke way too soon, the problem reappeared a few hours after. I guess I was too positive :) The same thing is happening here, my Huawei Watch is vibrating like crazy.

There doesn't seem to be any pattern when it turns off either, one time it can be after 30 minutes, the next after a few hours. It happens both at home and my workplace, so not location-related. Extremely annoying!

I think this is a bug with the XZ Premium, but I'm not sure.
 

loofmodnar

New member
This has been driving me nuts since I got the phone. At first I thought it was a battery saving thing but it's pretty inconsistent. The good news is it seems to maintain a connection as long as I'm actively using bluetooth for my headset or speakers but after I stop it shuts off after a period of time.
 

Denonite

Senior Member
Apr 4, 2011
74
6
Anyone still having this issue. I never had this issue under Nougat but its driving me nuts under Oreo. I just can't get a stable Bluetooth connection, it's constantly disconnecting and turning itself off. Bloody thing's almost gone out of the car window a few times as it turned bluetooth even when connected and I'm driving.
 

ScorpioViking

New member
Dec 14, 2014
3
0
Anyone still having this issue. I never had this issue under Nougat but its driving me nuts under Oreo. I just can't get a stable Bluetooth connection, it's constantly disconnecting and turning itself off. Bloody thing's almost gone out of the car window a few times as it turned bluetooth even when connected and I'm driving.
Hi again. Still frustrated with bluetooth glitch on my now Oreo version of Sony Xperia XZ Premium. Somebody mentioned time to contact the lawyers; class action anyone?

Sent from my G8141 using Tapatalk
 

AREK28

Member
Sep 9, 2013
41
0
I have the same problem on my XZ1 compact when paired to my Plantronics BT headset, it kept disconnecting and reconnecting the next second. Sometimes the BT would show that is is connected but when i make a call, it isn't connected to the BT headset. I emailed support and follow their instructions below and still have the same problem, anybody experiencing the same? Hope there is a solution to fix this problem soon.

Thank you for contacting the Sony Xperia support centre.
With regards to your query, kindly be advised to switch your phone to the safe mode, under the safe mode, please reset your Plantronics BT earphone and pair with the phone again.
If the device performance improves in safe mode, it’s likely that one or more downloaded applications are affecting the device negatively. You can exit safe mode and restart the device to uninstall the application or applications you suspect are causing the problem. If the problem is recent and you’re not sure which application is causing the problem, you can start by uninstalling the most recently downloaded application.
To enable Safe mode
1. While the phone is on, press and hold down the power key.
2. In the pop up window, touch and hold Power off until the Reboot to safe mode message appears.
3. Tap OK to reboot in safe mode.
To exit Safe mode
• When in Safe mode, restart the phone.
If the issue still persist under the safe mode, kindly be advised to perform a software repair by using the Xperia Companion.
To do this, you will need to install Xperia Companion from the Sony Xperia website. Please perform a backup first if your phone is able to on. Please follow the steps below to do this:

1. Go to http://www.sonymobile.com/global-en/
2. Select Support
3.Click on Xperia companion
4.Look for " connect to your computer
5.Click on" Download for windows "

System requirements:
• Broadband connection
• Intel Pentium 4 or equivalent AMD processor
• 5 GB free hard disk space
• 2 GB RAM
• 1 available USB 2.0 or USB 3.0 port and USB cable
• Microsoft Windows 7, Windows 8(8.1 or Windows 10
• OSX 10.8 (Mountain Lion) or above

Note! There will be no support for Windows XP or Vista

To do a Backup, click on the "Backup" icon and follow the steps accordingly.

1) Click Backup to start
2) Xperia Companion will prompt you to name a new backup set. If an existing backup is available the data will added to the existing backup set. Click OK, to save the file name
3) Xperia Companion is able to backup personal data and media. Click the arrow to expand the My Data selection. Click Next to start the backup.

My data – Contacts & Call log, Calendar, Text messages and Others
Camera – Photos and Videos
Music – Music

4) Xperia Companion will request a password to be set for the backup files. This is optional unless the device is encrypted. If encrypted this will be mandatory. Click Next to progress.
5) Once the application has complied a backup the progress will automatically move onto the next window. Xperia Companion will notify that the backup has been successful. Click to Done to complete the process.

To do a Software Repair, just click on the "Software Repair" icon and follow the steps accordingly.

1) Click Software Repair to start
2) Xperia Companion will advise of Google Theft Protection risks. You must acknowledge that you know your details before process to the next step. Tick Yes to progress and then click Next.
3) You will be warned that all your local stored data will be removed. Tick I understand follow by clicking Next to progress.
4) Xperia Companion will download the Update Engine application. This application will run in background and you will not see the service. The service will progress automatically. The progress will vary depending on internet speeds. Once the Update Engine has been installed, you will be requested to connect your device. You must follow the steps for Xperia Companion to detect the device.
5) When the device has been detected the application will automatically move to the next step. Click Next to progress. When the repair has been completed, Xperia Companion will progress and confirm a successful repair. Click Done to complete the process.

Thank you for contacting the Sony Xperia support centre.

With regards to your query, we suggest you to forget the Bluetooth pairing and clear data of the Bluetooth app by going Settings > Apps & notification > Apps info > tap on 3 vertical dots on top right hand corner > Show system > Bluetooth > Force stop > OK > Storage > Clear cache and clear data and try again.
If problem persists, we suggest you to try reset network settings and try again and monitor it.
To clear all connection data
1. Find and tap Settings > Network & Internet.
2. Tap the menu button (three vertical dots) > Network settings reset > RESET SETTINGS.
 

ScorpioViking

New member
Dec 14, 2014
3
0
Hi again. Still frustrated with bluetooth glitch on my now Oreo version of Sony Xperia XZ Premium. Somebody mentioned time to contact the lawyers; class action anyone?

Hi again folks. Great news. Sony disappointed me for the last time during their IFA 2018 for not introducing an honest to goodness successor to my Xperia XZ Premium so I finally switched over to Samsung Galaxy & got a great deal on the Note 9, 8gb. ram, 512gb. rom version (SM-N960FZBHNEE model) with my phone carrier Telenor's Swap program. As it's using Ore 8.1 as well as Bluetooth 5.0 all Bluetooth blackouts are a thing of the past on both my Sony SmartBand 2, swr12, as well as my Plantronics Edge. Thus happy days for all you others who have phones with update options equivalencies.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Hello! I got my XZ Premium this Friday, and I got this problem almost right away.

    I have a Huawei Watch connected to my phone, the problem is that Bluetooth on the phone turns itself off quite often. Sometimes it happens after 30 minutes, another time it happens after 2 hours.

    I have to activate Bluetooth on the phone again when it happens, so it's not that the watch is disconnecting by itself.

    Is anyone else having this problem? This might not be specific to the XZ Premium, it might be a bug in Android.

    I have the same problem, it looks like bluetooth got serious issues on Android 7. I have problems with bluetooth song information not being updated on my car radio, so I decided to create a bug report. "Luckily" the bluetooth turned off about 20 sec after I turned it on. So my bug report should contain necessary data to fix this issue, I've sent it over to Sony support.