• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

Bootloader Upgrader Tool [Falcon] [Peregrine] [41.18] [41.19] [41.1A]

Search This thread

xtrs84zk

Senior Member
Oct 5, 2013
216
369
Saltillo
javiersanchez.dev
Introduction

Recently, I have noticed about the multiple new roms that requires the boot 41.18+ and refuses to be installed over the 41.13 one, & that's why I had to "make" this script using various files from google, and other sites, and obviously a keyboard :p
I made a Spanish Version (wich has been tested many times) and now for xda, the english one :D

If you want something like this for another model, just provide correct bootloader, and let me see what can I do :fingers-crossed:

Supported devices:
xt1002, xt1003, xt1008, xt1028, xt1031, xt1032, xt1033, xt1034, xt1039, xt1040, xt1042, xt1045 :victory:
Old downloads | Bootloaders in zip mode.
First of all, you should read post 3 (FAQ) We don't want your device gets bricked ;)


Requisites:
  • -Have the motorola drivers installed.
  • -Usb cable.
  • -For the moment you need to use Windows.
  • -I'll try to get this working on Linux and Mac. Something went wrong :( I got a Mac, trying to make it. :cowboy:


Hope you find it useful. :highfive:
Don't forget to hit thanks if helped you! :good:

XDA:DevDB Information
Bootloader Upgrader Tool, Tool/Utility for the Moto G

Contributors
Xyzko, lost101
Source Code: https://goo.gl/N6Mk47


Version Information
Status: Stable
Current Stable Version: v1.29
Stable Release Date: 2015-12-07
Current Beta Version: ---

Created 2015-05-24
Last Updated 2015-12-12
 
Last edited:

xtrs84zk

Senior Member
Oct 5, 2013
216
369
Saltillo
javiersanchez.dev
Current changelog -- 21/11/2015
[version] -Updated to 1.29.
[new] -Added support for upgrading xt1028 & xt1042 to 41.1A
[fix] -Fixed (or should be fixed) update script for xt1032-41.1A on English.
[fix] -Cleaned more code, more "double hit" deleted.


Old changelogs :)
Old changelog: -- 21/11/2015
[new] -Updated to v.1.22
[new] -Added support for upgrading xt1031 to 41.1A
[new] -Re-added Spanish support.
[fix] -Cleaned code to delete the need of "double hit enter" on some windows version.
[merge] -Now lang selector is again on the script. :)
[up] -Updated screenshots.

Old changelog: -- 11/10/2015
[new] -now using androidfilehost as server due to troubles with xda filesystem.
[new] -merged original and lite version
[new] -deleted spanish support (for now, will come back on the next update)
[new] -now can upgrade to 41.1A also these devices: xt032, xt1033, xt1034.

Old changelog: -- 13/09/2015
[new] -added lite version with only some rare variants.
[new] -added suport for the xt1002, xt1003 & xt1008 variants.
[fixed] -now the script also lets you to select a lang (instead of making two scripts)
[help] -if you wanna contribute with a translate to your lang, send me a PM ;)

Old changelog: -- 19/07/2015
[new] -added suport for the xt1045 variant
[note] -Updated to v1.16a, some lines changed.
[note] -Some lang faults fixed.

old changelog: -- 22/06/2015
[new] -added suport for the xt1039 variant
[new] -added suport for the xt1040 variant
[note] -Updated to v1.12b, ther are the changes ;)

Old changelog: -- 15/05/2015
[new] -redesigned all the scripts in a bigger one with support of xt1032,33 and 34
[new] -added multiple chooser to the script, it let's you to select what to do
[fix] -added some extra lines in the code to make it "safer"
[dev] -you can view the script and suggest, or find bugs here

Old changelog: -- 09/05/2015
[new] -made an specific one for the xt1034 variant

Old changelog: -- 02/05/2015
[new] -made an specific one for the xt1033 variant
[new] -made new script for those who wants the GPE 41.19 one

Old changelog: -- 27/04/2015
[new] translated to english and published on xda

Old changelog: -- 14/04/2015
-initial release.
 
Last edited:

xtrs84zk

Senior Member
Oct 5, 2013
216
369
Saltillo
javiersanchez.dev
Reserved for notes and FAQ.

Important note:
It should be mentioned that flashing an incorrect Bootloader (motoboot.img) could result in an instant hard-brick. Upgrading Bootloader is not something that should be casually done with any motoboot.img.

For safety, each model should have a specific script that includes the correct Bootloader for that model.

And this works only on xt1028, xt1031, xt1032, xt1033, xt1034, xt1039, xt1040, xt1042 xt1045, xt1002, xt1003 & the xt1008 variants. I think those are all variants available, but... however.

For Moto G 4G users
After upgrading, you may lose signal. To fix it, just flash latest radio firmware available here. As always, thanks to @lost101 ;)

For all users
Don't flash random bootloaders on random device, It can gets bricked!

FAQ

Q: Can I flash it on a peregrine (4G)?
A: No. Congratulations, now you can ;)

Q: I got an screen fllickering after updating the bootloader
A: Update your rom and kernel to one using latest sources.

Q: Can I flash it if I already have the 41.18 one?
A: Why are you planing to do it?

Q: Screenshot?
A: 4th post.

Q: Can I flash the xt1032 on a xt1040?
A: See up.

Q: Does the dodo flies?
A: Yeah, it flies if I can fly :v

Q: Can I downgrade from the 41.19 to the 41.18?
A: You can check this

Q: How to know if I have latest bootloader?
A: The chronological order is: 41.05 -> 41.13 -> 41.18 -> 41.19 -> 41.1A. :)
 
Last edited:

xtrs84zk

Senior Member
Oct 5, 2013
216
369
Saltillo
javiersanchez.dev
Screenshots.

Have a look before you try ;)
 

Attachments

  • 1.PNG
    1.PNG
    16.3 KB · Views: 13,353
  • 2.PNG
    2.PNG
    17 KB · Views: 13,081
  • 3.PNG
    3.PNG
    11.4 KB · Views: 12,954
Last edited:

lost101

Inactive Recognized Contributor
May 30, 2008
7,434
9,332
It should be mentioned that flashing an incorrect Bootloader (motoboot.img) could result in an instant hard-brick. Upgrading Bootloader is not something that should be casually done with any motoboot.img.

For safety, each model should have a specific script that includes the correct Bootloader for that model.
 

xtrs84zk

Senior Member
Oct 5, 2013
216
369
Saltillo
javiersanchez.dev
It should be mentioned that flashing an incorrect Bootloader (motoboot.img) could result in an instant hard-brick. Upgrading Bootloader is not something that should be casually done with any motoboot.img.

For safety, each model should have a specific script that includes the correct Bootloader for that model.

At the start of the script it tells you that is only for xt1032 and 33, but thanks, I'll add it to the OP. :)
 
Last edited:
  • Like
Reactions: Rickav and lost101

xtrs84zk

Senior Member
Oct 5, 2013
216
369
Saltillo
javiersanchez.dev
Shouldn't this work on XT1031? The bootloader for it is 41.19

I think no... As lost101 sayid,

It should be mentioned that flashing an incorrect Bootloader (motoboot.img) could result in an instant hard-brick. Upgrading Bootloader is not something that should be casually done with any motoboot.img.

For safety, each model should have a specific script that includes the correct Bootloader for that model.
 
  • Like
Reactions: Rickav

.:Addicted:.

Senior Member
Aug 22, 2014
388
88
Cuttack
addicted.tk
Ya , boot-loader is something that actually flashes files to ROM.

Bootloader makes it possible for chip to communicate through USB.
So if you flash incorrect file then you need to correct that by mannually opening chip & connecting may be through ISB or any other available for ARM processor
 
  • Like
Reactions: xtrs84zk

lost101

Inactive Recognized Contributor
May 30, 2008
7,434
9,332
I know sir, and I don't even plan to flash it

I was just asking
I have not read of any XT1033 user flashing it. I would personally not be comfortable flashing it if I owned an XT1033 - as it is in no way worth the risk.

The v41.19 Bootloader is intended for XT1032 / GPE - and came included with the GPE Android 5.1 Firmware. It appears to be only a very minor upgrade, with no obvious changes. However custom recoveries often need redevelopment to support new Bootloaders.

You flash at your own risk, and if it creates problems with recoveries you are stuck until they can be fixed.

In summary; you should probably only flash a newer Bootloader if absolutely necessary, or face unwanted consequences.
 
Last edited:

sjandroiddeveloper

Senior Member
Jan 16, 2015
912
324
I have not read of any XT1033 user flashing it. I would personally not be comfortable flashing it if I owned an XT1033 - as it is in no way worth the risk.

The v41.19 Bootloader intended for XT1032 / GPE - and came included with the GPE Android 5.1 Firmware. It appears to be only a very minor upgrade, with no obvious changes. However custom recoveries often need redevelopement to support new Bootloaders.

You flash at your own risk, and if it creates problems with recoveries you are stuck until they can be fixed.

In summary, you should probably only flash a newer Bootloader if absolutely necessary, or face unwanted consequences.


Thanks for the heads up, I will not flash it unless necessary

Q- Do you think the non gpe variants will get an official update to 5.1 because then only it may be necessary in the future to upgrade the bootloader (like it was from 41.13 to 41.18 )
 

lost101

Inactive Recognized Contributor
May 30, 2008
7,434
9,332
Q- Do you think the non gpe variants will get an official update to 5.1 because then only it may be necessary in the future to upgrade the bootloader (like it was from 41.13 to 41.18 )
I expect all variants will get 5.1 (more probably 5.1.1) - the GPE 5.1 firmware is essentially what the Stock Motorola ROMs will be. Much of the work is already done.

It's a matter of opinion how necessary upgrading to v41.18 is. I run GPE 5.1 with the v41.13 Bootloader.
 
Last edited:

xtrs84zk

Senior Member
Oct 5, 2013
216
369
Saltillo
javiersanchez.dev
I expect all variants will get 5.1 (more probably 5.1.1) - the GPE 5.1 firmware is essentially what the Stock Motorola ROMs will be. Much of the work is already done.

It's a matter of opinion how necessary upgrading to v41.18 is. I run GPE 5.1 with the v41.13 Bootloader.

Maybe it will be necesary due to custom roms just like was been with the latest cyanogenmod and the Alberto's aosp.
The installer script refuses to be installed over the 41.13, and you need to upgrade it... or change the updater script :p
 

Top Liked Posts

  • There are no posts matching your filters.
  • 149
    Introduction

    Recently, I have noticed about the multiple new roms that requires the boot 41.18+ and refuses to be installed over the 41.13 one, & that's why I had to "make" this script using various files from google, and other sites, and obviously a keyboard :p
    I made a Spanish Version (wich has been tested many times) and now for xda, the english one :D

    If you want something like this for another model, just provide correct bootloader, and let me see what can I do :fingers-crossed:

    Supported devices:
    xt1002, xt1003, xt1008, xt1028, xt1031, xt1032, xt1033, xt1034, xt1039, xt1040, xt1042, xt1045 :victory:
    Old downloads | Bootloaders in zip mode.
    First of all, you should read post 3 (FAQ) We don't want your device gets bricked ;)


    Requisites:
    • -Have the motorola drivers installed.
    • -Usb cable.
    • -For the moment you need to use Windows.
    • -I'll try to get this working on Linux and Mac. Something went wrong :( I got a Mac, trying to make it. :cowboy:


    Hope you find it useful. :highfive:
    Don't forget to hit thanks if helped you! :good:

    XDA:DevDB Information
    Bootloader Upgrader Tool, Tool/Utility for the Moto G

    Contributors
    Xyzko, lost101
    Source Code: https://goo.gl/N6Mk47


    Version Information
    Status: Stable
    Current Stable Version: v1.29
    Stable Release Date: 2015-12-07
    Current Beta Version: ---

    Created 2015-05-24
    Last Updated 2015-12-12
    28
    Reserved for notes and FAQ.

    Important note:
    It should be mentioned that flashing an incorrect Bootloader (motoboot.img) could result in an instant hard-brick. Upgrading Bootloader is not something that should be casually done with any motoboot.img.

    For safety, each model should have a specific script that includes the correct Bootloader for that model.

    And this works only on xt1028, xt1031, xt1032, xt1033, xt1034, xt1039, xt1040, xt1042 xt1045, xt1002, xt1003 & the xt1008 variants. I think those are all variants available, but... however.

    For Moto G 4G users
    After upgrading, you may lose signal. To fix it, just flash latest radio firmware available here. As always, thanks to @lost101 ;)

    For all users
    Don't flash random bootloaders on random device, It can gets bricked!

    FAQ

    Q: Can I flash it on a peregrine (4G)?
    A: No. Congratulations, now you can ;)

    Q: I got an screen fllickering after updating the bootloader
    A: Update your rom and kernel to one using latest sources.

    Q: Can I flash it if I already have the 41.18 one?
    A: Why are you planing to do it?

    Q: Screenshot?
    A: 4th post.

    Q: Can I flash the xt1032 on a xt1040?
    A: See up.

    Q: Does the dodo flies?
    A: Yeah, it flies if I can fly :v

    Q: Can I downgrade from the 41.19 to the 41.18?
    A: You can check this

    Q: How to know if I have latest bootloader?
    A: The chronological order is: 41.05 -> 41.13 -> 41.18 -> 41.19 -> 41.1A. :)
    24
    Current changelog -- 21/11/2015
    [version] -Updated to 1.29.
    [new] -Added support for upgrading xt1028 & xt1042 to 41.1A
    [fix] -Fixed (or should be fixed) update script for xt1032-41.1A on English.
    [fix] -Cleaned more code, more "double hit" deleted.


    Old changelogs :)
    Old changelog: -- 21/11/2015
    [new] -Updated to v.1.22
    [new] -Added support for upgrading xt1031 to 41.1A
    [new] -Re-added Spanish support.
    [fix] -Cleaned code to delete the need of "double hit enter" on some windows version.
    [merge] -Now lang selector is again on the script. :)
    [up] -Updated screenshots.

    Old changelog: -- 11/10/2015
    [new] -now using androidfilehost as server due to troubles with xda filesystem.
    [new] -merged original and lite version
    [new] -deleted spanish support (for now, will come back on the next update)
    [new] -now can upgrade to 41.1A also these devices: xt032, xt1033, xt1034.

    Old changelog: -- 13/09/2015
    [new] -added lite version with only some rare variants.
    [new] -added suport for the xt1002, xt1003 & xt1008 variants.
    [fixed] -now the script also lets you to select a lang (instead of making two scripts)
    [help] -if you wanna contribute with a translate to your lang, send me a PM ;)

    Old changelog: -- 19/07/2015
    [new] -added suport for the xt1045 variant
    [note] -Updated to v1.16a, some lines changed.
    [note] -Some lang faults fixed.

    old changelog: -- 22/06/2015
    [new] -added suport for the xt1039 variant
    [new] -added suport for the xt1040 variant
    [note] -Updated to v1.12b, ther are the changes ;)

    Old changelog: -- 15/05/2015
    [new] -redesigned all the scripts in a bigger one with support of xt1032,33 and 34
    [new] -added multiple chooser to the script, it let's you to select what to do
    [fix] -added some extra lines in the code to make it "safer"
    [dev] -you can view the script and suggest, or find bugs here

    Old changelog: -- 09/05/2015
    [new] -made an specific one for the xt1034 variant

    Old changelog: -- 02/05/2015
    [new] -made an specific one for the xt1033 variant
    [new] -made new script for those who wants the GPE 41.19 one

    Old changelog: -- 27/04/2015
    [new] translated to english and published on xda

    Old changelog: -- 14/04/2015
    -initial release.
    16
    Screenshots.

    Have a look before you try ;)
    5
    Changelog
    Current changelog: -- 22/06/2015
    [new] -added suport for the xt1039 variant
    [new] -added suport for the xt1040 variant

    New 4G support, thanks again to @lost101 :victory:
    You can test it here English, or here Spanish