Bootloop on Lock Screen

Search This thread

xnmb

Senior Member
Jan 1, 2005
90
7
Hello. I hope someone can help.

For no apparent reason my phone (G988B) started to soft restart when it gets to the lock screen after booting . It restarts to the white Samsung logo and repeats the cycle endlessly.

I've done practically everything (wipe and format in TWRP, erase system and userdata in fastboot, erase and re-partition NAND in Odin) yet the problem persists after a clean flash (stock, custom ROM's).

I would like to solicit suggestions for any remaining options that I may have (if any, at all) before hurling my phone on the wall.

Thank you.
 

xnmb

Senior Member
Jan 1, 2005
90
7
Update: Flashing AOSP based ROM's works fine (Lineage OS, GSI). Reverting to Samsung firmware restores the issue. Any hints on what else I should look into?
 

xnmb

Senior Member
Jan 1, 2005
90
7
When you flash the stock firmware, are you using CSC to force a wipe after the flash?

Have you tried booting into recovery when it is bootlooping and factory resetting?

Yes to both. I've done all ways that I know of to wipe all partitions of my device. Same result when flashing Samsung firmware; but works using AOSP based ROM's.

What boggles my mind is that I have erased everything, even the NAND itself yet the problem persists, and that AOSP based ROM's do not have the problem.
 

*Detection*

Senior Member
Dec 5, 2011
10,513
2,859
Durham
Yes to both. I've done all ways that I know of to wipe all partitions of my device. Same result when flashing Samsung firmware; but works using AOSP based ROM's.

What boggles my mind is that I have erased everything, even the NAND itself yet the problem persists, and that AOSP based ROM's do not have the problem.

Yea, I'm trying to work out what stock firmware has that AOSP does not, sounds like 'System' is crashing like it would if you flashed an older firmware over a newer firmware without wiping