• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Bought a new Moto G.. Moto Display unlocks to black screeen, should i return?

Search This thread

reddead66

Senior Member
Feb 10, 2011
950
242
I recieved my Moto g 3rd gen today and after playing with it for a while, i figured out that when i use the 'drag down to unlock' on moto display, the phone unlocks to a black screen...i can feel vibrations when i touch the screen but can't see ****...pressing power multiple times also doesn't work...i have to leave it for a few seconds and then try...Though i can always press the power button instead of draggin down but i am wondering if there are some sensor issues... i have already tried a factory reset... Currently i have switched to ambient display.
Here is the gif of me getting black screen on unlock: https://giphy.com/gifs/aGhfEhP2Mu5bO
Also i bought the phone for the wonderful battery life, but so far it has performance hasn't matched what's being said...does it take a few cycles to give better performance?
I have also faced the infamous wifi issues, where i got disconnected while installing apps..it only happened couple of times though for a few seconds.
I have heard MM update has some issues, is it right?
 

nandakis4

Senior Member
Jan 8, 2014
687
206
30
Rajahmundry
I recieved my Moto g 3rd gen today and after playing with it for a while, i figured out that when i use the 'drag down to unlock' on moto display, the phone unlocks to a black screen...i can feel vibrations when i touch the screen but can't see ****...pressing power multiple times also doesn't work...i have to leave it for a few seconds and then try...Though i can always press the power button instead of draggin down but i am wondering if there are some sensor issues... i have already tried a factory reset... Currently i have switched to ambient display.
Here is the gif of me getting black screen on unlock: https://giphy.com/gifs/aGhfEhP2Mu5bO
Also i bought the phone for the wonderful battery life, but so far it has performance hasn't matched what's being said...does it take a few cycles to give better performance?
I have also faced the infamous wifi issues, where i got disconnected while installing apps..it only happened couple of times though for a few seconds.
I have heard MM update has some issues, is it right?

This is strange, once try Updating your Moto app,my version is 4.1.12 :highfive:
 
  • Like
Reactions: reddead66

rwxr-xr-xis

Senior Member
Apr 9, 2015
396
155
Must be something with buggy OS shipped with your phone, as I usually get 5,6 and sometimes even 7 hours SOT. Try rebooting into bootloader (Press power + volume down) and navigate using the volume buttons to boot to recovery and press power to boot on it, after this press power+volume up until text appears, select wipe cache (it will take a while). Report your results and sorry for my bad english
 
Last edited:
  • Like
Reactions: reddead66

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    I recieved my Moto g 3rd gen today and after playing with it for a while, i figured out that when i use the 'drag down to unlock' on moto display, the phone unlocks to a black screen...i can feel vibrations when i touch the screen but can't see ****...pressing power multiple times also doesn't work...i have to leave it for a few seconds and then try...Though i can always press the power button instead of draggin down but i am wondering if there are some sensor issues... i have already tried a factory reset... Currently i have switched to ambient display.
    Here is the gif of me getting black screen on unlock: https://giphy.com/gifs/aGhfEhP2Mu5bO
    Also i bought the phone for the wonderful battery life, but so far it has performance hasn't matched what's being said...does it take a few cycles to give better performance?
    I have also faced the infamous wifi issues, where i got disconnected while installing apps..it only happened couple of times though for a few seconds.
    I have heard MM update has some issues, is it right?

    This is strange, once try Updating your Moto app,my version is 4.1.12 :highfive:
    1
    View attachment Moto.apk Moto APK
    View attachment MotoActions.apk Moto Actions Apk
    View attachment MotoDisplay_3.0.apk Moto Display Apk
    View attachment MotoDisplay_FWProxy_3.0.apk Moto Display FW proxy apk

    These are the ones which i have on my phone ( Andrd 6.0 ) try installing these to your phone, if updating your moto Apps doesnt work :highfive:
    1
    Must be something with buggy OS shipped with your phone, as I usually get 5,6 and sometimes even 7 hours SOT. Try rebooting into bootloader (Press power + volume down) and navigate using the volume buttons to boot to recovery and press power to boot on it, after this press power+volume up until text appears, select wipe cache (it will take a while). Report your results and sorry for my bad english