• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Brainstorming: how to completely disable DataTracker-FD and Fast Dormancy

Search This thread

metalboy94

Senior Member
May 12, 2011
680
170
Bucharest
Being fed up with the random wakelocks that Dialer produced on my Gingerbread P500, I spent a while searching for the cause. It turned out to be DataTracker-FD (found out using the amazing BetterBatteryStats app - http://www.cri.ch/sven/doku.php/computing/android/betterbatterystats ), which deals with Fast Dormancy (http://www.computerworld.com/s/article/9191759/Fast_dormancy_to_improve_smartphone_networking_and_battery_performance_ ).

Now, in theory, Fast Dormancy should be a great feature! But, if your network does not support it, DataTracker-FD will still drain a lot of battery through the wakelock. The SGSII secret code for deactivating it doesn't work on the P500, and neither does the nwk_info.db method. Luckily, you can deactivate (or change its timeout) through the LG hidden menu...

1. Dial 3845#*500#.
2. Go to Modem Setting > PDP Setting > [0] Set Fast Dormancy
3. Select your desired timeout (or "Disabled"). You should now be done! (will look at Battery Usage in a little bit, to see if a reboot/Dialer FC is also needed)
Optional step 4. If you still see no difference, set your desired timeout (or "Disabled") a few more times.

Hope it helps. :)


/* Edit: It doesn't seem to help, we might be back to square one. :( Does anyone have any idea on how to completely disable Fast Dormancy? We might need a dev to look at the source code of Dialer and make some modifications... Right now, if your phone stays awake after using Data, the only current workaround is FCing Dialer from Applications. :rolleyes: */

EDIT 2: A SECOND TEST, USING THE ABOVE METHOD TO DISABLE FAST DORMANCY, YIELDS POSITIVE RESULTS! THE WAKELOCK IS NOT THERE ANYMORE, EVEN AFTER SEVERAL RECONNECTIONS TO HSDPA!

It needs way more testing though, I will reconnect to data and leave the phone idle (screen off), then see what happens, and I will reboot the phone to see if the setting persists.

EDIT 3: Yes, the setting persists, and the wakelock is still not running! The final test will be done after it has completely charged, because there still is a small possibility that the wakelock is so far not active just because the phone was charging. :rolleyes:


Edit 4: Straight after unplugging the phone, DataTracker-FD started running, without being connected to HSDPA (I was in a phonecall). In 17 minutes (of mostly talking on the phone) it drained 1% of the battery - so, it should last for about 29 hours with the same usage. Now I have started HSDPA and left the phone idle for 10 minutes, to see how much it drains and how much it drains after I turn data off. It just might be that, while the phone is still awake, it doesn't drain a large amount of battery. If it actually still drains a lot, this tweak definitely only /seems/ to work while charging (maybe BetterBatteryStats was reporting false data or FD just doesnt' work when charging).

Edit 5: Here's a pleasant surprise. Right after connecting to HSDPA and putting the phone to sleep, the Awake bar in Battery Usage faded out. In 5 minutes of idling with data activated, the phone drained another 1% battery - not sure how well that is, since it amounts to 8 hours of data on a full charge, but it's better than 12 hours of idling with no data on a full charge. :rolleyes: Currently repeating the test. Just got an email on Yahoo pushed, I'll get to see the influence on awake time of that as well.

Edit 6: After 10 minutes of idling with data ON, a bit over 1% of the battery is gone. This is a fantastic value, and the Awake bar is only dotted in this period of time. DataTracker-FD seems to be running a bit in the background during the data connection, but stopped once I turned it off. It might just be me, though, because aLogCat still can't find any entries for Fast Dormancy. Now leaving the phone idle with no data for a while to look at the evolution of Awake time.


Edit 7: After about 45 minutes of complete idling, the battery went down 2%. This would mean the battery would last for about a day and a half, which is meh, considering I OC'd the phone to 730 and don't really use a task manager.

The conclusion: YES, disabling Fast Dormancy does work using the above method, and it does help battery life!


Edit 8: After another unrelated reboot, DataTracker-FD is once again awake after using data, but this time it draws significantly less battery. The Battery Usage graph shows no difference between sleep times and awake-because-of-FD times.

Edit 9: During the night, the phone drained 30% battery, once again because of some random action of DataTracker-FD. This is still not a definite fix. :mad:
 
Last edited:

droidaem

Senior Member
Feb 6, 2011
291
42
Riga
"Connection problem or invalid MMI code" when I dial that number..
I remember that long ago I dialed the number and everything was fine.
 

masteryx

Senior Member
Jan 5, 2011
593
280
Bucharest
Xiaomi Mi 10T / 10T Pro
Considering I am still on Froyo v2.2.2, could this be of interest for me too? There's no abnormal battery drain on my phone, but if I can improve the battery life by tweaking this setting, I'd gladly do it.
 

metalboy94

Senior Member
May 12, 2011
680
170
Bucharest
Considering I am still on Froyo v2.2.2, could this be of interest for me too? There's no abnormal battery drain on my phone, but if I can improve the battery life by tweaking this setting, I'd gladly do it.

I didn't have such problems on Froyo either. It MIGHT help, but as you can see from the numerous edits to the OP, it's not a clear win yet.
 

Roqu3

Senior Member
May 9, 2011
256
186
So it need to be disabled twice to stop working?

I've been looking for this service since using that Battery App but theres not much information of that in the web.
 

metalboy94

Senior Member
May 12, 2011
680
170
Bucharest
I'm not sure just how many times, but it took about 3-4 times for me until I was completely sure the wakelock stopped running and the phone went into deep sleep each time I locked it. :confused:
 

Roqu3

Senior Member
May 9, 2011
256
186
Yeah I think I got it doing it twice, FC phone and rebooting, btw maybe you can check system/etc/flex/flex.db and flex.xml there are fast dormancy settings there
 

atulalvenkar

Senior Member
Mar 8, 2011
1,029
364
Hyderabad
@metalboy94 I mailed LG regarding Fast Dormancy and the reply i got was that P500 does not support fast dormancy. My phone does not switch from H to 3G. I tried enabling it many times using secret menu but it does not work.

I asked him if GB ROM/Baseband supports fast dormancy, he replied saying GB hasn't been released for India :(
 
Last edited:

metalboy94

Senior Member
May 12, 2011
680
170
Bucharest
Yeah I think I got it doing it twice, FC phone and rebooting, btw maybe you can check system/etc/flex/flex.db and flex.xml there are fast dormancy settings there

There are? Thanks a bunch, gonna try those methods as well!

@atulalvenkar: Well, it still draws power from the battery, so at least they could have done something to the Dialer if it's not supported at all. :rolleyes:


Edited the OP once again.
 

Roqu3

Senior Member
May 9, 2011
256
186
Stock GB. I found it, but you have to fill in the info for your operator if it's not on that list. Guess which is my situation.

Yeah my operator isn´t there also (I´m on a custom V20g ROM and I´m not from Romania) but i got the flex files from the Froyo stock so im going to try using that information to replace one of the V20g operators.

Also tried putting the Froyo ones on GB but get a lot of FC
 
Last edited:

tsuda

Senior Member
Mar 24, 2011
193
35
Toronto
LG G Pad X 8.0
I tried to change the FD settings in the hidden menu, but the setting does not "stick", so I don't know if it's actually OFF or not.

However, I found that DataTracker-FD only keeps the phone awake when Wifi is on. If I'm always on 3G, FD seems to work and keep the phone asleep. Overnight with wifi off and 3G on, it only drained 2% battery.

I'm on official GB2.3.3 with PaoloM's kernel v5.

Strange.
 

Roqu3

Senior Member
May 9, 2011
256
186
hey maybe let´s try this:
Code:
ro.ril.disable.fd.plmn.prefix=23402,23410,23411,
have to put that on the build.prop then restart, the values must be changed to your carriers code, you can get that code from adb typing

Code:
adb shell
getprop gsm.operator.numeric
Then the system should show the number
 

metalboy94

Senior Member
May 12, 2011
680
170
Bucharest
I tried to change the FD settings in the hidden menu, but the setting does not "stick", so I don't know if it's actually OFF or not.

However, I found that DataTracker-FD only keeps the phone awake when Wifi is on. If I'm always on 3G, FD seems to work and keep the phone asleep. Overnight with wifi off and 3G on, it only drained 2% battery.

I'm on official GB2.3.3 with PaoloM's kernel v5.

Strange.

But did you see how many MBs the phone used? Cause if it's too much, people will definitely prefer just turning the phone off.


@Roqu3: I think I tried that before and it didn't seem to make a difference.
Worth a shot tho.

I'll try both of your methods if I still have the issue when I get my phone back from the service center.


Sent from a crappy rebranded Huawei using my hands
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 5
    Being fed up with the random wakelocks that Dialer produced on my Gingerbread P500, I spent a while searching for the cause. It turned out to be DataTracker-FD (found out using the amazing BetterBatteryStats app - http://www.cri.ch/sven/doku.php/computing/android/betterbatterystats ), which deals with Fast Dormancy (http://www.computerworld.com/s/article/9191759/Fast_dormancy_to_improve_smartphone_networking_and_battery_performance_ ).

    Now, in theory, Fast Dormancy should be a great feature! But, if your network does not support it, DataTracker-FD will still drain a lot of battery through the wakelock. The SGSII secret code for deactivating it doesn't work on the P500, and neither does the nwk_info.db method. Luckily, you can deactivate (or change its timeout) through the LG hidden menu...

    1. Dial 3845#*500#.
    2. Go to Modem Setting > PDP Setting > [0] Set Fast Dormancy
    3. Select your desired timeout (or "Disabled"). You should now be done! (will look at Battery Usage in a little bit, to see if a reboot/Dialer FC is also needed)
    Optional step 4. If you still see no difference, set your desired timeout (or "Disabled") a few more times.

    Hope it helps. :)


    /* Edit: It doesn't seem to help, we might be back to square one. :( Does anyone have any idea on how to completely disable Fast Dormancy? We might need a dev to look at the source code of Dialer and make some modifications... Right now, if your phone stays awake after using Data, the only current workaround is FCing Dialer from Applications. :rolleyes: */

    EDIT 2: A SECOND TEST, USING THE ABOVE METHOD TO DISABLE FAST DORMANCY, YIELDS POSITIVE RESULTS! THE WAKELOCK IS NOT THERE ANYMORE, EVEN AFTER SEVERAL RECONNECTIONS TO HSDPA!

    It needs way more testing though, I will reconnect to data and leave the phone idle (screen off), then see what happens, and I will reboot the phone to see if the setting persists.

    EDIT 3: Yes, the setting persists, and the wakelock is still not running! The final test will be done after it has completely charged, because there still is a small possibility that the wakelock is so far not active just because the phone was charging. :rolleyes:


    Edit 4: Straight after unplugging the phone, DataTracker-FD started running, without being connected to HSDPA (I was in a phonecall). In 17 minutes (of mostly talking on the phone) it drained 1% of the battery - so, it should last for about 29 hours with the same usage. Now I have started HSDPA and left the phone idle for 10 minutes, to see how much it drains and how much it drains after I turn data off. It just might be that, while the phone is still awake, it doesn't drain a large amount of battery. If it actually still drains a lot, this tweak definitely only /seems/ to work while charging (maybe BetterBatteryStats was reporting false data or FD just doesnt' work when charging).

    Edit 5: Here's a pleasant surprise. Right after connecting to HSDPA and putting the phone to sleep, the Awake bar in Battery Usage faded out. In 5 minutes of idling with data activated, the phone drained another 1% battery - not sure how well that is, since it amounts to 8 hours of data on a full charge, but it's better than 12 hours of idling with no data on a full charge. :rolleyes: Currently repeating the test. Just got an email on Yahoo pushed, I'll get to see the influence on awake time of that as well.

    Edit 6: After 10 minutes of idling with data ON, a bit over 1% of the battery is gone. This is a fantastic value, and the Awake bar is only dotted in this period of time. DataTracker-FD seems to be running a bit in the background during the data connection, but stopped once I turned it off. It might just be me, though, because aLogCat still can't find any entries for Fast Dormancy. Now leaving the phone idle with no data for a while to look at the evolution of Awake time.


    Edit 7: After about 45 minutes of complete idling, the battery went down 2%. This would mean the battery would last for about a day and a half, which is meh, considering I OC'd the phone to 730 and don't really use a task manager.

    The conclusion: YES, disabling Fast Dormancy does work using the above method, and it does help battery life!


    Edit 8: After another unrelated reboot, DataTracker-FD is once again awake after using data, but this time it draws significantly less battery. The Battery Usage graph shows no difference between sleep times and awake-because-of-FD times.

    Edit 9: During the night, the phone drained 30% battery, once again because of some random action of DataTracker-FD. This is still not a definite fix. :mad:
    3
    Hi, I resurrect this thread just to share a workaround I made to keep controlled the DataTracker-FD process.

    I've been using APNDROID and it works but I really dont like to use apps to patch system issues, so i made a service that runs a script every time the data connection is turned off, the script kills the phone.apk and stops DataTracker-FD, the phone app then restarts but DataTracker-FD keeps stopped.

    So first you need to open your boot.img and on your init.rc or on the init.thunderg.rc put this at the end of the file:

    Code:
    # DataTracker-FD workaround by RoQ
    service dtfix /system/bin/dtfix
       disabled
       oneshot
    
    on property:gsm.defaultpdpcontext.active=false
       start dtfix

    This creates a service that executes a script every time when data connection is turned off

    Then we need the script, just create a file with the name "dtfix" on system/bin/ and give it full permissions, inside the file put this:

    Code:
    #!/system/bin/sh
    # Kills phone.apk and stops DataTracker-FD
    
    PHONEKILL="$(ps | grep com.android.phone | awk '{print $2}')"
    
    kill $PHONEKILL

    And thats it, now every time when you turn data off, the service will kill the phone app and with that stops DataTracker-FD, the phone app will restart automatically so you just will see your phone without signal for a few seconds
    2
    hello, i was just been banned from an italian forum after, togheter to other user, we found a way to stop datatracker-FD :) I was banned becouse before we found the way,forum moderator sayd that found a way was impossible and the problem wa snot really a problem because android must be ever connected....

    Ok solution is this, left data on from top menu, but using application "APNDROID" to get them on or off! you can see with betterbatterystats that datatracker is not active in this way (after get data off by apndroid) and phone can now go in deep sleep without battery drain! :)

    this is a work around, I hope to found a solution to disable datatracker definitively using defult android button to disable data :)

    oh just another think, the italian forum moderators that banned me for this discovery are crime and tecnhofab...nice...good to see that men who make custom rom have a so close mentality! hello to everybody and i hope to be useful!
    1
    [!QUOTE=Layio;16110918]FastDormancy not want to shut down permanently. There is always re-activated when the connection with 3G/HSDPA is on. The worst thing is that when data is off, FastDormancy is still running and does not allow the phone to go to sleep. See my screenshots. In 1,5 hour I get down 5%, and phone was still awake, but data was off.

    Is this bug in Gingerbread? In froyo I don't remember that draining battery problem with 3G. On 2G everythink is ok. This makes it practically impossible to use the phone in 3G.[/QUOTE]

    Yeah sometimes is completely off and sometimes not, i think maybe we need to edit the flex.db because the hidden menu reads from there
    , but with that prop stting is off at boot
    1
    this bug is still present in latest v20C indian rom. dont know how to get rid of this bug :(