Search This thread

Sal_1616

New member
Jul 23, 2019
1
0
So I had a OnePlus 5 laying around and decided to flash pixel experience with twrp and everything was fine until I decided to update ota. Then it took me to twrp but it wouldnt let me do anything. It was just stuck in the loading screen. So I managed to reflash twrp and got it working again with factory reset but then whenever I went into twrp it never asked for a password even tho I had one. I also tried backing up but it kept failing so I took a chance and saw a video on how to flash derpfest so I wouldn't have to deal with its problems again and so I followed the instructions and downloaded the ROM to the device and wiped everything except the internal storage and USB storage so I could flash the ROM but when I attempted to flash the ROM it wasn't there. I just had a bunch of files with different names and so I attempted to adb sideload oxygen os and it looked like it worked but when I was about to reboot it said there was no os even tho I flashed it so I took a chance and rebooted. Now I have no os recovery or bootloader and I keep getting a bootloop with the OnePlus logo. Am I screwed and if anyone can plz help
 

JonasHS

Senior Member
Oct 15, 2020
53
4
21
Your device does not fail anything, it just needs some more software. Follow my guide and your device is fixed in 10 minutes. Download the drivers on your pc. If you do not know how to do then open readme file. Run MSM some admin and set settings currect. Connect your phone to PC with USB. Press power and vol - an vol + buttons on same time. Look on PC new device registered. It's normal your phone 📱 s screen is black. Start MSM and select download mode and unbrick tool. Wait long time and your phone os is reinstalled. Official OnePlus tool.

Msm + Driver link:

I have compressed driver and MSM to gz file, for faster download and upload. Use 7zip file manager to open gz file.




Bad English Google translate.
 

Gaukler_Faun

Senior Member
Aug 10, 2012
698
1,434
Germany
github.com
Try to reflash recovery via fastboot. Then reboot in recovery. Connect device to your PC. If the device is not shown on your PC, enable mtp in recovery settings. Copy your ZIP-file to flash to your phone. Install it from recovery, reboot.

The important thing is to get a working recovery. If you can boot in a recovery, your phone is still working.