• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[Bricked] LG G3 Rogers D852

Search This thread

FlashFlush

Member
Jan 13, 2016
5
0
I really need help. I've searched around all over the web and on here with no solution. What happened was I tried to downgrade my G3 to stock 4.4.2 KitKat from 5.0.1 Lollipop. The flash tool went all the way to 89% and failed. I took out the battery and now my phone just boot to the Android recovery after the LG logo. When I try to use Flashtool to flash it again, my IMEI and S/N show as null and flash tool fails at 6%. I can't find a solution. I'm able to go into download mode and recovery which the recovery mode only has wipe data to factory.
I'm running Windows 7-64bit. I've tried different Windows version and 32 bit version and none works. I've sent it to a store and they thought they could fix it because they say it is software issues. They couldn't fix it.
I try downloading different Roms variant and .KDZ and .ToT files but nothing works. I've tried both upgrade dl and board dl in Flashtool but nothing works. I've used the D852 DLL, the generic DlL and even the DLL extracted from the .KDZ file.
Please somone help me. There are people with the same issues and either they got it fix or their thread end unsolved. What can I do.
 
Last edited: