Bricked my phone

Search This thread

coolbho3000

Retired Senior Recognized Developer
Dec 26, 2008
899
784
I just bricked my G1. Tried to use nandroid backup back into rc33, but I did something wrong and now it wont' even boot to HSPL. Here's shell code:

PS D:\android\tools> fastboot devices
HTXXXXXXXXXXXX fastboot
PS D:\android\tools> fastboot flash system system.img
sending 'system' (69850 KB)... FAILED (data transfer failure (Too many links))

then I tried it with another (the default extUSB) USB cable:

PS D:\android\tools> fastboot flash system system.img
< waiting for device >
sending 'system' (69850 KB)... OKAY
writing 'system'... OKAY
PS D:\android\tools> fastboot flash userdata data.img
sending 'userdata' (28924 KB)... OKAY
writing 'userdata'... OKAY
PS D:\android\tools> fastboot flash splash1 splash1.img
sending 'splash1' (300 KB)... OKAY
writing 'splash1'... OKAY
PS D:\android\tools> fastboot flash splash2 splash2.img
sending 'splash2' (300 KB)... OKAY
writing 'splash2'... OKAY
PS D:\android\tools>

Stuck on HTC Magic screen... help would be appreciated.

EDIT: Took battery out... now works into HSPL... was already looking to eBay, I see G1 prices have risen... now please help me flash this baby properly, thanks. I have a NANDROID backup. Which .img files to flash? And why did this one fail? :)

So relieved. Rofl, you should have seen look on my face when I booted up with Camera+Power and it just kept going...

Edit: find my problem... forgot boot.img. :p
 
Last edited:

coolbho3000

Retired Senior Recognized Developer
Dec 26, 2008
899
784
Yeah, I forgot to restore boot.img... and the phone wouldn't boot, not even into Fastboot anymore, until the battery was removed.

I wanted splash1 and splash2 flashed too as I wanted my custom boot image back. :D