• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Bricked Realme X2 Pro (Still have TWRP and Fastboot)

Search This thread

natedogg20050

Senior Member
Aug 19, 2009
301
72
I was trying to flash the Ozip to restore the stock rom using TWRP and after that boom

damaged boot/recovery that msg

i still can go inside twrp and the fastboot mode

what i did notice is that the file folder name changed to system_root and it was just system bevor

is there any fix for it i am using the CN Version
 

natedogg20050

Senior Member
Aug 19, 2009
301
72
(how-to unbrick your realme device) fastboot needed fix inside.

I Went totally nuts last night when i bricked my phone so i did figure out my self how to unblock the phone.


First you need to BE ABLE TO ENTER FASTBOOT it won't work without it and you need working TWRP.

First you need to go to TWRP and go to mount and unmount everything and disable MTP.

Then go to Advanced and select Terminal

type in LS make sure there is 2 Folders one called system and one called system_root

make sure that the system folder is empty if empty type in rm -r system

and rename the system_root folder to system using mv system_root system

after that boot into Fastboot mode and Flash your Rom for your Device using the Fastboot Tool

Hope that works for you guys.
 
Last edited by a moderator:

hack-os

Senior Member
Feb 3, 2018
73
31
Samsung Galaxy S5
OnePlus One
What to do when 2 Folders one called system and one called system_root are missing? cant access data in MTP when in TWRP from PC to send the rom file.

I Went totally nuts last night when i bricked my phone so i did figure out my self how to unblock the phone.


First you need to BE ABLE TO ENTER FASTBOOT it won't work without it and you need working TWRP.

First you need to go to TWRP and go to mount and unmount everything and disable MTP.

Then go to Advanced and select Terminal

type in LS make sure there is 2 Folders one called system and one called system_root

make sure that the system folder is empty if empty type in rm -r system

and rename the system_root folder to system using mv system_root system

after that boot into Fastboot mode and Flash your Rom for your Device using the Fastboot Tool

Hope that works for you guys.
 

jhha

Senior Member
Aug 7, 2009
134
20
Matara
Solved.! (For me) CN

I unlocked the bootloader according to the guide [Guide] Guides for x2 Pro[Locking/unlocking bootloader, tweaks and more]. And flashed TWRP successfully. MY MAIN MISTAKE -> DIDN'T MAKE A BACKUP AT THIS POINT. :mad:
Then I flash canary debug magisk and open gapps micro (culprit for brick). Then tried to reboot but stuck in yellow Realme screen. Then went back to recovery tried "Facrory reset", "Format data", flash latest CN ozip, even fastboot flash and guide by natedogg20050 with no luck. But Lineage OS unofficial by karthick mostwanted worked with magisk 20.3. :good:
For one final time I tried to get back the stock(since Lineage is still in alpha ATM), after seeing this post by exadeci. Did a "format data" following fastboot flash with chinese images, SUCCESS...!!! :victory: And even updated with ozips from CN site worked.. Finger print works too. :D
Still in update process to latest .15 . Plan to install magisk.(hopefully canary debug).
Will update this after latest upgrade + magisk install. ;):)
 

md.atheeqh

Member
Mar 29, 2020
7
2
don't worry we can

first reboot to recovery
then go to wipe
and wipe sytem,catche,davik catche and data
then download the stock os for realme software
download link(please select your mobile) in realme software website
and flash the recovery
wipe catche and data
and you are back to stock os
enjoy;)
 

newpassion

Member
Oct 24, 2015
39
6
Italy
I Went totally nuts last night when i bricked my phone so i did figure out my self how to unblock the phone.


First you need to BE ABLE TO ENTER FASTBOOT it won't work without it and you need working TWRP.

First you need to go to TWRP and go to mount and unmount everything and disable MTP.

Then go to Advanced and select Terminal

type in LS make sure there is 2 Folders one called system and one called system_root

make sure that the system folder is empty if empty type in rm -r system

and rename the system_root folder to system using mv system_root system

after that boot into Fastboot mode and Flash your Rom for your Device using the Fastboot Tool

Hope that works for you guys.

after do that my phone boot only in TWRP but i can't see anything.
if I connect the phone to the computer it is empty and if I want to transfer something on it gives me an error.
can you help me ?


SOLVED: i formatted by TWRP.
 
Last edited:

Sir Backe

Senior Member
Apr 14, 2012
155
22
When I type LS in terminal it gives a long list. There is a "system" and a "system_root".
When I try to open "system" with cd system command, it says, no such file or directory. When I enter "cd system_root" it goes into this Folder. But using "ls" command within this Folder it just shows nothing. Am I doing something wrong?


Any idea?

P.S. Yes I can enter fastboot, and TWRP is working.

I Went totally nuts last night when i bricked my phone so i did figure out my self how to unblock the phone.


First you need to BE ABLE TO ENTER FASTBOOT it won't work without it and you need working TWRP.

First you need to go to TWRP and go to mount and unmount everything and disable MTP.

Then go to Advanced and select Terminal

type in LS make sure there is 2 Folders one called system and one called system_root

make sure that the system folder is empty if empty type in rm -r system

and rename the system_root folder to system using mv system_root system

after that boot into Fastboot mode and Flash your Rom for your Device using the Fastboot Tool

Hope that works for you guys.
 
Last edited:

natedogg20050

Senior Member
Aug 19, 2009
301
72
When I type LS in terminal it gives a long list. There is a "system" and a "system_root".
When I try to open "system" with cd system command, it says, no such file or directory. When I enter "cd system_root" it goes into this Folder. But using "ls" command within this Folder it just shows nothing. Am I doing something wrong?


Any idea?

P.S. Yes I can enter fastboot, and TWRP is working.

did you figure it out ?
 

Sir Backe

Senior Member
Apr 14, 2012
155
22
did you figure it out ?

Thanks for asking! Yes, I did, but in a different way. It was a long way, running from stuck in yellow realme boot logo to bootloops already on the white realme start logo. Finally I got back a running system, which I don't trust anymore now. My configuration is:

- unlocked bootloader
- TWRP 3.3.1.13
- Magisk canary debug 8ca5a048 (20405)
- Magis Manager 72f6770d (278)
- Andorid 10, C24

I was already at this point 2 days ago. Then Magisk Manager announced an update. Stupid as I am, I just klicked install, and arrived at the same point. Stuck in yellow boot logo, and the whole operation started from beginning. Now I am at the same point again as above, and Magisk Manager announces again an update for itself. But I don't trust it anymore, and I don't know what to do. Just leave it? Or making a nandroid backup first? But will it be sufficiant to backup boot partition, system image and data when the crash comes again? I don't know what to do.
 

Top Liked Posts