• XDA Forums have been migrated to XenForo. To discuss, report bugs and other issues, use this thread.

Bromite magisk module

jacomail95

New member
Nov 11, 2012
899
386
0
25
Fondi, LT
Since the download is big and not always internet is stable, can you restructure the module the way osm0sis did with his Adreno Drivers Installer? So we download Bromite webview on our own and the module simply will install it through magisk, the module itself would be extremely smaller. Plus you would be free of the worry of updating the webview to follow original Bromite updates. Think about it, it's just an idea, but I think it's solid. Thank you for the effort put in the module :)

Inviato dal mio Nexus 6 utilizzando Tapatalk
 
Last edited:

problemathic

New member
Jan 14, 2018
290
94
0
Naval
last module is totally working great and got rid of stock webview and replaced by only bromite webiew but the latest update breaks it! why during installation need to download required files? in my case after it prompts "downloading required files" and succesfully flashed in magisk then after bromite webview implementation in developer option is empty!!!

-i think you did this because someone says module is too big and sometime internet not stable but please its not a good idea! i even go to computer shop just to download anything s**ts! please return it like the previous version. last version works great

---------- Post added at 05:12 AM ---------- Previous post was at 05:04 AM ----------

The latest update breaks the functionality of the module! why during installion of magisk it needs to download required files! after updating i checked on developer option and now its empty! reverted back to old version and now im back with bromite webview! personally for me i dont care if the given zip is big as long as it works. please revert the module just like before
 
Last edited:

DvineLord

New member
Aug 29, 2010
1,387
386
0
i installed v3.0 it downloaded the files but the log shows an issue with the webview folder so it couldn't the copy files.
 
Last edited:

clcombs262

New member
Oct 16, 2018
256
144
0
Monticello
We're excited to be releasing version 3.1

Sorry for the massive bug introduced in v3.0 but 3.1 is confirmed working on AOSP, RR, LOS, and OOS (needs testing). For some reason, appropriate directory was not getting copied over

Changelog:
  • Fixed installer and boot scripts (finally!)
  • Reduced file size by downloading external resources separate
  • Attempt to support more webview installation scenarios
 
Last edited:

clcombs262

New member
Oct 16, 2018
256
144
0
Monticello
last module is totally working great and got rid of stock webview and replaced by only bromite webiew but the latest update breaks it! why during installation need to download required files? in my case after it prompts "downloading required files" and succesfully flashed in magisk then after bromite webview implementation in developer option is empty!!!

-i think you did this because someone says module is too big and sometime internet not stable but please its not a good idea! i even go to computer shop just to download anything s**ts! please return it like the previous version. last version works great

---------- Post added at 05:12 AM ---------- Previous post was at 05:04 AM ----------

The latest update breaks the functionality of the module! why during installion of magisk it needs to download required files! after updating i checked on developer option and now its empty! reverted back to old version and now im back with bromite webview! personally for me i dont care if the given zip is big as long as it works. please revert the module just like before
Please check version 3.1

Unfortunately I do not recommend sticking with v2.1.1 (last fully offline flashable release) as it is missing several important script fixes
 

clcombs262

New member
Oct 16, 2018
256
144
0
Monticello
Anyway I have to uinstall it because I couldn't open Gmail and other apps behaved bad, i.e exit itself.

Waited few days, rebooted but nothing worked.

Device: 1+5, Magisk, Twrp, Oxygen Os Latest
On older versions OOS was a known issue due to odd folder naming

Please try v3.1; it's only had minimal testing with OOS

Sent from my Moto Z3 Play using XDA Labs
 

DvineLord

New member
Aug 29, 2010
1,387
386
0
i installed v3.1 chrome webview is gone and it shows aosp webview only so i used root explorer to check filesize and it seems to be the bromite webview size. i think bromite webview is conflicting with aosp webview and aosp browser.

i could see this getting endorsement from bromite devs if u can knockout some of the kinks.
 
Last edited:

problemathic

New member
Jan 14, 2018
290
94
0
Naval
Please check version 3.1

Unfortunately I do not recommend sticking with v2.1.1 (last fully offline flashable release) as it is missing several important script fixes
but bromite webview is on developer option? can we get other option to have offline installation! but great work. subscribed! will watch your project :good:
 

kos25k

Well-known member
Nov 15, 2012
3,066
425
83
hello.i have installed bromite both in my Xiaomi RN5 stock Miui & RN4 with custom Pie rom, but when i test it according this video https://youtu.be/vrs3NEsxA0w but weird thing is that sometimes it works,but most times it don't.is there anything more i need to do?
 

clcombs262

New member
Oct 16, 2018
256
144
0
Monticello
i installed v3.1 chrome webview is gone and it shows aosp webview only so i used root explorer to check filesize and it seems to be the bromite webview size. i think bromite webview is conflicting with aosp webview and aosp browser.

i could see this getting endorsement from bromite devs if u can knockout some of the kinks.
For some strange reason on some ROMs even with a successful installation of the module it thinks it still has AOSP webview

Unfortunately the actual problem is unknown currently so there is no solution

Sent from my Moto Z3 Play using XDA Labs
 
  • Like
Reactions: DvineLord

DvineLord

New member
Aug 29, 2010
1,387
386
0
should i wait for another release or remove aosp webview? not sure how to do it cleanly (ie libs and other files other then the apk)!? i was trying to see if opengapps had a keyword to remove it but didn't see one.

edit: i think ill wipe dalvik cache first.
 
Last edited:

kenny.lam

New member
Dec 19, 2014
116
37
0
Hello, after install this module, open Facebook and click a link, I still see this link is opened by the Facebook mobile browser, how can I replace that by Bromite in app browser ?