• XDA Forums have been migrated to XenForo. To discuss, report bugs and other issues, use this thread.

Bromite magisk module

hurray

New member
Oct 25, 2010
624
266
0
I have tested the newest version 3.1 on my Samsung Galaxy TabS2 under LOS 15.1 and it works good. :)

On my Oneplus 6 (still on OOS 5.1.11 due to compatibility reasons) it installs and is listed as "Bromite System WebView" under apps but I can't choose it under Settings - Developer options - WebView implementation: the list is complete empty.

Is there a way to test if the bromite webview is currently running and in use?
 

Revenant Ghost

New member
Jun 24, 2012
435
243
0
I have tested the newest version 3.1 on my Samsung Galaxy TabS2 under LOS 15.1 and it works good. :)

On my Oneplus 6 (still on OOS 5.1.11 due to compatibility reasons) it installs and is listed as "Bromite System WebView" under apps but I can't choose it under Settings - Developer options - WebView implementation: the list is complete empty.

Is there a way to test if the bromite webview is currently running and in use?
On my OnePlus 5 running OB33, I'm having the same issue here.
@clcombs262, could you investigate this? Thanks.

And AFAIK, Gmail and the Google app itself rely on WebView or they'll crash. No problems there, though.
 
Last edited:

clcombs262

New member
Oct 16, 2018
256
144
0
Monticello
On my OnePlus 5 running OB33, I'm having the same issue here.
@clcombs262, could you investigate this? Thanks.

And AFAIK, Gmail and the Google app itself rely on WebView or they'll crash. No problems there, though.
Known issue on OOS

They seem to block using non Google webview in framework-res.apk so absolutely nothing to be done right now

To override that, the module would have to grab framework-res, decompile, edit, recompile and sign that app and God knows what that could screw up if done even slightly wrong

Sent from my Moto Z3 Play using XDA Labs
 
  • Like
Reactions: Revenant Ghost

nikerossxp

New member
Sep 16, 2006
95
12
0
Moscow
with this module, many apps gonna crash or won't work.




How to completely remove this? After uninstall module, my webview still is bromite and reinstalls after reboot.
 
  • Like
Reactions: iR3kT

kenny.lam

New member
Dec 19, 2014
116
37
0
You'll need to remove updates to bromite webview or AOSP webview

Sent from my Moto Z3 Play using XDA Labs
Same question, please say clear about that way, how can I "remove updates to bromite webview or AOSP webview" ?? I already removed that module in Magisk but it still stay in developer option / webview

By the way, please answer my question:
"Hello, after install this module, open Facebook and click a link, I still see this link is opened by the Facebook mobile browser, how can I replace that by Bromite in app browser ?"
 

clcombs262

New member
Oct 16, 2018
256
144
0
Monticello
Same question, please say clear about that way, how can I "remove updates to bromite webview or AOSP webview" ?? I already removed that module in Magisk but it still stay in developer option / webview

By the way, please answer my question:
"Hello, after install this module, open Facebook and click a link, I still see this link is opened by the Facebook mobile browser, how can I replace that by Bromite in app browser ?"
1) App info->3 dots-> uninstall updates
2) A webview is not used to open links in a browser it's used to render web content. That is, signin and other links that launch other apps will still launch other apps

Sent from my Moto Z3 Play using XDA Labs
 

clcombs262

New member
Oct 16, 2018
256
144
0
Monticello
lineageos 14.1 unofficial 5/7/2019 d2att sgs3, magisk18.1/magiskmanager 7.1.2, xposed89.3systemless
Try reinstalling the module

Also I need to know names of any system apps folders that act as a webview in your ROM

I can confirm it works in official builds of lineage; it depends on what your maintainer did and what is implemented and if it's a GSI or ROM

Sent from my Moto Z3 Play using XDA Labs
 

kos25k

Well-known member
Nov 15, 2012
3,066
425
83
with latest version installed,i couldnt open puffin browser and news on android app. when i disabled module,they fibally opened.
 

clcombs262

New member
Oct 16, 2018
256
144
0
Monticello
with latest version installed,i couldnt open puffin browser and news on android app. when i disabled module,they fibally opened.
Some apps refuse to work with bromite

Did you reboot and verify successful installation?

Though I must say if webview break the browser of all things, switch browsers. That means it's just a webview wrapper

Sent from my Moto Z3 Play using XDA Labs
 

iR3kT

New member
Jan 11, 2018
21
1
0
how do I fully uninstall, when I removed module, the we view app seas disabled and greyed out and I wasn't able to access mathsway apps (blank screens)
 

clcombs262

New member
Oct 16, 2018
256
144
0
Monticello
Gmail and other apps start to crash/exit when u want to launch it.
Try navigating to /data/ASB/modules/bromitewebview/system/app/webview and installing the apk there

Boot scripts should take care of that but sometimes some devices work weird with magisk boot scripts

Sent from my Moto Z3 Play using XDA Labs
 

gorillus

New member
Jan 15, 2014
27
5
0
I have the same issue. With the latest release K9-Mail crashes again. I have no ASB directory in /data...

Edit: I see it's supposed to be adb not ASB. Alright I copied and installed that apk there and it works. Thank you!
I'm using a Xiaomi Redmi 4x with LineageOS for MicroG 15.1 btw. - if that helps to prevent this issue in future releases...
 
Last edited: