Question (bug?) Device control icon on lockscreen shown despite disabled

Search This thread

roirraW "edor" ehT

Forum Moderator
Staff member
Hmm ... weird ... not fixed ... icon suddenly started re-appearing on lock screen despite 'device controls' being OFF.
I usually keep mine on, but I've just now disabled mine and I'll see if it pops back up. In my case, so far, a reboot wasn't necessary to make it go away.
 
  • Like
Reactions: foobar66

theyellowplan

Member
Aug 26, 2016
9
3
Which firmware? Have you updated to January yet?
Yeah, and Play System is also up to date. Even tried 12L beta, same issue.
Deleting Play Services data and Google Home app didn't work either.
As soon as I set up any app for device controls from the quick settings tile (Google Home, Xiaomi, Tasker), that button shows up on the lockscreen (sometimes with a delay), regardless of the "show device control" setting under lockscreen settings.
 
  • Wow
Reactions: roirraW "edor" ehT

theyellowplan

Member
Aug 26, 2016
9
3
Yeah, and Play System is also up to date. Even tried 12L beta, same issue.
Deleting Play Services data and Google Home app didn't work either.
As soon as I set up any app for device controls from the quick settings tile (Google Home, Xiaomi, Tasker), that button shows up on the lockscreen (sometimes with a delay), regardless of the "show device control" setting under lockscreen settings.
After resetting Play Services again, I just found the culprit: Smart Lock. If you enable Smart Lock for home and you're on that location, the button is shown. Not sure if that's intended behaviour.
 
  • Like
Reactions: roirraW "edor" ehT

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Settings > Display > Lock screen > Show device controls ... I disabled this, but the device control icon is still showing on the lock screen.
    Is this a bug? Could someone please try as well? thanks.
    OK ... well ... seems to be 'fixed' after a reboot ...
    1
    Hmm ... weird ... not fixed ... icon suddenly started re-appearing on lock screen despite 'device controls' being OFF.
    I usually keep mine on, but I've just now disabled mine and I'll see if it pops back up. In my case, so far, a reboot wasn't necessary to make it go away.
    1
    Same here. Figure it'll get fixed and it's a silly oversight.
    1
    I even checked:
    Code:
    # settings get secure lockscreen_show_controls
    0
    So it's clearly 'off' ... still the icon for device control is sometimes appearing on my lock screen.

    Silly bug ... I will report it to Google.
    1
    I've had it disabled since Friday and it hasn't reappeared on the lockscreen for me yet. You've probably already tried this, but maybe try enabling it, lock the screen, then disable it again?