[Bug][Resolved] Bluetooth media buttons not working

Search This thread

MikeOShay

Member
Nov 27, 2014
13
2
I just got a Google Pixel 6, upgrading from a Samsung Galaxy S7. I'm running MX Player Pro (Activated) version 1.42.13 (ARMv8 NEON).
Attached are the files that were generated when I hit the "Bug Report" button under More Settings. I tried hitting the "Save to File" option, but never got the confirmation message that one had been generated, and couldn't find a generated file in my phone. I've zipped them together and tried to name the file according to the expected zip filename.

On my previous phone (and whatever version of MX Player was on it) the play/pause/forward/back buttons on my headphones worked as expected.
I could also use those media controls when my phone was paired with my car.
They worked fine when the video was in the foreground, background, or in PiP.

Now on my new phone they aren't working. I'm not sure if I'm missing any permissions, or if there's been some other software change.
I've tried it on 2 different pairs of Bluetooth headphones and in my car, and the media buttons aren't working properly for any of them.

The same devices are working fine on other players (BlackPlayer EX and Youtube), so I believe this problem to be specific to MX Player, and not a fault with the Bluetooth devices or my phone.

If anyone knows a setting I could change that might fix this, I'm up to do whatever testing will help.


[Edit: Sometimes, if the app is playing in the background, the media buttons are able to pause it, but not unpause it. Again, other players seem to work as expected with the same BT devices.]
 

Attachments

  • report_2022-06-05_192800.zip
    13.2 KB · Views: 15
Last edited:

kradcliffe

Senior Member
Sep 28, 2010
287
119
Aberdeen
Toggling settings>Player>Media Buttons gets it working for a while.

Just noticed this thread after raising a new one. Doesn't respond to the buttons on my Fiio DAC
 

greyhat62

Member
Jan 6, 2014
8
0
I use Note 20 ultra, Android 12 & I faced the same problem.
My bluetooth headphone can not control the MX Player.
Nothing happend when press button on headphone.
When will this bug be fixed ???
 

kradcliffe

Senior Member
Sep 28, 2010
287
119
Aberdeen
Never by the looks of it. No update for months, nothing on the beta channel. This app is abandonware. Time to find sometjing else.
 

MikeOShay

Member
Nov 27, 2014
13
2
Confirmed, it's working on my headpones again as of release version 1.51.8 (ARMv8 NEON). Will test in my car this weekend, but I'll mark this as Resolved.

[Edit: Sometimes, if the app has been dismissed and the video's been paused for a while, it takes two Play presses for it to start again. I think this is on the app's end and not my Bluetooth device. Still, it's functional enough to be usable again, so I'm going to keep this marked as Resolved.]
 
Last edited: