Bugs

Search This thread

mattymon

Senior Member
Oct 6, 2010
99
10
Toronto
Anyone notice any bugs so far with the one xl? If so, report them here. I'm getting some weird bugs.

Wifi issue 1: Sometimes when i leave a wifi zone the phone still shows its connected to wifi. Only way to get rid of it is to turn wifi off and then back on.

Wifi issue 2: It stays connected to wifi, however, i notice it jumps up and down quite often and doesnt remain consistent. Sometimes i loose connection at 0 bars and then it goes back to full.

Loading: Sometimes when i leave an application the screen needs to load and i get a "loading" notification in the middle of the screen.

SMS notifications sometimes don't notify me. I randomly have o check myself.

Facebook private messages don't notify me as well. I have to manuallty check. Even though its set to sync.

Sometimes my sim needs to re-register.

This is my second HTC one XL unit. Also, rogers cannot get lte to work on my device. Yes, i have an lte sim and my account has an lte plan. I just came from a sgs 2 lte.


Let me know if anyone else is experience any bugs?
 

NextNexus

Senior Member
Jan 19, 2007
464
117
Those are some serious bugs that would be a deal breaker for me. Hopefully it's just a defective unit and you could get it replaced?
 

~David

Senior Member
Nov 27, 2007
329
78
Toronto
I can safely say I have not encountered any of those issues yet.

LTE is working great (on Telus). No issues with WiFi. All SMS notifications are working. Haven't received any Facebook PMs yet, so not sure about that.

One issue I have noticed, though I'm not sure if it's with the device or with specific apps, is that some apps that have a dedicated menu key will still show the soft menu key at the bottom of the screen.

e.g...

yzGJol.png


Note the app has it's own menu key, yet the soft menu key is still visible.
 
Last edited:

danada

Senior Member
Apr 20, 2012
83
23
Toronto
I previously stated my wifi was fine, but I am starting to notice some issues with it lately. It seems to drop connection from time to time. Sometimes my SMS also will not notify me, or if they do, I won't have a flashing green notification led.

I was having a problem earlier saying something like 'Network access changed. Calling is restricted' and forced me to have no signal. Switching airplane mode on/off fixed this problem, and playing around with the network mode (gsm/hspda/lte) seems to have fixed this problem for now.
 

mattymon

Senior Member
Oct 6, 2010
99
10
Toronto
I previously stated my wifi was fine, but I am starting to notice some issues with it lately. It seems to drop connection from time to time. Sometimes my SMS also will not notify me, or if they do, I won't have a flashing green notification led.

I was having a problem earlier saying something like 'Network access changed. Calling is restricted' and forced me to have no signal. Switching airplane mode on/off fixed this problem, and playing around with the network mode (gsm/hspda/lte) seems to have fixed this problem for now.

I get the same issue with the calling is restricted issue. Then it registers the sim again. Seems like we have some of the same issues. These issues were both persistent on both of the HTC one xl phones i had.
 

bongd

Senior Member
Jun 20, 2010
1,533
170
I wasn't sure if it was from a screw up of mine or not, but I've noticed Wifi drops as well. I think I've had some network drops too but never any dropped calls and it's difficult to diagnose as a certainty.

The wifi definitely drops though. Hope a custom kernel with better wifi drivers comes out.
 

~David

Senior Member
Nov 27, 2007
329
78
Toronto
I've been using my One X nonstop since I got it yesterday, I haven't noticed my WiFi drop even once. Though I'm connected to a 5Ghz network; I've switched to my 2.4Ghz network now and I'll report back with my results later.

Haven't seen those on AT&T's version.

Does the AT&T version have a different radio baseband or anything? Otherwise, the AT&T and Rogers are the same model (X325e).
 

mrvirginia

Senior Member
Jun 12, 2010
4,403
2,699
37
Charlotte, NC
I've been using my One X nonstop since I got it yesterday, I haven't noticed my WiFi drop even once. Though I'm connected to a 5Ghz network; I've switched to my 2.4Ghz network now and I'll report back with my results later.



Does the AT&T version have a different radio baseband or anything? Otherwise, the AT&T and Rogers are the same model (X325e).

i believe our model is PJ83100... i could be wrong on that though.
 

DannySmurf

Member
Dec 29, 2010
25
2
I have noticed the wifi issue. It's fine when I'm near the hotspot (say, in my living room), but if I go out onto my deck, a place that other phones have no issue with, it goes completely squirrelly.

Rogers LTE is definitely weaker on this phone than on the Samsungs. At work, I get one bar with this phone (sometimes two) when I'm on LTE. With my Note, I got 3 or 4. It doesn't seem to affect the speed at all though.
 

slegrand

Senior Member
Nov 18, 2010
63
8
Calgary
LTE has been fine on mine but again I am in Calgary and the Rogers coverage here isn't the best for LTE, so I don't get in the coverage area often but even without LTE coverage my device is pulling 12-13/Mbs which I am more than content with.

I have experienced some minor signal issues with Wifi but nothing worse than what I have experienced in the past with my Galaxy SII (I9100M). The only real bug I have experienced is in the official twitter app.

Each time I go to compose a tweet the screen sometimes glitches out for a second before the popup to compose the tweet appears. That is all I have found so far.
 

~David

Senior Member
Nov 27, 2007
329
78
Toronto
i believe our model is PJ83100... i could be wrong on that though.

I don't think that's the correct number.

I've been looking into this over the last few days. After all the videos I watched and reviews I read, etc. I can only find two models of the One X. The HSPA/WCDMA "International" variant, the S720e; and the HSPA/WCDMA/LTE variant, the X325a.

Everyone in this forum should have the X325a.
 
Last edited:
E

E.Cadro

Guest
The pj83100 is the number listed on the pre order
HTC
America
Inc.
PJ83100
WHT
PHONE
Maybe just the number used for pre order or something

Sent from wherever I am!
 

~David

Senior Member
Nov 27, 2007
329
78
Toronto
Ah, I just got the "no SMS notification" bug.

It happens when you leave the SMS app open when the screen is shut off. Even off, it assumes you're in the app and doesn't generate a notification.
 

bmolloy

Senior Member
May 3, 2010
159
27
Temecula,
I can safely say I have not encountered any of those issues yet.

LTE is working great (on Telus). No issues with WiFi. All SMS notifications are working. Haven't received any Facebook PMs yet, so not sure about that.

One issue I have noticed, though I'm not sure if it's with the device or with specific apps, is that some apps that have a dedicated menu key will still show the soft menu key at the bottom of the screen.

e.g...

yzGJol.png


Note the app has it's own menu key, yet the soft menu key is still visible.

That is how ICS (Android 4.0x) displays the menu button on legacy apps that have not been upgraded to the new ICS standards yet when being displayed on a phone with hard buttons like the One X. When a phone has the on screen buttons native in ICS (like on the Galaxy Nexus or some tablets) those dots show up as a fourth button on the bottom menu bar. Over time, as developers come into compliance with the new guidelines, I am sure the dots will go away or move to the top where they are supposed to be. I see that that app has a menu button up top but I would try something like Google Voice that is done "the right way" to see if you get the same result. For now though it is a monster waste of space.
 
Last edited:

froesei

Senior Member
Jun 19, 2005
210
11
Winnipeg
I get the sms notification bug as well. And I think it happens not only when you have the app open and the screen off, but also sometimes when you're using the phone (and maybe the app is running in the background).

Also experiencing the black screen and re-loading when app switching.

One that hasn't been mentioned, is while typing, I sometimes get a "strobe" like flash of the screen. It flashes really brightly for a mili-second, and then back to normal. I don't think this should be confused with the "flickering" that so many people who have the international version are talking about. I'm using swiftkey, so I suppose it could be related to that, but I don't think so.

Hopefully all of these bugs are software related and will be taken care of with an update.
 

mattymon

Senior Member
Oct 6, 2010
99
10
Toronto
They seem all software related. Im of course experiencing similar issues! the phone still rocks! just some bugs need to be resolved. But nothing to hinder your daily use.
 

RMatt1992

Senior Member
Sep 5, 2010
133
16
My WiFi/SMS notifs are fine, however as for Facebook, I've never had a single device that properly notified me when receiving a message, and therefore deem that a Facebook issue, not a One X issue. I've not had any problems with mine whatsoever.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Anyone else experiencing touch screen glitchyness?

    Mainly, when trying to highlight text or move the cursor, the cursors go nuts and start flailing around randomly, left and right.

    Edit: Seems to happen only when the stock ICS text selection is used instead of Sense.

    haha i just noticed that.. i was in chrome i typed in a word and i wanted to edit the word then the cursor just went berserk, back and forth . Kept doing it, until i left the search and came back to it afterwards.
    2
    Anyone hear something rattling around in the phone when they shake it?
    It's the focus mechanism in the camera. Don't sweat it, it's normal. My last few phones (including my iPhone 4s) did it. :cool:
    1
    I'm glad you found the thread ...

    Hi Peter. I see you mentioned you have a Nexus, which I can only assume is rooted and running a custom ROM like mine by the fact that you are here, lol.

    How did the One X perform in comparison? I am looking at the Rogers version, but I have to pay full pop, so I want to make sure its worth it.

    Thanks :)

    *Edit* I just found your X vs XL comparison thread and you answered it there in one of your posts.

    Swyped from my Skankwich GNex using XDA Premium App.

    I'm glad you found the thread. It should answer a host of questions concerning the Rogers ONE X and the International ONE X.

    In all honesty, both of the ONE X versions are superior to my GNex, which is rooted and running the AOKP ROM. Sadly, though, WiFi is such a critical issue for me, and both ONE X units are having issues with WiFi. Therefore, until such time that this issue is resolved, I'm going back to the GNex, which simply works ... and no complaints.

    Peter
    1
    I'm glad you found the thread. It should answer a host of questions concerning the Rogers ONE X and the International ONE X.

    In all honesty, both of the ONE X versions are superior to my GNex, which is rooted and running the AOKP ROM. Sadly, though, WiFi is such a critical issue for me, and both ONE X units are having issues with WiFi. Therefore, until such time that this issue is resolved, I'm going back to the GNex, which simply works ... and no complaints.

    Peter

    Yea, that thread is awesome. Thank you for taking the time to make and update it. It has boatloads of useful info. I am going to take the plunge and get the Rogers XL. I can sell my GNex and recover most of the $$$$. I can live with the wifi bug until its squashed, assuming its a kernel/rom issue and not hardware. :)

    Swyped from my Skankwich GNex.
    1
    I don't know if anyone has pointed this out yet, but here's another visual in the calculator. The numbers get cut off .

    Sent from my HTC One X using Tapatalk 2

    I thought I was the only one.. Dumb design.

    I put the calculator widget on one of my 5 home screens. It's fast to get to and has a normal look.

    ---------- Post added at 11:25 AM ---------- Previous post was at 11:13 AM ----------

    Anybody having a problem with their camera app not opening? Randomly when I click on my camera app it will open for .5 seconds then close out immediatly. Restarting the phone fixes the problem temporarily but eventually it happens again.

    Sent from my HTC One X using XDA

    Happened to me a bit differently.
    While pressing video record the camera app would close. Photos were fine, but the video would record failed 1 out of 6 attempts. The failed attempts closed the phone app. Reboot solved. Frustrating though. Had the phone for about 2 weeks now.