Call audio being routed to watch

Search This thread

reviad

Senior Member
Oct 16, 2011
59
2
I'm having some trouble with by Gear S3.

For some reason, every time someone calls me and I pick up on my phone, the audio comes through the watch which is a bit crazy. If I'm picking up from my phone, I want the audio on it (obviously).

I haven't found a setting that will specify to always use my phone for calls.

Any ideas on how to fix this?

I'm on a Moto X Pure.
 

jimmydigital00

Senior Member
Aug 30, 2010
334
72
I had the same problem and this is what I did to fix it.
I did a soft reset on the watch and when it reconnected I went into the Gear app on the phone, Settings, Call Forwarding and hit Turn off.
Make sure it says call forwarding was successfully turned off.
 
  • Like
Reactions: reviad

reviad

Senior Member
Oct 16, 2011
59
2
I had the same problem and this is what I did to fix it.
I did a soft reset on the watch and when it reconnected I went into the Gear app on the phone, Settings, Call Forwarding and hit Turn off.
Make sure it says call forwarding was successfully turned off.

Thanks.

I went to the Gear app on the phone, but I don't have the Call Forwarding option in the settings menu :S
 

jimmydigital00

Senior Member
Aug 30, 2010
334
72
Thanks.

I went to the Gear app on the phone, but I don't have the Call Forwarding option in the settings menu :S

Thats strange.
Maybe your gear software needs to be updated? Also try a hard reset of the watch.
There should also be a call forwarding setting on the watch that will allow you to disable it.
 

reviad

Senior Member
Oct 16, 2011
59
2
Strange.

This is what I have and I have everything updated :S
 

Attachments

  • Screenshot_20161202-132738.png
    Screenshot_20161202-132738.png
    194.2 KB · Views: 2,845

cdd543

Senior Member
Sep 20, 2007
268
31
5280
Same issue on my pixel. Go to Bluetooth settings on your phone, choose s3 and uncheck phone audio.

Sent from my Pixel XL using Tapatalk
 

cosmaru

Member
Jul 12, 2008
6
0
I get the same strange think when i'm making the call from my phone (HTC m8) the audio output it 1st set to phone then when the recipient answer's the audio output changes to the watch by it self. It works find if i'm not making the call
 

Mr.Tinus76

Member
Dec 24, 2016
13
3
Turn the wacht off , press and hold the lower button on the right. After that same procedure to turn it on.

It helped me
 

marcgear

Senior Member
Feb 9, 2013
286
44
Wolverhampton
Can u guide me to this "reset" option so i can try the exact same think.
Thanks in advance.

Sorry for late reply my friend I just went to main setting direct on the each, then find about gear option down click "reset gear"

I'm using a s7 edge with mine on the beta 7.0 but I still had same issue as you have described
 

cosmaru

Member
Jul 12, 2008
6
0
Sorry for late reply my friend I just went to main setting direct on the each, then find about gear option down click "reset gear"

I'm using a s7 edge with mine on the beta 7.0 but I still had same issue as you have described

well that's a bummer, if the samsung s7 can't make the watch work as a normal smartwatch whats the point...u can't have your watch pickup the audio if your using your phone it's just not normal.
So it has nothing to do whit samsung or non samsung phone it's just dose not work? It's a bug not a defective smartwatche?
 

marcgear

Senior Member
Feb 9, 2013
286
44
Wolverhampton
well that's a bummer, if the samsung s7 can't make the watch work as a normal smartwatch whats the point...u can't have your watch pickup the audio if your using your phone it's just not normal.
So it has nothing to do whit samsung or non samsung phone it's just dose not work? It's a bug not a defective smartwatche?

Well mine was just a bug I think because after one quick reset I'm up and running g without fault.
 

stsdema28

Member
Nov 26, 2012
24
36
I have the same issue you all describe at this thread when I use Gear S3 (Bluetooth edition) with HTC 10.

It happens when I make calls from the phone. Once the other person answer the call, the audio automatically is routed to the watch.

In all other cases the watch works ok. eg. If someone call me and I answer on the phone the audio is not routed to the watch. If I use the watch to make or accept calls, work fine as well.

Did anyone find a solution to this?
 
Last edited:

stsdema28

Member
Nov 26, 2012
24
36
I get the same strange think when i'm making the call from my phone (HTC m8) the audio output it 1st set to phone then when the recipient answer's the audio output changes to the watch by it self. It works find if i'm not making the call

Did you manage to solve this?
As I mentioned above I have the same issue with HTC 10.

A possible solution would be to disable the "phone audio" from the bluetooth settings of the device, but in my case this cause the gear s3 to be disconnected from the phone.

It is so annoying.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    I had the same problem and this is what I did to fix it.
    I did a soft reset on the watch and when it reconnected I went into the Gear app on the phone, Settings, Call Forwarding and hit Turn off.
    Make sure it says call forwarding was successfully turned off.
    1
    Same issue on my pixel. Go to Bluetooth settings on your phone, choose s3 and uncheck phone audio.

    Sent from my Pixel XL using Tapatalk
    Guys, this is the answer

    Sent from my ONEPLUS A3000 using Tapatalk
    1
    I'm having the complete opposite problem. I have the Bluetooth version and I can't make calls or answer calls from the gear s3. I'm using HTC 10 on lineage os
    1
    It works after all, however the phone says that the watch is not paired... but it is..

    I will try to do something with tasker, in order to keep "phone audio" on in order to receive calls on the watch.
    Something simple would be to turn off bluetooth during the outgoing calls..

    I resolved the problem using a tasker. Of course this is workaround :) You must have tasker and secure settings plugin installed.
    Scene "car in" -> task: plugin secure settings -> actions -> bt connection -> "choose gear3 and disconnect", add wait 2 sec, plugin secure settings -> actions -> bt connection -> "choose your car audio bt name" and connect
    Scene "car out" -> you dont need to do here nothing, gear s3 will automaticly reconnect after you turn of your car audio.
    Of course you should also add some triggers to run scenes.

    I hope this will help to someone.