Call audio being routed to watch

Search This thread

cosmaru

Member
Jul 12, 2008
6
0
No there is no fixing it...if u ask samsung they will say that it is limited support on non Samsung phones...
And yes if i do that i get the same think, phone and smartwache get disconnected so that is not an option.

I have tested it on Samsung and there it works as intended, if u ask me is false advertised ...i can't use the watch whit all the andorid devices this is not a working device.
Did you manage to solve this?
As I mentioned above I have the same issue with HTC 10.

A possible solution would be to disable the "phone audio" from the bluetooth settings of the device, but in my case this cause the gear s3 to be disconnected from the phone.

It is so annoying.
 

stsdema28

Member
Nov 26, 2012
24
36
That does not happen to me.

It works after all, however the phone says that the watch is not paired... but it is..

I will try to do something with tasker, in order to keep "phone audio" on in order to receive calls on the watch.
Something simple would be to turn off bluetooth during the outgoing calls..
 

reviad

Senior Member
Oct 16, 2011
59
2
Yeah, sometimes it doesn't show it connected to Bluetooth but everything works.

Sent from my ONEPLUS A3000 using Tapatalk
 

raypro112

Senior Member
Feb 20, 2012
101
9
I'm having the complete opposite problem. I have the Bluetooth version and I can't make calls or answer calls from the gear s3. I'm using HTC 10 on lineage os
 
  • Like
Reactions: punkpk

ciopyn

Member
Jun 29, 2016
22
0
Also I have this problem, have the Bluetooth version and I can't make calls or answer calls from the gear s3. I'm using Leeco Max 2 and the os EUI 6.0. Please help.
 

kluczus

Member
Feb 19, 2006
45
3
It works after all, however the phone says that the watch is not paired... but it is..

I will try to do something with tasker, in order to keep "phone audio" on in order to receive calls on the watch.
Something simple would be to turn off bluetooth during the outgoing calls..

I resolved the problem using a tasker. Of course this is workaround :) You must have tasker and secure settings plugin installed.
Scene "car in" -> task: plugin secure settings -> actions -> bt connection -> "choose gear3 and disconnect", add wait 2 sec, plugin secure settings -> actions -> bt connection -> "choose your car audio bt name" and connect
Scene "car out" -> you dont need to do here nothing, gear s3 will automaticly reconnect after you turn of your car audio.
Of course you should also add some triggers to run scenes.

I hope this will help to someone.
 
  • Like
Reactions: QAM

stsdema28

Member
Nov 26, 2012
24
36
I resolved the problem using a tasker. Of course this is workaround :) You must have tasker and secure settings plugin installed.
Scene "car in" -> task: plugin secure settings -> actions -> bt connection -> "choose gear3 and disconnect", add wait 2 sec, plugin secure settings -> actions -> bt connection -> "choose your car audio bt name" and connect
Scene "car out" -> you dont need to do here nothing, gear s3 will automaticly reconnect after you turn of your car audio.
Of course you should also add some triggers to run scenes.

I hope this will help to someone.

I am currently testing a setup with Automate.
I describe it here.
 

Russeren88

New member
Mar 28, 2017
1
0
Same issue here gear s3 BT version and Huawei P9 pro mate.
The watch acts like a regular BT connection in the car, pulls all calls as standard.
this is so annoying when the watch is in the charger at home and you walk around talking, suddenly the audio goes to the watch.
going to test a reset when I get home.
 

superkev72

Member
Sep 3, 2007
7
1
I tried numerous things from this thread and they either didn't work or only worked briefly. I have a Pixel 2 XL and a Gear S3 Frontier edition. Unchecking the phone checkbox in the settings menu for the S3 on the phone briefly causes phone calls to work on the phone and not through the watch but the first time the bluetooth gets disconnected the dialog is checked again.

I did find an easy solution though that should work for many. Just put the S3 into do not disturb mode. With this mode running everything works for some reason and the watch stays connected via bluetooth to the phone. All calls routed properly through the phone and watch can still communicate with the phone. You toggle it on the watch in the settings menu under "device".
 

dj_banderas

Member
Apr 29, 2010
11
0
Bratislava
I have same problems with:
1st Sony XZ1 Clean Oreo 8.0 + Gear s3
2nd Pixel 2 Clean Oreo 8.1 + Gear s3
3rd Pixel 2 Clean Oreo 8.1 + Huawei watch 2
EVEN
with Galaxy s7 on Stock Android 7.1.1 or any older versikn no problem

Just sometimes sound goes througth watch,
I thing its a bug on Phone SW, it does not handle what from was the call created/accepted.

NOTE: With Bluetooth headset call goes every time througth it, which is OK.

EDIT:
Galaxy s9 Android 8.0 problem seems to be fixed (by Samsung), its maybe some workaroung, I think, because at begginig of call for 1st second the otherside does not heae me when I answer via watch to incoming call.
In case of make call I can see bluetooth icon on call screen blink as active than turn to phone icon. I can also change to Speaker or Watch during call. Everyting works ok. BUT ONLY ON SAMSUNG!

Now I bought Google Pixel 3 - problem still here. No fix after year. I had same issues with Huawei Watch 2. I thing its bug in Android 8+ as well. And its not solved.
Yesterday a was driving. I answered call via bluetooth car radio and call goes to watch :D and I cannot switch audio to Phone or Reproductor. :(
 
Last edited:

dyandell

Senior Member
Jul 22, 2013
229
70
I have had the watch for almost a year. It was working fine until I had to reset my network connections this week. I started having the problem with the audio from my phone call going to my watch when I reconnected it. This may not work for most of you since I have the Gear S3 and a Samsung S8+ but I disconnected the phone from the watch in the Gear App, gave it a few seconds and reconnected. Problem fixed, at least for now. I hope this helps some of you.
 

orrvee

New member
Jul 13, 2018
1
0
I have the same problem.My mobile is One Plus 3 T. I too do not have the "Call forwarding" option in the app settings. But if I reboot the phone (which is quite irritating) and connect the Gear S 3 I get the ring audio through the phone as well as the Gear S 3. Is there any permanent solution please.

Raj
 

Xzibit187

New member
Jul 27, 2018
1
0
No they don't. I want to be able to see on the watch who's calling then answer on the phone. If I shut off phone audio in phone settings, the watch doesn't show who's calling anymore. There is third party software available in the Google Play store designed to enable automatic audio re-routing, but I can't get it to work on Huawei P10.
 
Last edited:

Fecky72

New member
Mar 7, 2019
1
0
Solved

Setting that will solve your problem is in bluetooth settings for your connected watch on your phone. Go to Bluetooth settings on your phone, find your connected watch, and select additional settings for your watch (on my phone it's by tapping the "i" in the circle), and then turning off Phone function, as shown on pictures bellow.
open

open


Of course, if you later want to use call audio from your watch (like when driving a car), you'll have to go back to this settings and enable Phone function again.

(Sorry for not switching my phone into English language and then taking the screenshots)...
 

tyrich30

Senior Member
Dec 10, 2009
57
12
VA
Issue looks to be solved?
Well, I was having the same issue and it was driving me crazy.
It happened after an watch update. There use to be a setting to turn off voice calls.
Here is the fix
-go to watch settings on the watch
-Apps
-Permissions
-Phone
-uncheck Call option
You should be good to go. Hope that helps.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    I had the same problem and this is what I did to fix it.
    I did a soft reset on the watch and when it reconnected I went into the Gear app on the phone, Settings, Call Forwarding and hit Turn off.
    Make sure it says call forwarding was successfully turned off.
    1
    Same issue on my pixel. Go to Bluetooth settings on your phone, choose s3 and uncheck phone audio.

    Sent from my Pixel XL using Tapatalk
    Guys, this is the answer

    Sent from my ONEPLUS A3000 using Tapatalk
    1
    I'm having the complete opposite problem. I have the Bluetooth version and I can't make calls or answer calls from the gear s3. I'm using HTC 10 on lineage os
    1
    It works after all, however the phone says that the watch is not paired... but it is..

    I will try to do something with tasker, in order to keep "phone audio" on in order to receive calls on the watch.
    Something simple would be to turn off bluetooth during the outgoing calls..

    I resolved the problem using a tasker. Of course this is workaround :) You must have tasker and secure settings plugin installed.
    Scene "car in" -> task: plugin secure settings -> actions -> bt connection -> "choose gear3 and disconnect", add wait 2 sec, plugin secure settings -> actions -> bt connection -> "choose your car audio bt name" and connect
    Scene "car out" -> you dont need to do here nothing, gear s3 will automaticly reconnect after you turn of your car audio.
    Of course you should also add some triggers to run scenes.

    I hope this will help to someone.