Cam Plus Module Problems - How Should it work?!

Search This thread

Icetea

Senior Member
Nov 8, 2014
1,735
510
143
@coliboy
I think, you have a really big mouth for a newbie but this will grant you to be the newest entry on my ignore list.:
And yes, you are welcome too!

BTW: Mum is dead, couldn’t ask!
 
Last edited:

mike69290

Member
Dec 16, 2010
30
2
0
I got the cam plus a few days ago (only 20 euros from Amazon.de) and it’s fine for me. So I share the method:

1/Cam plus comes empty. Plug it on your phone and charge. Don’t worry if red light isn’t on.

2/Unplug the cable and open app “LG friend manager”. It installs something and you get a white screen telling “Go to google play store for update(...)”.

3/Go to google play store and install “LG CAM Plus Manager”.

4/Return to the white screen, it must tell Version is up-to-date.

5/LG CAM Plus Manager is not an app, it is a driver. To use camera, push down the sliding button on the camplus.


NOTE: Datasheet tell Phone & Camplus must be from the same country to work. My phone is from Italy, my Camplus is from Germany, I live in France and it is working :eek:
 
Last edited:

Moonbear1989

New member
Jun 8, 2017
1
0
0
help

I have the same problem...please help


Hey guys,

I'm on my second Cam Plus module, and I have no idea how to make it work, or what I should expect.

I've attached it to my phone, and charged it for 5+ hours. During the first two hours I didn't see any LEDs on the Cam Plus. After two hours it started flashing red to indicate charging (I think?).

I've never had it change from red flashing LED.

The Cam Plus firmware update just shows the same "Connect a Cam Plus to check for Updates" message with the module attached. The LG Friends app sees the device and lists it as connected. I've not been able to get the module to do anything, or have any buttons work in the LG Camera app. Moving the bottom switch seems to not do anything.

Am I crazy here, or is this second unit defective? Am I just doing it wrong?

Thanks guys, any help is appreciated.
 

AntonBara

New member
Aug 23, 2017
1
0
0
Hi,

After doing a dumb thing and purchasing the Cam Plus for my G5, I found that I purchased the wrong MPN. I have purchased the correct one now, but would like to know what country and carrier so I can sell the wrong one. Manufacturer's part # is TMON64673. LG has only told me to go to every countries LG site and check the model #. Off hand any advice you can give would be appreciated.

Hi there! The one you want to sell is CBG-700 or CBG-720?
 

doerfast

New member
Oct 24, 2017
1
0
0
I finally got my cam plus to charge. Apparently the battery locks when it is fully discharged, you have to attach it to the phone and charge for about 5 minutes, but apps have to be up to date for this to work, got no light or flashing red light at first. Flashing red light started once I installed lg friends manager app. The cam plus app will not see the module either. I think I did press the camera on button and the video button on the cam plus for 3 seconds before it started to flash on one of the phones, I had 2 that did not work.

If you get the flashing red light it is not charging, what you need to do is update your lg5 by going to settings>general>about phone>update centre>app updates then do the updates. Once I did this the module started to get a solid red light and started the charge. You can then remove from phone and charge cam plus on it's own then and you should get a solid green light when charged.
Hope this helps.

I updated the apps through Google Play as my LG 5 does not have an "Update centre" or "app updates" under the "about phone" section but it still flashes red when charging and in the Cam Plus Manager it states "USB device must be allowed before updating" and when I click CHECK it states to "attach the cam plus" when it's already attached.

---------- Post added at 11:18 PM ---------- Previous post was at 11:11 PM ----------

I updated the apps through Google Play as my LG 5 does not have an "Update centre" or "app updates" under the "about phone" section but it still flashes red when charging and in the Cam Plus Manager it states "USB device must be allowed before updating" and when I click CHECK it states to "attach the cam plus" when it's already attached.

So how does one do the following: "USB device must be allowed before updating"? How do you allow the USB device?
 

itm

Senior Member
Jan 1, 2007
1,332
30
0
5/LG CAM Plus Manager is not an app, it is a driver. To use camera, push down the sliding button on the camplus.

I can confirm that this is not true. I don't have the LG CAM Plus Manager app installed but the buttons on the module all work fine.
 

ryancolm

New member
Jan 2, 2018
4
1
0
"Hi i managed to connect it to computer and pull the cable and then it asking it to allow app to use this usb device."
@gerciolisz: Can you be more specific? I tried what you say, but my cam plus is still a brick. When I go into the permissions for this app, it says that no permissions are necessary. How do I get the G5 to give the app permission to use this usb device? I am tearing my hair out here...
 

gerciolisz

Senior Member
Feb 22, 2013
933
343
83
Gdańsk
I connected lg with camplus module to my PC. Was actually in camplus app. Changed USB charging to file transfer. And disconnected it a while later. It showed me dialog ( similar to one for adb permission when connected to PC) and confirmed. In my case connecting to PC and disconnecting triggered something. Camplus wasn't even charged to max.
 

mrvasaldo

Member
Oct 22, 2017
8
1
0
camplus and lg g5se

got a camplus not working, always telling me to connect it when it is connected
buy a new one on amazon.fr....9.5 euros worth the risk
i don't know what i dit
i connect it on the phone, start the phone, plug the usb to charge, launche playstore to check if camplus manager need an update - it was the cas - solve noting so i reboot the phone and now te red light is solid on...does it mean it's charging ?
i didn't have that on my other camplus....maybeit was a probleme of update or association
i have a g5se so an H840 and not the h850 of europe, the first camplus i bought it from bouygues, a french provider, the 2nd one from amazon.Fr but it was sent by amazon not selled by amazon...

i have a moto z ...with battery mod...it works better than this lg crap !!!
btw i'm waiting for the mod to charge and see iof it really works
the lg g5 even the SE (3gb ram and s652 instead of 4gb/s820) has a fantastic camera so i hope it finally work
 

ryancolm

New member
Jan 2, 2018
4
1
0
In my case connecting to PC and disconnecting triggered something. Camplus wasn't even charged to max.

Many thanks. I tried this, but to no avail.

A tech shop in town has them on sale for 1 euro (yes, 1 euro) so I think I'll buy a handful and try them all!!!

Update: I bought 'em. Guy in the shop thought I was crazy. I unboxed one, and it shows the same problem as before. I note that when I attach the cam plus and power on the phone, that the LED blinks red and then green and then never turns on again. I wonder if that's important... In the previous cam plus I tried, it did that at the start, but as I tried and messed with it and kept playing with it, it stopped.
Hmm. It's a mystery...
 
Last edited:

mohammadGEO

New member
Jan 11, 2018
1
0
0
solve red flashing LED CAM Plus

Hi , I registering at XDA just to share this video could
googling for this video named
"LG G5 Cam Plus fix (how to overcome the flashing red LED of death problem "
 

ryancolm

New member
Jan 2, 2018
4
1
0
Finally the damn thing works

Stop press! I finally got it working. I have no idea how i did it. To any one else who's still banging their heads off a wall, i say, just keep at it. Leave it on charge overnight, over a weekend, etc., until you finally see LED flashing or at least staying on. Yes!

Only thing is... It's a bit ****, no?
 
  • Like
Reactions: gerciolisz

jaggyjags

Senior Member
Dec 8, 2011
1,487
2,116
0
Murcia
Stop press! I finally got it working. I have no idea how i did it. To any one else who's still banging their heads off a wall, i say, just keep at it. Leave it on charge overnight, over a weekend, etc., until you finally see LED flashing or at least staying on. Yes!

Only thing is... It's a bit ****, no?


Hi, Did you keep it charging alone or plugged to the phone?
 

ryancolm

New member
Jan 2, 2018
4
1
0
I don't know, to be honest with you. Try both. Leave it charging overnight both on and off the phone, etc. Keep finding with the buttons, trying to reset the device.
Also, I'll post later about the USB permissions.

---------- Post added at 08:24 AM ---------- Previous post was at 07:52 AM ----------

Re: USB device permissions.
When you attach the cam plus, as you already know, the Friends app tells you to authorize the app to use the USB port. Now, what I found one day was that a notification actually popped up on the screen of the G5, asking me to authorize that very thing. I tapped on Authorize and the rest is history; it started charging, I was able to use it from then on.

However, when I plugged one of my other cam plus modules into the same phone, I was back to square one. The "enabled" cam plus works okay now, except that when it's attached, sometimes the g5 thinks (because it's a USB device) that I'm trying to transfer data from another phone, and it pops up a screen telling me how to move that process along. I dismiss that screen, and then I can use the buttons on the cam plus. This can get frustrating because on a bad day, that damn data transfer prompt shows up every time I unlock the phone, and I have to dismiss it every time before I can use the buttons on the cam plus.

That's just given me an idea, actually. Start the LG app for data transfer, or backup, after you attach the cam plus. It might toggle something to make the USB permissions dialog come up and you can then enable the cam plus.

When I get home I'll try this with one of my non functioning cam plus modules and let you know how I get on.
 

jaggyjags

Senior Member
Dec 8, 2011
1,487
2,116
0
Murcia
OK, finally fixed it, it's a dead battery problem and the module won't charge it under a certain voltage, which is lame, bad design. I opened it, used the battery dock, made a bridge with two copper wires I peeled off from a dead cable and made contact with the module battery as you see on the images.
All lithium batteries charge at the same voltage AFAIK so I was confident it would work, you need a phone battery plugged in the dock to work as it checks the other pins for safety reasons I guess.
After an hour I removed it, the module charged by itself. :good: and everything works as intended.





20180326_120736.jpg20180326_141523.jpg

Sent from my LG-H850 using Tapatalk
 
Last edited:

cridus

Senior Member
Apr 3, 2013
55
10
0
so the only real solution is a hardware "hack"? seriously?

(I'm also bumping this thread in the hope that someone who solved the problem in another way and didn't participate in this thread sees it)
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Hey guys,

    I'm on my second Cam Plus module, and I have no idea how to make it work, or what I should expect.

    I've attached it to my phone, and charged it for 5+ hours. During the first two hours I didn't see any LEDs on the Cam Plus. After two hours it started flashing red to indicate charging (I think?).

    I've never had it change from red flashing LED.

    The Cam Plus firmware update just shows the same "Connect a Cam Plus to check for Updates" message with the module attached. The LG Friends app sees the device and lists it as connected. I've not been able to get the module to do anything, or have any buttons work in the LG Camera app. Moving the bottom switch seems to not do anything.

    Am I crazy here, or is this second unit defective? Am I just doing it wrong?

    Thanks guys, any help is appreciated.
    1
    When I got my g5 from Telus they gave me the camplus and it never worked, returned it and tried 3 different units brand new from Telus And none worked, the LG rep was at the store that day and none worked for he either on her g5. I ended up getting credit back for that bonus item

    My Cam Module stopped working after a software update. I pressed the video record and sliding on/off switch for 3 seconds. The led start blinking green, amber and red. I rebooted the phone and launched the LG Friends app to re-pair the LG Cam Plus. It works again. This procedure must hard reset the module.
    1
    Cam Plus help

    Hi,

    After doing a dumb thing and purchasing the Cam Plus for my G5, I found that I purchased the wrong MPN. I have purchased the correct one now, but would like to know what country and carrier so I can sell the wrong one. Manufacturer's part # is TMON64673. LG has only told me to go to every countries LG site and check the model #. Off hand any advice you can give would be appreciated.
    1
    I had the same problem. Go to youtube and look for a video entitled 'LG G5 Cam Plus fix (how to overcome the flashing red LED of death problem )'. Follow this guys instructions and you should have a functioning Cam Plus that you don't want to punch anymore.
    Kudos to the guy who posted the video for persevering and getting an answer from LG.
    I hope this helps because I know how aggravated I was by the whole thing, especially after having to send back the G5 SE as it doesn't have RAW capability. It took ages to get the phone and set up I wanted. Anyway, it's all been worth it 'cos it's a cracking wee piece of kit.
    1
    @coliboy
    the live can be so easy!
    Why do you forget to post the link???

    -> https://www.youtube.com/watch?v=Z274bXPanN0
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone