• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[Camera App] Background Defocus - no root needed!

Search This thread

Ambroos

Senior Member
Aug 11, 2010
1,401
915
Dublin / Belgium
Hello guys!

I modified the deodexed Background Defocus app to make it installable on phones that aren't rooted.

Enjoy!

You might get an occasional UI bug but that's not fixable for now. App should still work fine and I've only encountered it once so far.

Just download and install like any APK:
http://www.ambroosvaes.be/bgdefocus-noroot-signed.apk

kRF6YX7l.png
 

josephnero

Senior Member
Mar 23, 2011
2,174
720
Sanford NC
Anyone experiencing failed to blur background? I haven't been able to take a blurred pic also i tried many times.
Ps:good to see you here ambroos

Sent from my LT30p using XDA Premium 4 mobile app
 

DooMLoRD

Inactive Recognized Developer
Jul 27, 2010
13,191
39,703
Pune
keep getting same error:

Code:
Failure [INSTALL_FAILED_UID_CHANGED]

on Xperia Z1 .290 FW
 
  • Like
Reactions: El.Guaje

Ame123

Senior Member
Dec 30, 2012
677
62
keep getting same error:

Code:
Failure [INSTALL_FAILED_UID_CHANGED]

on Xperia Z1 .290 FW

I also cant install it. It always fails to install

Sent from my C6902 using Tapatalk

---------- Post added at 07:55 AM ---------- Previous post was at 07:54 AM ----------

Sounds like you still have a part of the root-only version installed, no?

I never had any issues, don't have root.

So what should i do now? I tried to install the root only version but it didnt happend

Sent from my C6902 using Tapatalk
 

ImAnurag

Senior Member
Aug 10, 2011
1,069
480
New Delhi
GizmoBolt.com
Google Pixel 2 XL
Hello guys!

I modified the deodexed Background Defocus app to make it installable on phones that aren't root

Not working on my non rooted z1
Same install failed error while installing it like normal apk, any solution ?

Am on .290 4.3 firmware

[UPDATE] did a reboot cleared cache and then it worked.



Sent from my C6902 using XDA Premium 4 mobile app
 
Last edited:

mextreme

New member
Feb 27, 2009
2
1
Works Great Tks

Thanks a lot, worked great on C6906 4.3 not root. :good:

The processing is a little slow, but I think is normal when combining the pictures it took to do the effect.
 

DetmL

Senior Member
Oct 25, 2013
68
19
Got it sooner than expected. Thanks alot mate. :thumbup::D

Sent from my C6902 using XDA Premium 4 mobile app
 

Ame123

Senior Member
Dec 30, 2012
677
62
Not working on my non rooted z1
Same install failed error while installing it like normal apk, any solution ?

Am on .290 4.3 firmware

[UPDATE] did a reboot cleared cache and then it worked.



Sent from my C6902 using XDA Premium 4 mobile app

Which cache should i clear?

Sent from my C6902 using Tapatalk
 

arediy_ash84

New member
May 30, 2013
1
0
its work perfectly on my Z1. no need to clear cache or reboot. str8 download, install and use. no problem so far
 

Top Liked Posts