• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Question Cannot activate OEM unlock

Search This thread

traber

Member
Oct 27, 2008
7
4
Hello,
I cannot activate OEM unlock on my Moto G30.

1-szare.png



Firmware: RRCS31.Q.Q1-3-34-1-4 (EU Retail), the device is not from the carrier, just from the shop (yesterday "out of the box").
I have "OEM unlock" code from Motorola, but that doesn't help (because "OEM unlock" is not active).

2-niedas.JPG


I tried to do hard reset, but under "Recovery Mode" I get "no command". After a few attempts, I was able to start "Recovery Mode" and do "wipe / factory reset", but that doesn't help as well.
Even "Rescue" with LMSA from Motorola could not solve the problem (I tried 3-4 times).
I can't do anything with fastboot either, because "OEM locked" = access denied.

Is there a solution here or do I have to wait until a new OTA update comes and repairs(?) the firmware?

TIA
t.
 
  • Like
Reactions: Kuntitled
Hello,
I cannot activate OEM unlock on my Moto G30.

View attachment 5333033



Firmware: RRCS31.Q.Q1-3-34-1-4 (EU Retail), the device is not from the carrier, just from the shop (yesterday "out of the box").
I have "OEM unlock" code from Motorola, but that doesn't help (because "OEM unlock" is not active).

View attachment 5333035

I tried to do hard reset, but under "Recovery Mode" I get "no command". After a few attempts, I was able to start "Recovery Mode" and do "wipe / factory reset", but that doesn't help as well.
Even "Rescue" with LMSA from Motorola could not solve the problem (I tried 3-4 times).
I can't do anything with fastboot either, because "OEM locked" = access denied.

Is there a solution here or do I have to wait until a new OTA update comes and repairs(?) the firmware?

TIA
t.
Try contacting motorola customer support or wait out for an OTA update which could fix it. But its best to contact motorola customer support first
 
  • Like
Reactions: Kuntitled

sd_shadow

Recognized Contributor
Sep 21, 2011
18,107
1
8,678
South Dakota
goo.gl
Motorola Droid X
Moto X4
Hello,
I cannot activate OEM unlock on my Moto G30.

View attachment 5333033



Firmware: RRCS31.Q.Q1-3-34-1-4 (EU Retail), the device is not from the carrier, just from the shop (yesterday "out of the box").
I have "OEM unlock" code from Motorola, but that doesn't help (because "OEM unlock" is not active).

View attachment 5333035

I tried to do hard reset, but under "Recovery Mode" I get "no command". After a few attempts, I was able to start "Recovery Mode" and do "wipe / factory reset", but that doesn't help as well.
Even "Rescue" with LMSA from Motorola could not solve the problem (I tried 3-4 times).
I can't do anything with fastboot either, because "OEM locked" = access denied.

Is there a solution here or do I have to wait until a new OTA update comes and repairs(?) the firmware?

TIA
t.
It's not unusual for OEM unlocking on Moto devices, to be greyed out.
You need to connect to wifi/LTE and it should be available in 3 or so days after that.
1-szare_LI.jpg
 
Last edited:

traber

Member
Oct 27, 2008
7
4
It's not unusual for OEM unlocking on Moto devices, to be greyed out.
You need to connect to wifi/LTE and it should be available in 3 or so days after that.
View attachment 5333139
Thank you, you give me hope :) (BTW I didn't have this problem with my G7 Plus two years ago...)
This screenshot was taken without wifi access, but I also saw this hint and activated wifi (and inserted a SIM card as well), but it didn't help.
If that's the case, then I'll wait a few more days (like with Samsung phones, where you also have to wait about 7 days for the developer menu to appear - at least that's how I read it).
 
  • Like
Reactions: Kuntitled

sd_shadow

Recognized Contributor
Sep 21, 2011
18,107
1
8,678
South Dakota
goo.gl
Motorola Droid X
Moto X4
Thank you, you give me hope :) (BTW I didn't have this problem with my G7 Plus two years ago...)
This screenshot was taken without wifi access, but I also saw this hint and activated wifi (and inserted a SIM card as well), but it didn't help.
If that's the case, then I'll wait a few more days (like with Samsung phones, where you also have to wait about 7 days for the developer menu to appear - at least that's how I read it).
I use to see threads like this once and a while from people with devices on RetLA and a few others.
But now since 2020, I see this problem a lot.
 
  • Like
Reactions: Kuntitled

traber

Member
Oct 27, 2008
7
4
I use to see threads like this once and a while from people with devices on RetLA and a few others.
But now since 2020, I see this problem a lot.
For your statistics :) - my device has RETEU.
So... after about 24 hours nothing happened and I inserted a SIM card to be sure (but internet connection only via WLAN). Then after about 1 hour "OEM unlock" was active.
Maybe it's a topic for the FAQs "how to root": "you should not be afraid, in some cases this option can become active after 3(?) days / some time"?
What really worries me is the fact that a brand new device ("out of the box", not yet manipulated) has problems with "recovery mode" - an another reason to install TWRP to make backup properly.

And now I want to be sure: it is necessary to flash boot.img twice, so
fastboot flash boot_a patched_boot.img
fastboot flash boot_b patched_boot.img
?
"It works. I rooted mine, just keep in mind that since this is an A/B device, you have to flash the boot image to both boot_a and boot_b."
It's new for me, I have not done this (flash A&B, it was just "flash boot.img" once) on G7 Plus and it works very well (with EdXposed, XprivacyLua and so on). At that time I also read that with G7 I can't install TWRP permanently because it's such an "A&B device" (like G30 now...) and I have to choose, root or TWRP, or re-root the device after each use of TWRP, so "delete" TWRP again.
How does it look here?
t.
 
  • Like
Reactions: Kuntitled

sd_shadow

Recognized Contributor
Sep 21, 2011
18,107
1
8,678
South Dakota
goo.gl
Motorola Droid X
Moto X4
For your statistics :) - my device has RETEU.
So... after about 24 hours nothing happened and I inserted a SIM card to be sure (but internet connection only via WLAN). Then after about 1 hour "OEM unlock" was active.
Maybe it's a topic for the FAQs "how to root": "you should not be afraid, in some cases this option can become active after 3(?) days / some time"?
What really worries me is the fact that a brand new device ("out of the box", not yet manipulated) has problems with "recovery mode" - an another reason to install TWRP to make backup properly.

And now I want to be sure: it is necessary to flash boot.img twice, so
fastboot flash boot_a patched_boot.img
fastboot flash boot_b patched_boot.img
?
"It works. I rooted mine, just keep in mind that since this is an A/B device, you have to flash the boot image to both boot_a and boot_b."
It's new for me, I have not done this (flash A&B, it was just "flash boot.img" once) on G7 Plus and it works very well (with EdXposed, XprivacyLua and so on). At that time I also read that with G7 I can't install TWRP permanently because it's such an "A&B device" (like G30 now...) and I have to choose, root or TWRP, or re-root the device after each use of TWRP, so "delete" TWRP again.
How does it look here?
t.
I have had 4 or so a/b devices and I just used
Code:
fastboot flash boot patched_boot.img
which will flash the active partition
but flashing to both is probably better.
 
  • Like
Reactions: Kuntitled

Kuntitled

Senior Member
Feb 21, 2019
122
42
Moto G6 Play
Samsung Galaxy Watch 3
For your statistics :) - my device has RETEU.
So... after about 24 hours nothing happened and I inserted a SIM card to be sure (but internet connection only via WLAN). Then after about 1 hour "OEM unlock" was active.
Maybe it's a topic for the FAQs "how to root": "you should not be afraid, in some cases this option can become active after 3(?) days / some time"?
What really worries me is the fact that a brand new device ("out of the box", not yet manipulated) has problems with "recovery mode" - an another reason to install TWRP to make backup properly.

And now I want to be sure: it is necessary to flash boot.img twice, so
fastboot flash boot_a patched_boot.img
fastboot flash boot_b patched_boot.img
?
"It works. I rooted mine, just keep in mind that since this is an A/B device, you have to flash the boot image to both boot_a and boot_b."
It's new for me, I have not done this (flash A&B, it was just "flash boot.img" once) on G7 Plus and it works very well (with EdXposed, XprivacyLua and so on). At that time I also read that with G7 I can't install TWRP permanently because it's such an "A&B device" (like G30 now...) and I have to choose, root or TWRP, or re-root the device after each use of TWRP, so "delete" TWRP again.
How does it look here?
t.
Author of that thread here.

At first i only did:
fastboot flash boot patched_boot.img

and it only flashed to the active boot img, which was b. Then to make sure i just flashed to boot_a and it worked flawlessly.
 
  • Like
Reactions: sd_shadow

Pasha1705

New member
Jul 25, 2021
2
0
Здравствуйте !!!
Помогите пожалуйста разобраться у меня moto g30 11(RRC31.Q1-3-34-1) в режиме разработчика включена отладка по usb и oem разблокировка тоже включена,что можно сделать?!?!
заранее спасибо!!!
 

Attachments

  • IMG_20210725_141222832.jpg
    IMG_20210725_141222832.jpg
    6.5 MB · Views: 21

sd_shadow

Recognized Contributor
Sep 21, 2011
18,107
1
8,678
South Dakota
goo.gl
Motorola Droid X
Moto X4
Здравствуйте !!!
Помогите пожалуйста разобраться у меня moto g30 11(RRC31.Q1-3-34-1) в режиме разработчика включена отладка по usb и oem разблокировка тоже включена,что можно сделать?!?!
заранее спасибо!!!
English only on XDA Please.
Google translation.
Hello !!!
Please help me figure it out moto g30 11 (RRC31.Q1-3-34-1) in developer mode debugging by usb is enabled and oem unlocking is also enabled, what can I do?!?!
thanks in advance!!!

Edit; try using the latest SDK Platform-Tools from Google
 

traber

Member
Oct 27, 2008
7
4
Здравствуйте !!!
Помогите пожалуйста разобраться у меня moto g30 11(RRC31.Q1-3-34-1) в режиме разработчика включена отладка по usb и oem разблокировка тоже включена,что можно сделать?!?!
заранее спасибо!!!
Hello, maybe it's not the reason of your problem, but did you start cmd as administrator?

cmd.png

cmd2.png

admin2.jpg
Sorry for my polish version of Windows :)
 

Pasha1705

New member
Jul 25, 2021
2
0
Здравствуйте, может это не причина вашей проблемы, а вы запускали cmd от имени администратора?

[ПРИКЛЮЧИТЬ] 5371661 [/ ПРИКЛЮЧИТЬ]

[ПРИКЛЮЧИТЬ] 5371675 [/ ПРИКЛЮЧИТЬ]

[ПРИКЛЮЧИТЬ] 5371673 [/ ПРИКЛЮЧИТЬ]
Извините за мою доработанную версию Windows :)
нет только что спробывал всьо тоже !!!
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Hello,
    I cannot activate OEM unlock on my Moto G30.

    View attachment 5333033



    Firmware: RRCS31.Q.Q1-3-34-1-4 (EU Retail), the device is not from the carrier, just from the shop (yesterday "out of the box").
    I have "OEM unlock" code from Motorola, but that doesn't help (because "OEM unlock" is not active).

    View attachment 5333035

    I tried to do hard reset, but under "Recovery Mode" I get "no command". After a few attempts, I was able to start "Recovery Mode" and do "wipe / factory reset", but that doesn't help as well.
    Even "Rescue" with LMSA from Motorola could not solve the problem (I tried 3-4 times).
    I can't do anything with fastboot either, because "OEM locked" = access denied.

    Is there a solution here or do I have to wait until a new OTA update comes and repairs(?) the firmware?

    TIA
    t.
    It's not unusual for OEM unlocking on Moto devices, to be greyed out.
    You need to connect to wifi/LTE and it should be available in 3 or so days after that.
    1-szare_LI.jpg
    1
    Hello,
    I cannot activate OEM unlock on my Moto G30.

    1-szare.png



    Firmware: RRCS31.Q.Q1-3-34-1-4 (EU Retail), the device is not from the carrier, just from the shop (yesterday "out of the box").
    I have "OEM unlock" code from Motorola, but that doesn't help (because "OEM unlock" is not active).

    2-niedas.JPG


    I tried to do hard reset, but under "Recovery Mode" I get "no command". After a few attempts, I was able to start "Recovery Mode" and do "wipe / factory reset", but that doesn't help as well.
    Even "Rescue" with LMSA from Motorola could not solve the problem (I tried 3-4 times).
    I can't do anything with fastboot either, because "OEM locked" = access denied.

    Is there a solution here or do I have to wait until a new OTA update comes and repairs(?) the firmware?

    TIA
    t.
    1
    Hello,
    I cannot activate OEM unlock on my Moto G30.

    View attachment 5333033



    Firmware: RRCS31.Q.Q1-3-34-1-4 (EU Retail), the device is not from the carrier, just from the shop (yesterday "out of the box").
    I have "OEM unlock" code from Motorola, but that doesn't help (because "OEM unlock" is not active).

    View attachment 5333035

    I tried to do hard reset, but under "Recovery Mode" I get "no command". After a few attempts, I was able to start "Recovery Mode" and do "wipe / factory reset", but that doesn't help as well.
    Even "Rescue" with LMSA from Motorola could not solve the problem (I tried 3-4 times).
    I can't do anything with fastboot either, because "OEM locked" = access denied.

    Is there a solution here or do I have to wait until a new OTA update comes and repairs(?) the firmware?

    TIA
    t.
    Try contacting motorola customer support or wait out for an OTA update which could fix it. But its best to contact motorola customer support first
    1
    It's not unusual for OEM unlocking on Moto devices, to be greyed out.
    You need to connect to wifi/LTE and it should be available in 3 or so days after that.
    View attachment 5333139
    Thank you, you give me hope :) (BTW I didn't have this problem with my G7 Plus two years ago...)
    This screenshot was taken without wifi access, but I also saw this hint and activated wifi (and inserted a SIM card as well), but it didn't help.
    If that's the case, then I'll wait a few more days (like with Samsung phones, where you also have to wait about 7 days for the developer menu to appear - at least that's how I read it).
    1
    Thank you, you give me hope :) (BTW I didn't have this problem with my G7 Plus two years ago...)
    This screenshot was taken without wifi access, but I also saw this hint and activated wifi (and inserted a SIM card as well), but it didn't help.
    If that's the case, then I'll wait a few more days (like with Samsung phones, where you also have to wait about 7 days for the developer menu to appear - at least that's how I read it).
    I use to see threads like this once and a while from people with devices on RetLA and a few others.
    But now since 2020, I see this problem a lot.