can't access samba share

Search This thread

pundulum

New member
Jul 2, 2008
4
0
I also had such problem that cannot connect to samba share (NAS device) from HTC Touch Cruise.
But when I upgrade NAS samga version to 3.0.30, then no more problems to me to connect to my NAS server. And without any registry change.

Sorry for my bad English.
 

Inner_Bushman

Member
Nov 28, 2008
20
4
Bytom
Hi.
I have the same problem with samba shares and total commander ( error 53 ) but i have found a workaround for this problem.

I'm using:
Ubuntu 10.04 LTS
Samba 2:3.4.7~dfsg-1ubuntu3.2
Windows mobile 6 (CE 5.2.1620) on HTC Artemis
Total Commander V. 2.51

To open a Windows share (samba) first make sure you have the LAN connectivity. To do so open any www in WM IE (e.g. Google.com).
Now open TC and do not go into \\Plugins. Just start typing in the address bar.
You can copy/paste the address if you have Ctrl button on your soft-keyboard since tap&hold method does not work on this address bar (donno why, someone ask TC authors :p )

Syntax as before:
\\servername\sharename
click 'Enter' on your soft keyboard.

That worked for me just fine without changing anything in samba conf files.
Let me know if that works for you too.

Bushman
 
Last edited:

amplatfus

Senior Member
Sep 26, 2009
316
48
OnePlus 8T
thanks

OK. The correct answer is here:

Change HKLM\Comm\SecurityProviders\NTLM\LmCompatibilityLe vel to 1 from 3, not to 2 (ref: msdn.microsoft.com/en-us/library/aa922895.aspx and msdn.microsoft.com/en-us/library/aa925018.aspx) as "You can also set the LmCompatibilityLevelServer value to 2 or to 3. Both of these specify that the server will only use NTLM v2. Authentication will fail if the client is not capable of NTLM v2 protocol. For more information, see Authentication Services Registry Settings".

And check to make sure HKLM\Comm\Redir\SmbSignatureMode is set to 0 (not recommended 'cos it may cause problems with windows servers), 1 or 2, but not 3 (ref: msdn.microsoft.com/en-us/library/aa921092.aspx).

And you can try to set HKLM\Comm\Redir\AllowedAuthMethods to 3 to see if it makes any difference. To me, 2 works fine.

No need to modify samba configurations if you are running a recent version of samba (3.0.28 right now). Anyway, you can always try to add "use spnego = no" (maybe "client use spnego = no" or "spnego = no" as stated and/or quoted in other posts/web pages, I'm not sure of it.) to see if it makes any difference in your situation/samba version.

I am very happy. I use to have the problem with Samba server on DD-WRT Firmware on ASUS Router with Topaz WM 6.5. After modify the registry it is working. Thank you so much :)