• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

cant access system partition in twrp

Search This thread

computerlove1

New member
Dec 3, 2021
2
0
hey i want to install a custom rom (gsi) so i hope some people can help me out

main info:
i have a ulefone note 9p with mediatek 6762 (runs with mediatek 6765 android scatter) and android 10.
this twrp is a twrp 3.4.0. built for ulefone note 9p i downloaded from here:

after going to the painful procedure of unlocking bootloader flashing stock and twrp modified rom + rooting the device

i stuck at the procedure to install a gsi image via twrp.

i already know that the device must be unrooted and i have already gained some experiences in flashing the rom
even after a few softbricks, so i will try installing this image with a stock rom and twrp after i received the help i need.

i use a sd card because twrp always disappears when i transfer a file via my phone and i land on stock recovery.
this problem solves when i root my phone via magisk. as i heard flashing gsi's dont work in a heavy modified state (like with magisk),
so a sd card solved this problem to run files on recovery mode without file transfer and rooting.

the problem i have is the following: i followed some instructions saying to wipe some data first in advanced wipe
- also the system partition which is not available. after that tried to install the image directly. as it finds the rom from my sd card i have to select the partition type to flash image
i only have boot recovery and super available but i need the system partition. i looked in the internet further (the painful process) and it gave me some hints going to mount.

there it finds the system partition but when i set a checkmark on it nothing changes, so this hint didn't helped me.

what should i do now? i'm stuck in some dead end and i don't know what to do it seems like this is the only way for me to get it work.
please help.
 

computerlove1

New member
Dec 3, 2021
2
0
i think i found something. since my phone is rooted i also tried to delete system apps which also don't work. i tried many system app removers but it always give error. i think the problem lies in permissions that are not given to this phone. how can i get full access to \ system to gain full permission rights? i also have busybox installed btw
 
D

Deleted member 1890170

Guest
You've to mount the /system partition as RW in order to access this storage location.

Example code:
Code:
adb devices
adb shell "su -c 'mount -t auto -o rw,remount /system'"