Can't add google account to Ticwatch pro LTE

LaurisLT

Senior Member
Apr 14, 2011
61
13
33
Kaunas
Looking for help adding a google account to wear os on Oneplus 6, using Pixen OS 11.
When trying to add the account phone screen goes white and hangs after entering the password. I thought that it might be a problem with the rom, but after reverting back to stock OOS 10.3.7 (android 10) the issue persists. Tried clearing play services data, different version of play services, removing and re-adding the account to the phone, wiping both the watch and the phone multiple times, with no solution. Anyone knows a fix?
 
Nov 25, 2009
5
2
23
Caen
Unfortunately, same for me with Fossil gen 5.
My watch was already sync with my account, Yesterday I did a reset of my phone and watch... But it was a mistake because I can't sync again...
I tried also to delete devices in my Google account, delete 2factor Auth,... But always Error 400 or blank page while copying my account.
:-(
 
Nov 25, 2009
5
2
23
Caen
Today I tried again and it finally worked without any more modifications....
Yesterday I delete devices in my Google account, delete 2factor Auth and reactivated later.
(I still didn't get reply to my message to Google)
 

1000moths

Senior Member
Nov 16, 2010
92
13
28
Not sure if this is still an issue for you guys but I had the exact same issue with Fossil Gen 5 and Pixel 5. I got around it by installing wearOS v2.39 phone app from apk mirror. Worked first time and was then able to update to the current version after adding the my account