Question Can't boot install TWRP on Note 11 Pro+?

Search This thread

zekepliskin

Senior Member
Oct 12, 2011
68
6
I have the Chinese edition of this phone, which I put the Global ROM version onto (MIUI 13), bootloader unlocked.

However with fastboot on either the stock Chinese ROM or Global ROM I cannot get TWRP to install to 'recovery' (even tried 'recovery-a' and 'recovery-b' and 'rescue' based on the .img file in the Global ROM .tgz). It just says for all the 'recovery' options when trying to flash, 'This partition doesn't exist'.

It won't even one-time boot with the "fastboot boot twrp.img" command when the phone is in fastboot mode.

I'm using the 3.6.0 "pissarro" build. Can't seem to find any others that are built for this phone; it's usually older models such as the 10 Pro, not the 11 Pro or Pro+.

It either says it's booting and doesn't (usually boots MIUI again), or fails with the command line error "FAILED (Status read failed (Too many links))".

I'm starting to think most of the guides and tools out there are for older Xiaomi phones which is why it's not working. When flashed with the Global ROM or Chinese ROM you do get stock recovery with booting when Volume+ is held down, that's it.

As TWRP seems key to getting any kind of custom ROM onto the device such as Lineage OS, and for proper rooting, I'm basically stuck with MIUI unless anyone knows better?

Thanks in advance to anyone who offers suggestions. I've tried for several hours now and nothing...