Can't boot into Recovery, Bootloader, Download, or Fastboot! Why?

Search This thread


Dec 28, 2017
The bootloader must be unlocked if you can obtain the token from lenovo support. There are ways to get around this by flashing a "bumped" kernel/recovery. But in your situation it might not even flash (locked). The bumped kernel might be designed so as to allow a custom ROM to pass verification. More on that subject here
Kernel/recovery from your device forum or from twrp website should already be bumped. The question is: will it flash?

ok, so what do you advice me to do first? I don't know what to do, it is the first time i go so deep in android and i have no knowledge / experience ... I feel a bit st^pid for all these questions but ...


Dec 28, 2017
I'm trying to do all these... Failed is the only answer.


Teddy Lo

Senior Member
Nov 8, 2017
I have an LG Optimus Fuel (LG L34C) from Straightalk running Android 4.4. This phone is (as far as I know) the same as the LG Optimus Zone 2 from Verizon Prepaid.

I couldn't find a halfway decent manual for the LG L34C so I followed the LG Optimus Zone 2 Manual to enter Recovery mode. When I held the buttons on the L34C, it would boot, show the LG logo, then shut off, show the LG logo, and do it again. As long as the buttons were held in would loop.

So I downloaded the ADB and tried to do it from there.

"adb reboot recovery" brings up the classic "No Command".
"adb reboot bootloader" just reboots it.
"adb reboot download" just reboots it.
"adb reboot fastboot" just reboots it.

What the heck is going on! I'm going crazy trying to figure this out. Why can't I access any of the special menus?

Oh, and TowelRoot didn't work to root the phone either.

The only reason why it didn't work was because when the LG logo appears you have to let go of power (while still holding volume down), then press and hold power again until reset screen appears (note: dont let go of the volume down at all until the reset screen appears, only let go of the power button then press and hold it again after)
  • Like
Reactions: ibub


Senior Member
Oct 22, 2012
ok, so what do you advice me to do first? I don't know what to do, it is the first time i go so deep in android and i have no knowledge / experience ... I feel a bit st^pid for all these questions but ...

I'm trying to do all these... Failed is the only answer.

Try rename twrp.img to recovery.img and temporarily boot to it using
fastboot boot recovery.img
I am not a fastboot expert, but it seems safer to try it before flashing it
  • Like
Reactions: LeoPap

Top Liked Posts

  • There are no posts matching your filters.
  • 5
    To anyone who hasn't been keeping up at, I have twrp compiled with the added option of backing up the internal sdcard. It is fully functional except the clock still. Teamwin compiled theirs for the wrong processor and still haven't fixed it so I will be uploading mine this week after testing is complete ? haven't found anything wrong except the clock so I was thinking even within the next couple days ?

    The newer version has mtp support as well, meaning you can hook it up to the computer while in recovery and simply copy and paste stuff into your SD folders. There's a lot of other great features as well. Oh, and you can also restore a backup made with my 2.8 version if anyone was wondering...

    EDIT: Almost forgot to mention I also have cwm compiled and ready to go. I will be uploading that as well at the same time as twrp or maybe sooner. Maybe one of these days I'll take a shot at compiling PhilZ as well...
    LG has fastboot locked out. I was browsing the LG G2 forums when I found that people are able to get to fastboot by zeroing out their 'laf' partition and forcing the phone into fastboot (because aboot can't find it) where we can then flash a custom recovery.img hopefully. I have the recovery partition extracted and replaced /sbin/recovery with CWM and repacked. I just need to get into fastboot to test it. I will get a second phone from walmart to dev with, they're only $30. if anyone has a dev phone to test it on, read on...

    This is theory and hasen't been tested. We may not even be able to run custom recovery or fastboot.

    If anyone wants to pick up here be sure you have fastboot and adb installed and have some dev knowledge, not for noobs like me.

    backup your laf partition to an external SD card (insert a micro SD)
    dd if=/dev/block/platform/msm_sdcc.1/by-name/laf of=/storage/external_SD/laf.img
    pull laf.img to your computer as a backup and to use later in fastboot
    wipe your laf partition [I AM NOT RESPONSIBLE IF YOU KILL YOUR PHONE]
    dd if=/dev/zero of=/dev/block/platform/msm_sdcc.1/by-name/laf
    reboot your phone and connect it to your computer.
    your phone SHOULD (I have not tested this) boot into fastboot as a failsafe.
    on your computer
    fastboot flash laf laf.img
    fastboot reboot
    phone should reboot back to normal.

    This will test that we can in fact get to fastboot.

    STOCK laf, boot & recovery files to look at. The included repacker does not repack the images properly. I use linux tools for repacking.
    Just to let everyone know, I have been successful at creating a both twrp and cwm for this device. I also created a custom boot image that allows you to boot into recovery by tapping volume up while booting and it also has built in init.d support. I'm going to thoroughly test everything and have others test it then she will be all yours guys! ?
    When flashing firmware to my previous LG p500, I didn't need a special cable. As I recall, the LG update tool was able to put the phone into download mode. But the drivers need to be installed to computer first. To use KDZ, I think I had to hold key combinations for the p500, but not power button, while plugging into computer. This would set download mode. But with this phone...I'm stumped.
    What is the function of this cable?

    Sent from my LGL34C using XDA Free mobile app

    ---------- Post added at 03:55 PM ---------- Previous post was at 03:22 PM ----------

    Please document any successful methods here on the thread, for the benefit of everyone here. I have a feeling that there will be a lot of bricks here. :rolleyes:

    Sent from my LGL34C using XDA Free mobile app

    Okay so this is actually fairly simple for once, I will cut out all the useless info and only post the stuff relative to the optimus fuel..if you have softbricked your device or maybe your not sure yet, first things first you need to plug it up to the pc in windows it will mount the phone like it would a thumbdrive, instead of showing the phone name under my computer it will now show it as a drive open that up and you will see two folders image and verinfo, if that is the case then you are ready to attempt to un-softbrick it.

    The second thing you are going to have to have is a copy of linux installed, I use a dual boot of mint and win 8.1, I tried this on a virtual machine as well and it did not list things I cannot say whether a vm will work for sure.

    So boot into your linux os on pc and plug the phone to usb to pc.

    Now open up console

    type in ls /dev/sd* -----press enter

    This will show you a big list of partitions, whichever partition you see with the highest number for instance sdf32 then take note of it as it is where your device is being detected.

    now with the result of the last command you typed from console enter gdisk -l /dev/sdf <----i am using sdf because that is what mine listed, i assume it will be the same, let me know if for some reason it is not, but would probably work anyway press enter and you will get a big list of the partitions, with numbers associated with them it will look something like this below

    Number Start (sector) End (sector) Size Code Name
    6 229376 231423 1024.0 KiB FFFF aboot

    but with many more numbers listed pay attention to those numbers, especiallly to the ones associated with the .img you may have altered to brick your phone in the first place, because you will be wanting to replace those .img with the originals.

    So....if you have messed up any of those partition images listed for instance the aboot is listed under sdf6 in the above example then you first need to be root in the console by typing sudo -i and enter your admin pw press enter to run console as root.

    now lets fix out aboot with none other than dd commands in the console you enter
    dd if=/path/toyour/aboot.img of=/dev/sdf6 and then press enter and it should push the image back.
    Once you have pushed all the images back that you need/want then simply hold power button down til the phone reboots and hopefully you see the logo again, i have recovered my own from messing with aboot twice, as far as the other partitions I cannot say as I have not messed with them much, i can say that abootb modifying it does not softbrick or do anything that i can tell, unless i type adb reboot recovery after changing it i get a security error instead of the regular booting right into the os.

    so just make sure to use sdf6 instead of most of the time you would use of=/dev/block/platform/msm_sdcc.1/aboot but since it is in bulk mode it changes to /dev/sdf6 and the gdisk -l /dev/sdf will give you the list of them all so you will know which # the img should be associated with hope that helps someone out there, I used the following post to figure all this out on my own for this device, i used all that info just simply modified it to fit my own needs, so if any thanks is given give it there.

    Once y

    ---------- Post added at 03:34 PM ---------- Previous post was at 03:26 PM ----------

    Also i found a post that tells you how to get into stock recovery if that helps or not i dunno, but it does work.

    the first is a way to run it in a script i had probs with it.

    cd /cache/recovery
    echo "--show_text" >> command
    chmod 644 command
    reboot recovery

    Now This is what I used thru adb and it works, however it doesnt stick for next time i have to enter this again just to get into stock recovery.

    adb shell
    cd /cache/recovery
    echo "--show_text" >> command
    chmod 644 command
    reboot recovery

    this info came from
    Loki exploit already Patched

    I did not know about the Loki tool, good find. I had dumped and decompiled the laf partition. I have no way of knowing how to get to it through commands tho. I think its used for LG's proprietary flash tool.

    I have aboot dumped and took a look at it in hex editor. Most aboot partitions are signed and cant be modified
    as they pertain to the hardware in the phone. HOWEVER, we can read them and use the info in them as the Loki tool does.

    The method that Loki uses is patched in our aboot. Relevant Patch Commit

    Verified with disassembly of my aboot from my LG lgl34c Fuel

    ROM:0004A454 "kernel/ramdisk addresses overlap with aboot addresses.\n"
    ROM:0004A684 "Device tree addresses overlap with aboot addresses.\n"
    ROM:0004A6BC "Boot image buffer address overlaps with aboot addresses.\n"
    ROM:0004A6F8 "Signature read buffer address overlaps with aboot addresses.\n"

    Relevant exploit section from Loki author djrbliss' notes:

    Exploitation of this flaw proved to be fairly straightforward. I prepare a specially crafted boot image that specifies a ramdisk load address equal to the address of the check_sig() function in aboot physical memory. In my malicious boot image, I place shellcode where the ramdisk is expected to reside. I flash this image by leveraging root access in the Android operating system to write to the boot block device. When aboot reads the supposed ramdisk from eMMC flash, it actually overwrites the check_sig() function with my shellcode, and then invokes it. The shellcode simply patches up the boot image header to contain sane values, copies the actual kernel and ramdisk into appropriate locations in memory, and returns zero, indicating the signature verification succeeded. At this point, aboot continues the boot process and finally boots my unsigned kernel and ramdisk. Victory!

    I'm still digging lol