• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Can't boot into TWRP

Search This thread

zachjen

Member
Apr 22, 2010
28
1
OnePlus 8T
Pixel 3a xl
Android 10 March update

Having problems rooting

Rooting by patching the boot.img with Magisk patch file causes a bootloop.

Tried rooting by installing Magisk via TWRP but when it tries to boot into TWRP I get an error "failed (remote: 'Error verifying the received boot.img: Invalid Parametery" and it won't boot or install TWRP.

I've tried multiple cables, multiple computers, multiple factory resets, fresh installs, unlocked and relocked bootloader, all with the same result when I try boot into TWRP.



Please help.
Thanks
 

thatsupnow

Senior Member
Jan 31, 2011
2,496
591
Vernon
Google Pixel 3a XL
Google Pixel 5
Pixel 3a xl
Android 10 March update

Having problems rooting

Rooting by patching the boot.img with Magisk patch file causes a bootloop.

Tried rooting by installing Magisk via TWRP but when it tries to boot into TWRP I get an error "failed (remote: 'Error verifying the received boot.img: Invalid Parametery" and it won't boot or install TWRP.

I've tried multiple cables, multiple computers, multiple factory resets, fresh installs, unlocked and relocked bootloader, all with the same result when I try boot into TWRP.



Please help.
Thanks

Lol. There's no TWRP for Android 10 and most likely will never be. That would be your main issue right there
 
  • Like
Reactions: mward7221

sic0048

Senior Member
Jun 25, 2010
965
504
Google Pixel 6
Ok. Yeah that could be a problem.

Anyone know why the boot image patch way of rooting causes a bootloop?

Where you already rooted and then it is bootlooping when you updated to the March release? If so, it is likely because of a Magisk module that you have installed that isn't compatible with the March update. There are threads here that walk you through the process of removing Magisk modules without TWRP.

If this is your first time rooting on this phone and you are getting a bootloop, I suspect it is something wrong with your procedure. Usually a bootloop in that situation is because you are not using the stock boot.img file from the current OS version you are running when you use Magisk to modify the file. For example, if you updated to the March release, but somehow are trying to use Feb release's boot.img file you will get a bootloop.

EDIT - also apparently there may be an issue if you are using the latest Canary Build of Magisk with the March update. There isn't a problem with the current stable build and the March update. If you are using the latest Canary build, then this is likely your issue.
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Pixel 3a xl
    Android 10 March update

    Having problems rooting

    Rooting by patching the boot.img with Magisk patch file causes a bootloop.

    Tried rooting by installing Magisk via TWRP but when it tries to boot into TWRP I get an error "failed (remote: 'Error verifying the received boot.img: Invalid Parametery" and it won't boot or install TWRP.

    I've tried multiple cables, multiple computers, multiple factory resets, fresh installs, unlocked and relocked bootloader, all with the same result when I try boot into TWRP.



    Please help.
    Thanks

    Lol. There's no TWRP for Android 10 and most likely will never be. That would be your main issue right there