• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Can't change Bluetooth audio codecs or

Search This thread

s4shield

Senior Member
Aug 23, 2015
223
42
I got the Oreo update and in developer options you're supposed to be able to change the codec, samplerate and a few other things to improve Bluetooth audio. However when I select a codec it doesn't change. It defaults to aac. I wanted to use Ldac. Tried aptx hd and Samsung hd as well and they don't work. ☹️
 

jUsT2eXy

Senior Member
Mar 17, 2010
405
18
I have the same issue. When you select for example, AptX, the settings don't seem to stick.

Any suggestions? Thanks!
 
  • Like
Reactions: s4shield

mxEin

Member
Apr 27, 2016
32
5
Apt-X is the best. That being said, the bluetooth device you connect too has to be compatible. Maybe that's why it switches back to AAC for you. (It sticks to apt X in my case)
 

starfishhaha

New member
May 29, 2018
1
3
Yo, everyone. I use a sennheiser gt 4.40 with aptx with s8. If you want to enable aptx. first go to BLUETOOTH settings, click the 3 dots. disable the duo bluetooth audio and then go to the developer settings, you will see it's working. but to be honest, I find no difference between these. LOL
Cheers :p:p;)
 
Last edited:

EP2008

Senior Member
Jan 2, 2008
2,946
580
Toronto, Ontario, Canada
Yo, everyone. I use a sennheiser gt 4.40 with aptx with s8. If you want to enable aptx. first go to BLUETOOTH settings, click the 3 dots. disable the duo bluetooth audio and then go to the developer settings, you will see it's working. but to be honest, I find no difference between these. LOL
Cheers :p:p;)

Finally! Disabling dul audio is what allows the setting to work on my Note 8. Using Forza Metallo headphones there is a VERY noticeable improvement when using aptx!
 

P_P_P

New member
Jun 14, 2018
1
0
The audio codec is switching back from LDAC because your bluetooth headphones/speaker doesnt support LDAC. Same would be the case with APTX HD.
 

RCA1186

Member
Mar 24, 2018
5
1
Yo, everyone. I use a sennheiser gt 4.40 with aptx with s8. If you want to enable aptx. first go to BLUETOOTH settings, click the 3 dots. disable the duo bluetooth audio and then go to the developer settings, you will see it's working. but to be honest, I find no difference between these. LOL
Cheers :p:p;)

My problem is my stereo in my car is older and needs to use the SBC codec to stay connected with any reliability, but the phone automatically switches back to AAC when it connects to it. If I switch it back to SBC after it connects I have no connectivity issues but if I leave it on AAC it disconnects every 5 mins, won't display some track information, etc.

Duo bluetooth audio is not enabled, I have changed settings with both bluetooth and duo audio off. It will accept the change to SBC, but it reverts back to AAC when the stereo connects. The phone will not accept any change to any other bluetooth developer option either, when I exit the developer options and go back in they all are reverted back from my changes. Quite frustrating.
 
Jun 27, 2012
34
3
Yo, everyone. I use a sennheiser gt 4.40 with aptx with s8. If you want to enable aptx. first go to BLUETOOTH settings, click the 3 dots. disable the duo bluetooth audio and then go to the developer settings, you will see it's working. but to be honest, I find no difference between these. LOL
Cheers :p:p;)

Just logged cause of this solution, thank you comrade, this solved the issue.
 

mikey_sk

Senior Member
on the s9 plus u can only change to profiles whilst playing sound through the bluetooth headphones and only codecs the headphones support. when you re-pair it will auto select the best codec the headphones support anyway so no need to change it at all. i would leave this setting alone unless you want to dowbscale the codec (as it picks the best one for your bluetooth device)
 
  • Like
Reactions: myshokk

frankfrank1

New member
Jan 14, 2011
1
0
Codec change on S8 does not stick

I have tried the dual audio status trick mentioned above for Note 8, but it doesn't work for my S8. I can select AptX in the developers section, but when you return to that section, the codec selected reverts to SBC. I have a pair of earbuds that supports AptX. Is Samsung pulling a fast one on us?
 

slider2828

Senior Member
Jul 19, 2010
1,153
128
I have tried the dual audio status trick mentioned above for Note 8, but it doesn't work for my S8. I can select AptX in the developers section, but when you return to that section, the codec selected reverts to SBC. I have a pair of earbuds that supports AptX. Is Samsung pulling a fast one on us?

Worked for my s8. I am using it with a fiio q5. Aptx sticks after duo audio disable.
 

Pfeffa-rah

Senior Member
Sep 26, 2005
270
2
Enschede
www.pfeffa.dds.nl
My S7 kept reverting back to aptx after I used LDAC With mij Sony 1000mx2.
There is an extra setting in the bluetooth settings for that headphone (tap the little)cog) to enable LDAC.
Switching that on worked for me.
 
  • Like
Reactions: sjnsth

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    I got the Oreo update and in developer options you're supposed to be able to change the codec, samplerate and a few other things to improve Bluetooth audio. However when I select a codec it doesn't change. It defaults to aac. I wanted to use Ldac. Tried aptx hd and Samsung hd as well and they don't work. ☹️
    3
    Yo, everyone. I use a sennheiser gt 4.40 with aptx with s8. If you want to enable aptx. first go to BLUETOOTH settings, click the 3 dots. disable the duo bluetooth audio and then go to the developer settings, you will see it's working. but to be honest, I find no difference between these. LOL
    Cheers :p:p;)
    2
    I have the same issue. When you select for example, AptX, the settings don't seem to stick.

    Any suggestions? Thanks!

    Try deactivating Bluetooth, then change the codec. Should work. Cheers
    1
    I have the same issue. When you select for example, AptX, the settings don't seem to stick.

    Any suggestions? Thanks!
    1
    on the s9 plus u can only change to profiles whilst playing sound through the bluetooth headphones and only codecs the headphones support. when you re-pair it will auto select the best codec the headphones support anyway so no need to change it at all. i would leave this setting alone unless you want to dowbscale the codec (as it picks the best one for your bluetooth device)