Can't exit bootloader after trying to reinstall TWRP on android 10

Search This thread

redpoint73

Inactive Recognized Contributor
Oct 24, 2007
15,259
6,950
How do you install TWRP from Magisk?

Was already explained to you in Post #9 above. Once you have the patched boot image installed, you should be able to see the "Modules" option in the Magisk Manager menu. Just install the TWRP.zip as a module.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    I updated to android 10 an hour ago, and placed my phone into the bootloader so I could re-flash TWRP. After I ran the command (fastboot flash boot C:\Users\USER\Downloads\twrp-3.3.1-4-guacamole.img), and tried rebooting, I couldn't leave the bootloader. I've tried using the buttons, trying to push the img to the phone and force it into TWRP, but nothing works. I think I didn't enable USB debugging when I entered the bootloader, but it was enabled before I updated.

    First you don't flash the TWRP image.
    That image is used as a fastboot boot. It is not to be flashed.

    Normally, you would boot with that image and flash the TWRP zip to make it permanent.
    Once TWRP is flashed, you need to also flash Magisk.
    To get out of the situation you are in, you need a stock boot image to flash.
    Once that is done, you can start over.

    Read the instructions carefully before flashing images.
    1
    Just to clarify then, when I run fastboot flash boot TWRP, I use the zip? If not, what command am I using?!

    Hope I can explain myself. You are using a command you shouldn't be using: fastboot FLASH boot, you shouldn't flash the image from fastboot, you need to use that image to boot into recovery and then flash recovery itself from INSIDE recovery, then you NEED to flash Magisk from inside recovery too.

    The command is: fastboot boot recovery.img

    Btw, you can't see the "modules" option in Magisk because I think you flashed stock boot.img. Try flashing Magisk patched boot img and then flash recovery in Magisk as it was said before.
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone