• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Can't get TWRP to work and can't get into OS

Search This thread

r3v0

Member
Nov 27, 2007
30
8
I use Linux mint 19.1 based on Ubuntu 18.04 and run newflasher as root while having my phone in download mode.

Maybe a different USB port could help

download mode? Is that different from flash mode/fastboot mode?

Aaaand I managed to flash stock rom. Yessss

Now I need to root it.
Magisk 18.1 didn't work. I got stuck in bootloop.
 
Last edited:

r3v0

Member
Nov 27, 2007
30
8
After extensive reading on the net I found out that, if You flash magisk through TWRP, You don't boot directly from that screen where you flashed it, but go to the main menu and power off from there. Than it works. ????
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Maybe yes.
    I never saw this message. Hmmm.
    At least one xz3 user I know from is happy with the twrp.
    Weird, very weird.

    I whish I could reproduce it. :(

    TWRP worked until I messed up the boot.
    When I now try to fastboot flash boot boot.img I get this:
    FAILED (remote: 'Error flashing partition : Volume Full')
    1
    I managed to get it to boot to twrp. I guess at some time I set-active it to b. Setting it back to a solved the not booting twrp.

    Now I used the vbmeta.img from twrp to set vbmeta.

    Gonna try rooting it again now.
    OS not booting yet.
    1
    I recommand flashing the entire firmware via newflasher.
    Remove the userdata.sin so you don't wipe your phone.

    So, I just found out You're the developer of what I downloaded. :)
    Can I flash this one:
    H9436_Customized CE1_1316-3759_52.0.A.3.84_R9B.tar.gz
    through newflasher?
    1
    Ok, thanks so far. You pointed me in the right direction. Hopefully I get my Xz3 running again. ??
    1
    I'm optimistic, that you'll achieved success. :)

    In the end. :D

    Now i'm struggling with an error with newflasher.
    No usb device with vid:0x0fce pid:0xb00b

    Oh yeah, I'm on linux. So I'll have to do all my windows stuff through a VM