Cant get Walmart Samsung Galaxy XCover Pro into download mode

Search This thread


Senior Member
Aug 15, 2016
So I worked for Walmart for a while.
They gave me this free phone. See below.

The phone was locked out by Walmart for inactivity. (See image for details)

I fixed that with a hard factory reset from the recovery menu.

I was given explicit permission to KEEP the phone after I stopped working there. The phone thinks it's still part of the organization.

Ive downloaded a firmware file for the specific model ( SM-G715U1 ) so I can flash it and use it, but the device will not enter download mode.
I'm beginning to think its not possible.

I have access to developer options. I have access to adb. I have access to the recovery menu.

'adb reboot download' result:

Ive tried every button combination imaginable repeatedly.

Reboot to bootloader from the recovery menu just reboots the phone to lock screen like normal.

Have also tried:
Remove battery and reinstall (unplugged from PC) Press the Volume Up, Volume Down, and Power Button(All 3 on right side) at the same time.
And several variations of button combinations and plugging into PC. (Volume up + Volume down + plug into phone) Does not work...

Also Note that Samsung 300K Tool does not work, phone reboots like normal (No Download Mode).

Any help would be greatly appreciated.

ADB Serial Number : R58R82F3NKV
Model Name : SM-G715U1
Device CodeName : XCOVERPRO
Hardware : EXYNOS9611 EXYNOS9611
Modem Board : SHANNON337
HW Version : REV0.3
BL version : G715U1UESEBVB1
AP version : G715U1UESEBVB1
CP version : G715U1UESEBVB1
CSC version : G715U1OYMEBVB1
Android version : 11
Build date : Thu Jan 27 14:06:47 KST 2022
Country : USA
IMEI : #################
Serial Number : N/A
Carrier : XAA
Debug Level : 0x4f4c
CP Debug Level : N/A
Warranty VOID : 0
SIM operator : N/A
USB Settings : MTP,ADB

Last edited:
Oct 2, 2022
I was able to disable all Knox admin apps and all knox work app, but it seem like seem to be the package that is triggering that warning sign and I want know if y’all were able to uninstall or disable it by anyway for it to not trigger a lock? Thanks.


New member
Oct 2, 2022
Hello typing this i already understand that I will sound like a complete noob and tbh that is 100% truth lol. Either way I was hoping y'all would be inclined to help me out still. I have this phone and have tried my ass off to get through this **** and set up as a personal device and at the moment I have never been at more of a wall. Thank you anyone on here with the know how and the patience in advanced to helping my dumbass at this point I feel like i shouldn't be able to eat ****ing Campbell's Soup without a helmet on!!!!


New member
Oct 16, 2022
I am in exactly the same situation, my daughter just got a new job and moved on from walmart, they locked the phone, her boyfriend got a different job months ago, and his is locked for inactivity, so they gave them to me to wipe. So here i am. So far i found 1 video on youtube for all samsungs 2022 i pointed him here, and another person on this site says hes done dozens of xcover pros with knox. hopefully they can reveal some helpful info on us.

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    how did u get into download mode
    Try this let me know if it works.

    Boot to recovery by:
    Turn off the phone.
    Hold volume + and power, let go of power, keep holding volume + until it boots to recovery menu.
    Factory data reset 3 times. Clear cache 3 times.
    Power off.

    Boot to download mode by:
    Hold volume +, volume -, and power all at the same time and don't let go.
    It should boot into download mode.
    to every one here i figured it out how to get in to download mode if you got discord xxxxxxxx

    Mod Edit: Some content removed.
    Asking users to contact you privately for solutions is frowned upon by XDA. If you share your solution publicly, it will benefit all.
    Crazy I have been working on this same thing for the past few months, started screwing with it again a few nights ago. good luck
    seems pretty messed up that they never asked me for the equipment back, took money from my last check automatically for the device and now that it's "mine" I can't even use it for anything because it's all locked up with knox
    Here is something for people to play with for the time being.

    1. Factory Reset
    2. Tap 6 Times on the Welcome! Screen
    3. Scan this QR Code:


    4. Register an Account, Sign in, and see what you can do from there.