Cant get Walmart Samsung Galaxy XCover Pro into download mode

Search This thread


Senior Member
Aug 15, 2016
So I worked for Walmart for a while.
They gave me this free phone. See below.

The phone was locked out by Walmart for inactivity. (See image for details)

I fixed that with a hard factory reset from the recovery menu.

I was given explicit permission to KEEP the phone after I stopped working there. The phone thinks it's still part of the organization.

Ive downloaded a firmware file for the specific model ( SM-G715U1 ) so I can flash it and use it, but the device will not enter download mode.
I'm beginning to think its not possible.

I have access to developer options. I have access to adb. I have access to the recovery menu.

'adb reboot download' result:

Ive tried every button combination imaginable repeatedly.

Reboot to bootloader from the recovery menu just reboots the phone to lock screen like normal.

Have also tried:
Remove battery and reinstall (unplugged from PC) Press the Volume Up, Volume Down, and Power Button(All 3 on right side) at the same time.
And several variations of button combinations and plugging into PC. (Volume up + Volume down + plug into phone) Does not work...

Also Note that Samsung 300K Tool does not work, phone reboots like normal (No Download Mode).

Any help would be greatly appreciated.

ADB Serial Number : R58R82F3NKV
Model Name : SM-G715U1
Device CodeName : XCOVERPRO
Hardware : EXYNOS9611 EXYNOS9611
Modem Board : SHANNON337
HW Version : REV0.3
BL version : G715U1UESEBVB1
AP version : G715U1UESEBVB1
CP version : G715U1UESEBVB1
CSC version : G715U1OYMEBVB1
Android version : 11
Build date : Thu Jan 27 14:06:47 KST 2022
Country : USA
IMEI : #################
Serial Number : N/A
Carrier : XAA
Debug Level : 0x4f4c
CP Debug Level : N/A
Warranty VOID : 0
SIM operator : N/A
USB Settings : MTP,ADB

Last edited:


New member
Jan 10, 2023
Could somebody please share on how to bypass KG and get rid of the Walmart warning pop-up? Thank you kindly.
So this will be my first post under this new screen name but I've been with XDA developers since I could remember this form is always helped me out so I thought that I would reply to this I have a Galaxy x cover pro that was once a Walmart phone and I have screenshots to successfully prove that it's possible. I will attach them in this post and the tool that I used along with the process of doing so... I hope that this is what you guys are talking about I've never heard of Samsung kg but I do know that those phones are knox cloud enabled and without disabling knox.... Your fried.... But....

Here's how I came about my COMPLEATLY useable sgxcp .

Well.... First. It was found. Picked it up. Asked around. No one claimed it. So. I took it home and factory reset it. Boom.... Google locked.... Well. Then I was looking for fro bypasses and stumbled across this tool.....

I'll post tool here after while.

Then. I clicked on the 2022 frp bypass update button.

Then that ran a bunch of adb commands which I'm not able to see , then it rebooted and everything was gravy I thought.


Now. It was trying to register as an enterprise and it had knox cloud security and as soon as it connected to wifi. It was like "NO IM NOT WORKING"

SO.... Then I rebooted the phone. And then had the tool go ahead and then I clicked the remove knox button....

It said can't enable adb debugging. " Try that first " then I remembered that it had just given me a debugging pop up after it read and started sending random adb commands which subsequent lead to a little adb USB authorization popup!!!

So. I rebooted and started over. Bc after the initial reboot after the first FRP removal the tool wouldn't recognize the phone it kept saying that it couldn't find an ADB device so I clicked the 2022 method again and then without rebooting it with ADB still enabled I then ran the remove nox script from the tool which then said removed two packages and then it started to reboot or I rebooted it I can't remember but there was one reboot and when it started over it had no Enterprise I didn't ask anything about Walmart nothing......

I've got screenshots to prove it. And I'll link the tool also.

It's one of the many MANY Samsung frp tools out there. I had to install some prerequisites like .net framework and some other drivers. But as soon as I did. The phone WAS MINE ! 👍😜💯👋😎😁🤪🤑🤓🤓🤓🤓🤓🤓🙌🙌🙌🙌🤘👍



  • SamFw_Tool_v3.31.rar
    10.7 MB · Views: 114
    11.6 MB · Views: 101


New member
Jan 22, 2023
I followed every step reading this forum from start to end an still have gotten nowhere i was able to get past the beginning setup using Sam but no farther, after that spot no mater how many things I tried nothing on on Sam was able to get adb enabled even though I already accepted the debugging prompt


New member
Jan 10, 2023
I followed every step reading this forum from start to end an still have gotten nowhere i was able to get past the beginning setup using Sam but no farther, after that spot no mater how many things I tried nothing on on Sam was able to get adb enabled even though I already accepted the debugging prompt
Did you already downgrade as low as you could with what would probably need to be a patched version of odin3 then flash down as low as you can with your binary staying the same.

And then.

So after the Odin reboot after a successful firmware reflash ,

You then need to run a factory reset (I did it after enabling the prompt.

Then. After the reboot with the adb commands. I went back to the tool , hurtyd up and hit the remove Samsung apps and then it said successfully removed like 11 packages. Then. I adb rebooted from the same tool. Got it restarted. And started setting it up. I ddenied all Samsung stuff in the setup. Then once on the home screen after the finishing up of wizard it took me to the home screen.

I wish I could be there man. I wanna see what your talking about.

Is there a way you could maybe upload a few pics or a video to maybe help us understand and see the phone as it is being scripted by the tool and see the tools output on the side. Copy and paste that here if you don't mind.

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    how did u get into download mode
    Try this let me know if it works.

    Boot to recovery by:
    Turn off the phone.
    Hold volume + and power, let go of power, keep holding volume + until it boots to recovery menu.
    Factory data reset 3 times. Clear cache 3 times.
    Power off.

    Boot to download mode by:
    Hold volume +, volume -, and power all at the same time and don't let go.
    It should boot into download mode.
    to every one here i figured it out how to get in to download mode if you got discord xxxxxxxx

    Mod Edit: Some content removed.
    Asking users to contact you privately for solutions is frowned upon by XDA. If you share your solution publicly, it will benefit all.
    Crazy I have been working on this same thing for the past few months, started screwing with it again a few nights ago. good luck
    seems pretty messed up that they never asked me for the equipment back, took money from my last check automatically for the device and now that it's "mine" I can't even use it for anything because it's all locked up with knox
    Fastest Walmart Lockout bypass method so far.

    1. Factory reset
    2. Run SamFw FRP Tool 3.0
    3. Run Disable Knox
    4. On startup page open up emergency call and dial *#0*#
    5. On Phone tap always allow and allow
    6. Stop FRP Tool before it has a chance to make any changes, or at least before it reboots the phone
    (We only needed it for ADB access)
    7. Download and run:
    8. Disable
    9. Disable
    10. Disable
    11. Search "Knox" and disable all of them
    12. Reboot


    You'll need to go into settings, Accessibility, Interaction and dexterity, and Enable the Assistant Menu to get around at first. Just until you install a persistent nav bar and notification bar app.