• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Can't Install WhatsApp on custom rom

Search This thread

The Carpenter

Member
Nov 24, 2021
7
2
Dear Forum members,

I have lineae 15.1 on my Samsung S2 GT-19100 Running Oreo 8.1.0.

WhatsApp stopped supporting my version and said I needed ot upgrade. I couldn't upgrade. Just nothing happened when I tried to update.
I couldn't download via the phone so I downloaded a good .apk file and installed it via my desktop computer.
After I installed WhatsApp the app said my phone date and time was wrong so I recalibrated the date and time but it still said phone date and time is wrong.

So it was stuck on that notification page... Phone date and time is wrong.

Then it said WhatsApp does not support custom Roms. Is there any way to get WhatsApp to work on my custom rom? I've tried all I know and I can't get it working.

Thanks Community

Tim
 
I have lineae 15.1 on my Samsung S2 GT-19100 Running Oreo 8.1.0.
Looking at Whatsapp's FAQ it seems like Whatsapp doesn't support custom roms and/or rooted devices. And if I understood your question right, you are currently running Lineage OS. So I would think your best hope would be finding an mod that supports rooted/custom rom devices or modding the app yourself.

If my answer helped you please upvote it to show your appreciation,
Jamie
 
  • Like
Reactions: The Carpenter

jwoegerbauer

Senior Member
Jul 11, 2009
7,570
26
1,763
European Union
Your question got answered by WhatsApp themselves:

 
  • Like
Reactions: The Carpenter

RVR

Recognized Contributor
Oct 29, 2012
1,757
1
2,887
Mumbai
rutvikrajagopal.in
Samsung Galaxy S7 Edge
Try using the latest WhatsApp apk from apkmirror. I think it has more to do with the version you have installed. WhatsApp tends to disable the old APKs.
Also, although they say they don't support custom roms, it's just a pop-up that says you may face issues because you are on a custom rom which you can just click 'ok' and move forward.
Dear Forum members,

I have lineae 15.1 on my Samsung S2 GT-19100 Running Oreo 8.1.0.

WhatsApp stopped supporting my version and said I needed ot upgrade. I couldn't upgrade. Just nothing happened when I tried to update.
I couldn't download via the phone so I downloaded a good .apk file and installed it via my desktop computer.
After I installed WhatsApp the app said my phone date and time was wrong so I recalibrated the date and time but it still said phone date and time is wrong.

So it was stuck on that notification page... Phone date and time is wrong.

Then it said WhatsApp does not support custom Roms. Is there any way to get WhatsApp to work on my custom rom? I've tried all I know and I can't get it working.

Thanks Community

Tim

The version I installed is 2.18.92...

Tim
 
  • Like
Reactions: The Carpenter

The Carpenter

Member
Nov 24, 2021
7
2
I loaded the latest version and it restored all my conversations and content. What a refreshing simple answer ! So easy..
I was assuming all sorts of mismatches but it worked a treat. Usually I avoid the lates versions because of matching issues.

Thanks for the guidance, I should have spotted that myself.. ! Enjoy your day.
 
  • Like
Reactions: James_Watson

The Carpenter

Member
Nov 24, 2021
7
2
Try using the latest WhatsApp apk from apkmirror. I think it has more to do with the version you have installed. WhatsApp tends to disable the old APKs.
Also, although they say they don't support custom roms, it's just a pop-up that says you may face issues because you are on a custom rom which you can just click 'ok' and move forward.
Thanks RVR probelm sorted... ! Have a good day. Tim
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    I have lineae 15.1 on my Samsung S2 GT-19100 Running Oreo 8.1.0.
    Looking at Whatsapp's FAQ it seems like Whatsapp doesn't support custom roms and/or rooted devices. And if I understood your question right, you are currently running Lineage OS. So I would think your best hope would be finding an mod that supports rooted/custom rom devices or modding the app yourself.

    If my answer helped you please upvote it to show your appreciation,
    Jamie
    1
    Did you download that apk from the WhatsApp official website? Is it the latest version, v2.21.23.17 or later?
    The common prompt 'the date is wrong' means that the version you are using is too old.
    1
    Your question got answered by WhatsApp themselves:

    1
    Try using the latest WhatsApp apk from apkmirror. I think it has more to do with the version you have installed. WhatsApp tends to disable the old APKs.
    Also, although they say they don't support custom roms, it's just a pop-up that says you may face issues because you are on a custom rom which you can just click 'ok' and move forward.
    Dear Forum members,

    I have lineae 15.1 on my Samsung S2 GT-19100 Running Oreo 8.1.0.

    WhatsApp stopped supporting my version and said I needed ot upgrade. I couldn't upgrade. Just nothing happened when I tried to update.
    I couldn't download via the phone so I downloaded a good .apk file and installed it via my desktop computer.
    After I installed WhatsApp the app said my phone date and time was wrong so I recalibrated the date and time but it still said phone date and time is wrong.

    So it was stuck on that notification page... Phone date and time is wrong.

    Then it said WhatsApp does not support custom Roms. Is there any way to get WhatsApp to work on my custom rom? I've tried all I know and I can't get it working.

    Thanks Community

    Tim

    The version I installed is 2.18.92...

    Tim
    1
    The version I installed is 2.18.92...

    Tim
    Get the lastest apk of v2.21.23.25 from the WhatsApp official website or update it through Google Play Store at first.