Cant open play store or connect to any google account

Search This thread

Filipelol

Member
Nov 19, 2016
20
1
Ponta Delgada
After installing MedroM I got this problem and couldn't connect to google account and every google app would crash if I tried to log in, so I flashed b161 and I still have this problem, even after numerous factory resets, has this ever happened to anyone ?
 

gtdaniel

Senior Member
Jul 2, 2008
550
180
Targu-Jiu
Yes, it is happening to other guys around here...
In fact is happening to all who flash B160/B161 firmware...
Is not possible to flash any firmware previously to B160/B161.
Workaround is to unlock bootloader, flash twrp, root it, reflash oeminfo for your device,
and after that you can flash another firmware again.
 
  • Like
Reactions: Angel&co

Angel&co

Member
Aug 20, 2013
37
1
Yes, it is happening to other guys around here...
In fact is happening to all who flash B160/B161 firmware...
Is not possible to flash any firmware previously to B160/B161.
Workaround is to unlock bootloader, flash twrp, root it, reflash oeminfo for your device,
and after that you can flash another firmware again.

i'm in the same situation, i tried to do what you've said, but twrp says that the installation failed. how can I have play store working again? please help, this situation is driving me crazy!
i'm on c900 b161.
 
Last edited:

HeavyHDx

Senior Member
Jun 27, 2013
263
93
I had the same issue. I did a clean flash of the new 161 update and that made my device a C900. I have a Eurpoean model (T-Mobile Germany).

After 2 days of trying different stuff, here's what gave me a functional device with TWRP and Root back:

-Back up any data you want to keep, obviously.

-Reflash stock ROM (put UPDATE.APP on your dload/ folder on the separate SD card, then boot into the update function by turning the phone off and then holding Vol+, Vol-, Power. Just wait until it's finished.

-Unlock Bootloader again

-Download the Toolkit: http://forum.xda-developers.com/huawei-p9lite/development/europe-vns-l31-toolkit-bootloader-t3432873

-Flash TWRP through the toolkit

-Boot TWRP and root

-In Android, enable ADB

-In the Toolkit, go to Dual Sim>Individual and select the appropriate custom.bin and oeminfo.img from the thread of the toolkit. For my European one it was L31 SS C432. Press flash and grant Root permissions on your phone.

-Turn off your phone and flash the stock ROM again like in step 1.

-If you want root, you need to unlock the Bootloader again, flash TWRP and then root it from there.

DON'T WIPE ANYTHING IN TWRP OR YOU WILL HAVE TO START ALL OVER AGAIN!
Don't ask me how I know.

Hope this saves someone from wasting their time with this nonsense like I have.
 

raffabraz

Member
Nov 12, 2016
25
3
Lisbon
No need to touch the oem stuff, just extract the boot.img and system.img and flash through adb, for dat you need bootloader unlocked and fastboot drivers then you can downgrade firmware and fix your sign problem or just wait for a new firmware
 
  • Like
Reactions: HeavyHDx

HeavyHDx

Senior Member
Jun 27, 2013
263
93
No need to touch the oem stuff, just extract the boot.img and system.img and flash through adb, for dat you need bootloader unlocked and fastboot drivers then you can downgrade firmware and fix your sign problem or just wait for a new firmware

That would be much simpler, I didn't consider that. Would you mind writing up a guide?
 

sirlex

Member
Dec 18, 2014
23
3
I've had the same issue and have resolved it pretty easily,

i did the following steps ;

- download both medrom versions
- do full factory reset
- install medrom v1
- do all settings of google etc
- reboot recovery and install v2
- wipe dalvik and reboot

-- all works now except for the forceclose on facebook

ps : this answer is also in the thread ( not as extended as this but it's there )

Edit : some other apps are Force closing to, my guess is that there's a shared resource of some kind that's corrupted or something..
 
Last edited:

HeavyHDx

Senior Member
Jun 27, 2013
263
93
I've had the same issue and have resolved it pretty easily,

i did the following steps ;

- download both medrom versions
- do full factory reset
- install medrom v1
- do all settings of google etc
- reboot recovery and install v2
- wipe dalvik and reboot

-- all works now except for the forceclose on facebook

ps : this answer is also in the thread ( not as extended as this but it's there )

Edit : some other apps are Force closing to, my guess is that there's a shared resource of some kind that's corrupted or something..

Force closing is caused by the oeminfo in my experience. Can you check in the "About Phone" section which build number your phone currently has? Should be something along the lines of "VNS-L31C432B161" where C432 indicates the region code.
 

simo255

Senior Member
Nov 16, 2015
1,151
546
Casablanca
I had the same issue. I did a clean flash of the new 161 update and that made my device a C900. I have a Eurpoean model (T-Mobile Germany).

After 2 days of trying different stuff, here's what gave me a functional device with TWRP and Root back:

-Back up any data you want to keep, obviously.

-Reflash stock ROM (put UPDATE.APP on your dload/ folder on the separate SD card, then boot into the update function by turning the phone off and then holding Vol+, Vol-, Power. Just wait until it's finished.

-Unlock Bootloader again

-Download the Toolkit: http://forum.xda-developers.com/huawei-p9lite/development/europe-vns-l31-toolkit-bootloader-t3432873

-Flash TWRP through the toolkit

-Boot TWRP and root

-In Android, enable ADB

-In the Toolkit, go to Dual Sim>Individual and select the appropriate custom.bin and oeminfo.img from the thread of the toolkit. For my European one it was L31 SS C432. Press flash and grant Root permissions on your phone.

-Turn off your phone and flash the stock ROM again like in step 1.

-If you want root, you need to unlock the Bootloader again, flash TWRP and then root it from there.

DON'T WIPE ANYTHING IN TWRP OR YOU WILL HAVE TO START ALL OVER AGAIN!
Don't ask me how I know.

Hope this saves someone from wasting their time with this nonsense like I have.

Thank you so much , you saved my phone !!
Fllashing stock rom again isnt necessary , just flash the oeminfo, reboot, they will tell you an encryption password, so you have to do a factory reset AND DONE !
 
Last edited:
  • Like
Reactions: reda19 and HeavyHDx

HeavyHDx

Senior Member
Jun 27, 2013
263
93
Thank you so much , you saved my phone !!
it doesn't need to reflash stock rom again, just flash the oeminfo, reboot, they will tell you an encryption password, so you have to do a factory reset AND DONE !

Interesting, when I tried to do a factory reset after that screen, it always failed.
 

Deddline

New member
Sep 30, 2013
1
3
34
Riga
medRom v2 fix

Hi all.
I think i found solution for Google login issue.

I use European VNS-L21-C432B161 dual sim phone with lattest rom.

I flashed medRom v2 with full wipes.
Ofcourse i Can not log in Google Services.

Today i download 3 Google apk files. Installed and it works.
Sorry. I cant post ling on XDA now.im newbie :D
Link in My profils.

There is instruction how i do:

1. Installed Gmail apk and login.
2. Installed Android System Web Wiev apk.
3. Installed Google Play Service apk


Proof: in My profils description in Youtube

Download Files: watch in YOUTUBE description.

Hope helps for someone.
 

siedlerchr

Member
Dec 9, 2016
6
0
Could someone provide me the correct oeminfo and custom.bin for a European/German model? C432? The images inlcuded in the toolkit don't work for me, it still crashes or can't communicate with the google server
 

Maxai94

Member
Jan 10, 2017
5
3
Hi all.
I think i found solution for Google login issue.

I use European VNS-L21-C432B161 dual sim phone with lattest rom.

I flashed medRom v2 with full wipes.
Ofcourse i Can not log in Google Services.

Today i download 3 Google apk files. Installed and it works.
Sorry. I cant post ling on XDA now.im newbie :D
Link in My profils.

There is instruction how i do:

1. Installed Gmail apk and login.
2. Installed Android System Web Wiev apk.
3. Installed Google Play Service apk


Proof: in My profils description in Youtube

Download Files: watch in YOUTUBE description.

Hope helps for someone.

Installing Android System Web View apk from apkmirror solved the problem for me (arm + x86 package). Thank you
 
  • Like
Reactions: emkaer and MartinMo

MartinMo

Senior Member
Mar 10, 2011
66
16
I had the same issue. I did a clean flash of the new 161 update and that made my device a C900. I have a Eurpoean model (T-Mobile Germany).
I got my P9 Lite from Congstar in Germany. I didn't knew, that the device would be branded by Telekom. I flashed the B161 and couldn't connect to any google account. Thankfully updating the webview apk via apk mirror solved this problem. But this leaves me with 2 questions and maybe you could answer these...?

1) Do you know which stock rom would work the best with my device (VNS-L31 without the possibility to use two sim cards :() and where I could download this stock rom.
2) Is the B161 supposed to work fine after solving this issue or are there other problems with it?

I would be really happy if someone of you could help me. :good:
 

HeavyHDx

Senior Member
Jun 27, 2013
263
93
1) Do you know which stock rom would work the best with my device (VNS-L31 without the possibility to use two sim cards :() and where I could download this stock rom.
2) Is the B161 supposed to work fine after solving this issue or are there other problems with it?

1) The best stock ROM would either be, well, the stock ROM, or the Revolution ROM.

2) I've had some strange behavior with Relay for Reddit and frequent crashes of WhatsApp when sending messages. Right now I'm on Lineage OS 14.1 and it's really great. Camera's a bit slow, but otherwise I love it. I missed stock Android.
 
  • Like
Reactions: MartinMo

MartinMo

Senior Member
Mar 10, 2011
66
16
1) The best stock ROM would either be, well, the stock ROM, or the Revolution ROM.
Isn't Nougat still a beta...? I'm looking for a stable stock version of EMUI...

2) I've had some strange behavior with Relay for Reddit and frequent crashes of WhatsApp when sending messages. Right now I'm on Lineage OS 14.1 and it's really great. Camera's a bit slow, but otherwise I love it. I missed stock Android.
Thank you, tomorrow I'll test if Whatsapp working fine or not, that's important for me. Is Lineage 14.1 the most stable Lineage version?
 

HeavyHDx

Senior Member
Jun 27, 2013
263
93
Nougat is still in beta, yes. The full version is expected to come out within the next few weeks.

14.1 refers to the Android version which is 7.1.1. They adopted CyanogenMod's naming scheme. You'll still need to update LineageOS to get bugfixes and such. The dev releases a new update every 2 or 3 days, just check their website periodically.
 

emkaer

New member
Dec 30, 2016
2
0
Hi all.
I think i found solution for Google login issue.

I use European VNS-L21-C432B161 dual sim phone with lattest rom.

I flashed medRom v2 with full wipes.
Ofcourse i Can not log in Google Services.

Today i download 3 Google apk files. Installed and it works.
Sorry. I cant post ling on XDA now.im newbie :D
Link in My profils.

There is instruction how i do:

1. Installed Gmail apk and login.
2. Installed Android System Web Wiev apk.
3. Installed Google Play Service apk


Proof: in My profils description in Youtube

Download Files: watch in YOUTUBE description.

Hope helps for someone.


Installed Android System Web Viev .apk did the trick for me, too. muchos gracias.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    medRom v2 fix

    Hi all.
    I think i found solution for Google login issue.

    I use European VNS-L21-C432B161 dual sim phone with lattest rom.

    I flashed medRom v2 with full wipes.
    Ofcourse i Can not log in Google Services.

    Today i download 3 Google apk files. Installed and it works.
    Sorry. I cant post ling on XDA now.im newbie :D
    Link in My profils.

    There is instruction how i do:

    1. Installed Gmail apk and login.
    2. Installed Android System Web Wiev apk.
    3. Installed Google Play Service apk


    Proof: in My profils description in Youtube

    Download Files: watch in YOUTUBE description.

    Hope helps for someone.
    2
    I had the same issue. I did a clean flash of the new 161 update and that made my device a C900. I have a Eurpoean model (T-Mobile Germany).

    After 2 days of trying different stuff, here's what gave me a functional device with TWRP and Root back:

    -Back up any data you want to keep, obviously.

    -Reflash stock ROM (put UPDATE.APP on your dload/ folder on the separate SD card, then boot into the update function by turning the phone off and then holding Vol+, Vol-, Power. Just wait until it's finished.

    -Unlock Bootloader again

    -Download the Toolkit: http://forum.xda-developers.com/huawei-p9lite/development/europe-vns-l31-toolkit-bootloader-t3432873

    -Flash TWRP through the toolkit

    -Boot TWRP and root

    -In Android, enable ADB

    -In the Toolkit, go to Dual Sim>Individual and select the appropriate custom.bin and oeminfo.img from the thread of the toolkit. For my European one it was L31 SS C432. Press flash and grant Root permissions on your phone.

    -Turn off your phone and flash the stock ROM again like in step 1.

    -If you want root, you need to unlock the Bootloader again, flash TWRP and then root it from there.

    DON'T WIPE ANYTHING IN TWRP OR YOU WILL HAVE TO START ALL OVER AGAIN!
    Don't ask me how I know.

    Hope this saves someone from wasting their time with this nonsense like I have.
    2
    I had the same issue. I did a clean flash of the new 161 update and that made my device a C900. I have a Eurpoean model (T-Mobile Germany).

    After 2 days of trying different stuff, here's what gave me a functional device with TWRP and Root back:

    -Back up any data you want to keep, obviously.

    -Reflash stock ROM (put UPDATE.APP on your dload/ folder on the separate SD card, then boot into the update function by turning the phone off and then holding Vol+, Vol-, Power. Just wait until it's finished.

    -Unlock Bootloader again

    -Download the Toolkit: http://forum.xda-developers.com/huawei-p9lite/development/europe-vns-l31-toolkit-bootloader-t3432873

    -Flash TWRP through the toolkit

    -Boot TWRP and root

    -In Android, enable ADB

    -In the Toolkit, go to Dual Sim>Individual and select the appropriate custom.bin and oeminfo.img from the thread of the toolkit. For my European one it was L31 SS C432. Press flash and grant Root permissions on your phone.

    -Turn off your phone and flash the stock ROM again like in step 1.

    -If you want root, you need to unlock the Bootloader again, flash TWRP and then root it from there.

    DON'T WIPE ANYTHING IN TWRP OR YOU WILL HAVE TO START ALL OVER AGAIN!
    Don't ask me how I know.

    Hope this saves someone from wasting their time with this nonsense like I have.

    Thank you so much , you saved my phone !!
    Fllashing stock rom again isnt necessary , just flash the oeminfo, reboot, they will tell you an encryption password, so you have to do a factory reset AND DONE !
    2
    Hi all.
    I think i found solution for Google login issue.

    I use European VNS-L21-C432B161 dual sim phone with lattest rom.

    I flashed medRom v2 with full wipes.
    Ofcourse i Can not log in Google Services.

    Today i download 3 Google apk files. Installed and it works.
    Sorry. I cant post ling on XDA now.im newbie :D
    Link in My profils.

    There is instruction how i do:

    1. Installed Gmail apk and login.
    2. Installed Android System Web Wiev apk.
    3. Installed Google Play Service apk


    Proof: in My profils description in Youtube

    Download Files: watch in YOUTUBE description.

    Hope helps for someone.

    Installing Android System Web View apk from apkmirror solved the problem for me (arm + x86 package). Thank you
    1
    Yes, it is happening to other guys around here...
    In fact is happening to all who flash B160/B161 firmware...
    Is not possible to flash any firmware previously to B160/B161.
    Workaround is to unlock bootloader, flash twrp, root it, reflash oeminfo for your device,
    and after that you can flash another firmware again.