Can't share photos or downloaded images in cm14.1

Search This thread

sonicxd64

Member
Sep 22, 2016
43
3
I installed cm14.1 and I tried to share a photo I took with this rom, but when I try to share it, the app displays a message showing it is corrupted. I can open the image with a gallery. It happens with screenshots and downloaded images too.
As I'm new user, I can't report it in the cm14.1 post.
 
  • Like
Reactions: D4N6L4CK

Silesh.Nair

Senior Member
Mar 19, 2012
4,704
13,187
Send how? Using what app? I have shared many images and screenshots on cm-14.1. Just to prove that it works, here are a few images that I sent my wife on WhatsApp and telegram.

Need more information to be of any help.

http://cloud.tapatalk.com/s/58240bd42bb22/Screenshot_20161110-112448.png?

http://cloud.tapatalk.com/s/58240c62973d0/Screenshot_20161110-112356.png?

85ebcaba2ae97fe2040b8671e9d118e2.jpg



Sent from my Moto G4 Plus using Tapatalk
 

D4N6L4CK

Member
Nov 10, 2016
31
5
Actually I have the same problem, when I take a picture, whatever the camera app (I tried Google Camera and Moto Camera) I only can see it by in build gallery. When I used Google photos, it appears in white, I can't see it and I can't make a backup on Google photos. If I try to send the photo or screenshot by the in build gallery, an error appears. I hope that you could help us.

Thanks for spend your time on this ROM, it's an awesome work!!
 
  • Like
Reactions: sonicxd64

sonicxd64

Member
Sep 22, 2016
43
3
Using WhatsApp for example, I got this. I'm able to share screenshots only using Google assistant.
It would be a shame if you can't reproduce it, I really love this rom, you're making an awesome work. Thanks for taking the time to read the post.
 

Attachments

  • Screenshot_20161110-003851.png
    Screenshot_20161110-003851.png
    62.9 KB · Views: 511

spartan 01

New member
Mar 13, 2015
3
0
Mumbai
Couldn't Upload Image or Couldn't find image.

This is what I got trying to share via WhatsApp

=======


########Reply##############
I wreck my brains out for this. I also Tried clean install again but failed. Finally success was found when I downloaded Moto file manager and tried updating my Whatsapp profile and share pics too. It works.

---------- Post added at 03:45 PM ---------- Previous post was at 03:43 PM ----------

This is what I got trying to share via WhatsApp


########Reply##############
I wreck my brains out for this. I also Tried clean install again but failed. Finally success was found when I downloaded Moto file manager and tried updating my Whatsapp profile and share pics too. It works.
Mind its a workaround and not a complete solution.
 

Mercado_Negro

Senior Member
Jan 25, 2013
2,365
1,798
Caracas
I also experienced the same yesterday when I clean flashed the latest cm14.1 build you guys shared. In fact, when I tried the very first cm14.1 build you shared it also happened so I had to restore my nandroid just like I did yesterday. Yesterday I had more troubles than before, though. Moto, Google and Snap cameras all gave me trouble when I tried to see any photos I was taking. I had to open the gallery first which force closed on me then reboot, then open again the gallery and then finally I could see the pictures I was taking with the camera for testing purposes.

I have some free time right now, I'll clean flash it again and post a couple of logs for you. I thought I was the only one with these problems because no one was reporting them in the cm14.1 thread.

Be right back with logs...

[EDIT] BTW, I just watched your YouTube video and that's definitely not happening here. Everything is working as expected on your end.
 
Last edited:

D4N6L4CK

Member
Nov 10, 2016
31
5
I was having that problem on all the Nougat Roms, but yesterday I tried the AOKP rom with this steps:
1- With TWRP wipe System, Dalvik, caché and internal storage.
2- Restore a TWRP backup from stock rom.
3- Without restart the device, I made a normal wipe with TWRP.
4- I installed the zip from AOKP.
5- Then the Gapps 7.1 arm mini.
6- Restart the device.

After the normal configuration, I realised that the problem with the photos was solved and also I was able to record videos with the in-build camera and the Google camera, i tried this method with cm 14.1 and also work.
 
  • Like
Reactions: sonicxd64

smitharro

Senior Member
Jan 2, 2012
2,629
1,711
Blokker
I was having that problem on all the Nougat Roms, but yesterday I tried the AOKP rom with this steps:
1- With TWRP wipe System, Dalvik, caché and internal storage.
2- Restore a TWRP backup from stock rom.
3- Without restart the device, I made a normal wipe with TWRP.
4- I installed the zip from AOKP.
5- Then the Gapps 7.1 arm mini.
6- Restart the device.

After the normal configuration, I realised that the problem with the photos was solved and also I was able to record videos with the in-build camera and the Google camera, i tried this method with cm 14.1 and also work.
Seems to be an issue with the filesystem then. Possibly just formatting the internal storage works too? I'll give it a try!
Edit: formatting the internal memory worked!
Maybe it's got something to do with the new TWRP. Not wiping internal memory but wiping everything else. Maybe there was a little change in the way the wiping/formatting takes place.

Send with my Moto G4 Plus (XT1642) on CyanogenMod 14.1, Android 7.1, using Tapatalk!
 
Last edited:

Mercado_Negro

Senior Member
Jan 25, 2013
2,365
1,798
Caracas
Seems to be an issue with the filesystem then. Possibly just formatting the internal storage works too? I'll give it a try!
Edit: formatting the internal memory worked!
Maybe it's got something to do with the new TWRP. Not wiping internal memory but wiping everything else. Maybe there was a little change in the way the wiping/formatting takes place.

Send with my Moto G4 Plus (XT1642) on CyanogenMod 14.1, Android 7.1, using Tapatalk!
I guess you had cm14.1 already working so you did a backup of your internal storage and just rebooted to recovery and wiped it. Correct? I just want to make sure if I have to boot the ROM first or I can wipe the internal storage after flashing both ROM and gapps.
 

sabithmk

Member
Jul 7, 2014
47
20
I had the same problem.

The solution is to delete the existing folders in the SD card and let the system create fresh folders. ?

I don't know what is the problem with using the pre-flash folders, but it doesn't load in whatsapp or anyother apps. I had to delete DCIM, Pictures folder inorder to get the camera and screenshot to work. ?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    I installed cm14.1 and I tried to share a photo I took with this rom, but when I try to share it, the app displays a message showing it is corrupted. I can open the image with a gallery. It happens with screenshots and downloaded images too.
    As I'm new user, I can't report it in the cm14.1 post.
    1
    Actually I have the same problem, when I take a picture, whatever the camera app (I tried Google Camera and Moto Camera) I only can see it by in build gallery. When I used Google photos, it appears in white, I can't see it and I can't make a backup on Google photos. If I try to send the photo or screenshot by the in build gallery, an error appears. I hope that you could help us.

    Thanks for spend your time on this ROM, it's an awesome work!!
    1
    The latest build is on my google drive.

    Sent from my Moto G4 Plus using Tapatalk
    1
    Well, I'll see what I can do, but I can't do much as it seems to work flawlessly for me.

    Sent from my Moto G4 Plus using Tapatalk
    1
    I was having that problem on all the Nougat Roms, but yesterday I tried the AOKP rom with this steps:
    1- With TWRP wipe System, Dalvik, caché and internal storage.
    2- Restore a TWRP backup from stock rom.
    3- Without restart the device, I made a normal wipe with TWRP.
    4- I installed the zip from AOKP.
    5- Then the Gapps 7.1 arm mini.
    6- Restart the device.

    After the normal configuration, I realised that the problem with the photos was solved and also I was able to record videos with the in-build camera and the Google camera, i tried this method with cm 14.1 and also work.
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone