Can't Turn Off Blue Light Filter

Search This thread

ccoulterjg1

Senior Member
Sep 19, 2013
107
40
This is driving me nuts. I set up my new s10 by signing in to my Google account and choosing to restore my Pixel 3 XL backup. All the apps and everything downloaded just fine, but the blue light filter that I had scheduled for 10pm to 6am on the Pixel has apparently followed me to the S10. The only problem is that I have no way to disable it. It shows as off in the settings even though it clearly turns on at 10pm. If I manually change the clock to say 7pm, the filter turns off, but the whole time, the settings show that it's off. Enabling it in settings while it is already active results in a slightly more red blue light filter, that's it. Short of doing a factory reset and setting it up as a new device, I can't think of any way to fix it. I've even tried turning off the setting on my Pixel to no avail. Any ideas?
 

Paradoxxx

Senior Member
Aug 14, 2008
5,584
5,959
Krakow
I had the same issue.

Download an application called Activity Launcher.

You will need to find the activity that is linked to night shift, I can't remember the name on the top of head but it will be pretty obvious when you will see it.

Samsung apparently decided to scratch away the stock feature by just creating their own one and removing the stock one's setting entry. However it's still there, and still working as long as you can manually launch the activity and it activate automatically if you had a schedule created on another device.

Funily enough that allows you to get even stronger effect by combining both features at the same time.
 

ccoulterjg1

Senior Member
Sep 19, 2013
107
40
Check your nightlight settings in the Google Play Books App. Set that to 0 and it should fix the issue.

Thanks for the suggestion, but I don't even have Google Play Books installed.

I had the same issue.

Download an application called Activity Launcher.

You will need to find the activity that is linked to night shift, I can't remember the name on the top of head but it will be pretty obvious when you will see it.

Samsung apparently decided to scratch away the stock feature by just creating their own one and removing the stock one's setting entry. However it's still there, and still working as long as you can manually launch the activity and it activate automatically if you had a schedule created on another device.

Funily enough that allows you to get even stronger effect by combining both features at the same time.

Dude, thank you so much. It worked. I can't believe how annoying it was not to be able to turn that off. Much appreciated!
 

Babla1234

New member
Nov 25, 2020
2
1
Blue light filter on off

Hi my blue light fliter is getting on and off. Specially on chrome and cnet website. And even when keyboard pops up on chrome.

Updated android 11. Still same. Keep changing sometimes while just scrolling.
 
I had the same issue.

Download an application called Activity Launcher.

You will need to find the activity that is linked to night shift, I can't remember the name on the top of head but it will be pretty obvious when you will see it.

Samsung apparently decided to scratch away the stock feature by just creating their own one and removing the stock one's setting entry. However it's still there, and still working as long as you can manually launch the activity and it activate automatically if you had a schedule created on another device.

Funily enough that allows you to get even stronger effect by combining both features at the same time.



Thank you! Thank you! Thank you!

This was driving me crazy when I upgraded to the OneUI 3.0 Beta on my S10+
 
Oct 17, 2018
22
5
I had the same issue.

Download an application called Activity Launcher.

You will need to find the activity that is linked to night shift, I can't remember the name on the top of head but it will be pretty obvious when you will see it.

Samsung apparently decided to scratch away the stock feature by just creating their own one and removing the stock one's setting entry. However it's still there, and still working as long as you can manually launch the activity and it activate automatically if you had a schedule created on another device.

Funily enough that allows you to get even stronger effect by combining both features at the same time.
I am having the same issue with my newly bought 2 days old Xiaomi 11T. I transferred everything from my previous phone Xiaomi Mi A1 and I had Night Light scheduled to turn on at 11:30 p.m. and off at 7:00 a.m. But now there is no NIGHT LIGHT feature on Xiaomi 11T but the screen automatically turns yellow when the schedule starts and turns back to normal at 7 a.m. Please help me with this. I tried installing Activity Launcher, but I couldn't find the setting you are talking about. I also have both, schedule and reading mode turned off in the settings, but this still happens due to settings brought from the old phone.
Please help me out.
 

blackhawk

Senior Member
Jun 23, 2020
9,889
3,927
Samsung Galaxy Note 10+
Check your nightlight settings in the Google Play Books App. Set that to 0 and it should fix the issue.

Think that's the same app that boned me. It alters a hidden user setting that remains after you uninstall it.
Unclean uninstall... Gookill sucks.
The way I fixed it was to reinstall it, change that setting, uninstall. Over a year later still on that same OS load, A-ok.

OP: don't use SmartSwitch when migrating to a different device especially for apps. Do a clean load... more *surprises* are likely waiting for you.
Do not trust SmartSwitch with critical data... I use it for homepage settings only where if it fails it's no big deal.
 

Ultraspj

New member
Dec 18, 2021
1
1
I have a Galaxy s21 ultra and I spent the last month so furious that I couldn't get the blue light filter to stop coming on at sunset until I saw this post and downloaded activity launcher and found the night light setting

Thank you so much to everybody who responded here
 
  • Like
Reactions: blackhawk

Floridaboy77

New member
Jan 21, 2022
1
0
God am I happy I wasn't the only one with this problem. Thank you guys so much for finding a fix, I just got a z fold 3 and updated from the Pixel 3XL so I had the exact same issue.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    I had the same issue.

    Download an application called Activity Launcher.

    You will need to find the activity that is linked to night shift, I can't remember the name on the top of head but it will be pretty obvious when you will see it.

    Samsung apparently decided to scratch away the stock feature by just creating their own one and removing the stock one's setting entry. However it's still there, and still working as long as you can manually launch the activity and it activate automatically if you had a schedule created on another device.

    Funily enough that allows you to get even stronger effect by combining both features at the same time.
    2
    Same issue. What was the name of the activity? Thanks in advance!
    At the top, select "All activities"
    then scroll down to Settings > Night Light
    1
    Check your nightlight settings in the Google Play Books App. Set that to 0 and it should fix the issue.
    1
    I have a Galaxy s21 ultra and I spent the last month so furious that I couldn't get the blue light filter to stop coming on at sunset until I saw this post and downloaded activity launcher and found the night light setting

    Thank you so much to everybody who responded here