• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Cell Standby battery drain fix for AT&T

Search This thread

jaltman

Senior Member
Aug 5, 2012
85
27
From the Android Central forums:

Settings. . Mobile networks. . mobile data .. enhanced 4g

Since turning off wifi also stops the drain, I might speculate the bug is actually in the voice processing for wider bandwidth and turning off wifi or enhanced 4g shuts down that section of voice processing, which is keeping the radio alive when it should not.
 

jackdforme

Senior Member
Aug 15, 2012
534
157
New York
Samsung Galaxy Z Fold3
Does anyone have proof that this is related to cell standby? I am skeptical that this is the smoking gun for battery drain. I have noticed a substantial drain even compared to my old Moto X (2014) and that is saying a lot since that phone's battery wasn't great. I am trying to see where we can make stride to determine the reasons for it. I have different results in my details. Sometimes android system is the culprit.
 

Pure+

Senior Member
May 28, 2013
1,317
515
Anyone do this and leave WiFi on and still have good battery. Seems to me that no matter what I do WiFi still causes the battery to drain far faster than it should.

Sent from my SAMSUNG-SM-G925A using Tapatalk
 

varunkumars

Senior Member
Sep 4, 2010
573
109
Dallas
Anyone do this and leave WiFi on and still have good battery. Seems to me that no matter what I do WiFi still causes the battery to drain far faster than it should.

Sent from my SAMSUNG-SM-G925A using Tapatalk
+1
I switched off enhanced LTE but if I leave the wifi on I see a battery drain. With wifi off I get a stable battery. My Edge (AT&T) is on Android 5.0.2.

I remember first T-mobile users mentioning battery was ok until 5.0.1 which was later updated to 5.0.2 and the trouble started.
 

Pure+

Senior Member
May 28, 2013
1,317
515
So today I decided to keep wifi on and wow. Battery life not as good. Not having horrible drain, but it is most certainly effecting my battery life. So tomorrow I will go all day without wifi and see how it fairs. But I'm thinking that unless I know I'm gonna be at home a lot where I can easily charge, then wifi will remain off indefinitely. Good thing I have 30gb mobile share data :D
 

mobilehavoc

Senior Member
Mar 12, 2006
2,172
355
From the Android Central forums:

Settings. . Mobile networks. . mobile data .. enhanced 4g

Since turning off wifi also stops the drain, I might speculate the bug is actually in the voice processing for wider bandwidth and turning off wifi or enhanced 4g shuts down that section of voice processing, which is keeping the radio alive when it should not.
Lol that was my post on Android Central. Its like that because I typed it one handed while at a stop light.
 

Pure+

Senior Member
May 28, 2013
1,317
515
Ill give it a try and report back. Does anyone use the "Battery Saving" feature all the time?

I'm about to try leaving it on all day. Anything that it turns off I don't really need so might as well. And let's be honest, who needs all the power this phone has all the time. I'd say 95% of the time I don't need anywhere near the processing that this beast is capable of.

Sent from my SAMSUNG-SM-G925A using Tapatalk
 

Top Liked Posts

  • There are no posts matching your filters.
  • 13
    ok so, heres what worked for me to get really good battery life. for starters i disabled all of the bloat ware. But i also disables samsung push services. doing that didnt harm or alter anything on my device. Second i disabled HD calling by going to system settings>connections tab>mobile networks>mobil data>then uncheck Enhanced 4GLTE services. I then also disabled wirless scanning. this stops apps from using your wifi even though your wifi is off. do this by going to Settings>Connections tab>WIFI>More(in the top right corner)>Advanced>Then uncheck "Always allow scanning". Now for the final touch about those google services draining the battery. What i did was follow these instructions, but remember to clear all data from google services. like this Settings>Device tab>Applications>Application Manager>"All" tab>then scroll down until you see google services>then hit the clear cache. and make sure to uninstall update for google play services if thats an option. After this then go to the "google settings" app in the app draw>click the three little dots on the top right of the screen> hit clear app data. Then for the final step. reboot into recovery(rooted or not, dosent matter) by powering off the device, once device is off, hold down the power, home, and volume up button to get into recovery mode( hold buttons until you see the little android with words saying applying update or something like that) after about 20 seconds, the recovery screen will appear. scroll down with the volume down button till you get to the "clear cache" opiton. hit the power button to clear the cache. then after that, reboot the system, and you should be good. And again. im not sure if this will work with everyone but it worked for me. and i get a hell of alot of better battery and my device dosent over heat anymore even when im playing games of streaming videos. good luck!!!! hope to hear some good replys!!!!! oh and heres the link to what i kinda followed. but i did it my way. https://forums.oneplus.net/threads/how-i-fixed-the-google-play-services-battery-drain.291608/
    9
    From the Android Central forums:

    Settings. . Mobile networks. . mobile data .. enhanced 4g

    Since turning off wifi also stops the drain, I might speculate the bug is actually in the voice processing for wider bandwidth and turning off wifi or enhanced 4g shuts down that section of voice processing, which is keeping the radio alive when it should not.
    3
    From the Android Central forums:

    Settings. . Mobile networks. . mobile data .. enhanced 4g

    Since turning off wifi also stops the drain, I might speculate the bug is actually in the voice processing for wider bandwidth and turning off wifi or enhanced 4g shuts down that section of voice processing, which is keeping the radio alive when it should not.
    Lol that was my post on Android Central. Its like that because I typed it one handed while at a stop light.
    3
    Seems like I fixed the drain issue with WIFI

    Steps:
    1.) Turned off the enhanced LTE (like OP suggested)
    2.) Turned off always allow scanning (Inside the advanced wifi settings)
    3.) Disabled AT&T bloatware including Amazon, fitness.
    4.) Last but most important is to Re-start the phone. I did the first 3 yesterday also but no use. Today after doing a little research in the forums I realized this is important too.

    Now if the above does not work for you try resetting the phone along with the above. This worked for many. Some suggested battery re-calibration (which means draining the battery to 10% and re-charging it to 100%).

    In about an hour I lost about 3 % of battery (with WIFI on) only with about 5 minutes of usage. Earlier I lost more than 10% in an hour.

    Hope fully this fix will stay. I will test further in the evening completely on wifi and report back.