• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

charging problem A3 2017 A320FL

Search This thread

der-seemann

Member
Jan 27, 2013
19
2
Hi,
my phone stopt charging properly, maybe s.o. can help me fit it.
Stock Android, Magisk, debloated.
Since a frew days is shows a yellow triangle wehn charging with phone turned off. When powered on, someties it is charging very slow,then again it shows that it it not charging at all.
I tried different cables and chargers.
I cleaned the USB port.
I cleaded the cache.
nothing seems to work.
here is a dump of "dmesg | grep bat" maybe s.o. can find a hint whats the problem.
the first one I took with TWRP, where it is slowly charging, the second with normal stock android, were it is only sometimes showing charging symbol and not really charing at all.
 

Attachments

  • TWRP-dmesg.txt
    153.2 KB · Views: 11
  • ardoid-dmesg.txt
    128.4 KB · Views: 11

HoldMySoul69

Senior Member
Jun 24, 2017
821
193
22
Liepaja
Huawei P8lite/P8 Lite
Hi,
my phone stopt charging properly, maybe s.o. can help me fit it.
Stock Android, Magisk, debloated.
Since a frew days is shows a yellow triangle wehn charging with phone turned off. When powered on, someties it is charging very slow,then again it shows that it it not charging at all.
I tried different cables and chargers.
I cleaned the USB port.
I cleaded the cache.
nothing seems to work.
here is a dump of "dmesg | grep bat" maybe s.o. can find a hint whats the problem.
the first one I took with TWRP, where it is slowly charging, the second with normal stock android, were it is only sometimes showing charging symbol and not really charing at all.
It's charging with usb, at least phone thinks you are connected to usb. I recommend reflashing phones FW(Firmware) and charge it without any mods, root or anything.
 

MaDaLiNoSt

Senior Member
Aug 15, 2013
813
281
Hi,
my phone stopt charging properly, maybe s.o. can help me fit it.
Stock Android, Magisk, debloated.
Since a frew days is shows a yellow triangle wehn charging with phone turned off. When powered on, someties it is charging very slow,then again it shows that it it not charging at all.
I tried different cables and chargers.
I cleaned the USB port.
I cleaded the cache.
nothing seems to work.
here is a dump of "dmesg | grep bat" maybe s.o. can find a hint whats the problem.
the first one I took with TWRP, where it is slowly charging, the second with normal stock android, were it is only sometimes showing charging symbol and not really charing at all.

Reflash stock kernel. On logs it says 2500mw but this phone is rated for 1.5A for charging.