• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Question Charging ZF3 with Anker PowerPort Atom III Slim 63W - Charging keeps turning on and off

Search This thread

prank1

Senior Member
Jan 28, 2007
448
85
Iraq
Wondering if anyone else is having a similar issue..

I have an Anker PowerPort Atom III Slim 63W with a 100w USB-C to C cable

When plugged into the 18w or 45w port on the Anker charger, the ZF3 activates Super Fast Charging for a few seconds, then turns off, then a few seconds later starts charging again, then turns off etc
The only way to stop this is to disable Super Fast Charging on the ZF3 - but then its just standard, slower charging

Charger works fine with Note 10+5G (Super Fast Charging) and other devices
Cable works fine with other chargers
Using a different cable with the Anker charger doesn't fix the problem

Is the Anker charger just simply not compatible with the ZF3?
 

blackhawk

Senior Member
Jun 23, 2020
6,468
2,121
Does the Samsung 25w brick charge it normally?
Erratic fast charging is one of the signs of a battery failure.
It sounds though likes it's incompatible with the Fold.

If fast charging parameters aren't fully met, it will disengage.
If charge start battery temperature is below 50-70F
Above 101F
If battery charge state is above 75-90%
If display/phone is active*.


*screen off listening to bt with Poweramp doesn't skew the charge curve.
 

prank1

Senior Member
Jan 28, 2007
448
85
Iraq
ZF3 Super Fast Charges perfectly fine with other chargers, including a third party WJOY USB C Charger 65W that I use.

The problem is only with this Anker charger.

I think the Anker charger is simply incompatible with the ZF3...
 
  • Like
Reactions: blackhawk
The issue is 2 fold. 1 - that charger doesn't support PPS or the new version of PD, so you can't get super fast charging. And 2- It supports PD, however it's an older protocol that only Google and Apple phones use for "rapid charging", so you can only use standard fast charging.

So it sounds like the phone is trying to handshake the PD signature from the charger for super fast charging, but fails once it realizes it doesn't actually meet the proper PD specs. Charging is very rudimentary, so it's going to keep trying because it keeps seeing "PD capable charger"
 

prank1

Senior Member
Jan 28, 2007
448
85
Iraq
Simply disconnecting the charger from the mains, waiting 5mins, and then reconnecting everything seemed to do the trick - The ZF3 now Super Fast Charges. Seems like it was just a glitch with the Anker charger and it just needed a reset. Thanks for all your help
 
  • Like
Reactions: blackhawk

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    The issue is 2 fold. 1 - that charger doesn't support PPS or the new version of PD, so you can't get super fast charging. And 2- It supports PD, however it's an older protocol that only Google and Apple phones use for "rapid charging", so you can only use standard fast charging.

    So it sounds like the phone is trying to handshake the PD signature from the charger for super fast charging, but fails once it realizes it doesn't actually meet the proper PD specs. Charging is very rudimentary, so it's going to keep trying because it keeps seeing "PD capable charger"
    2
    Does the Samsung 25w brick charge it normally?
    Erratic fast charging is one of the signs of a battery failure.
    It sounds though likes it's incompatible with the Fold.

    If fast charging parameters aren't fully met, it will disengage.
    If charge start battery temperature is below 50-70F
    Above 101F
    If battery charge state is above 75-90%
    If display/phone is active*.


    *screen off listening to bt with Poweramp doesn't skew the charge curve.
    1
    ZF3 Super Fast Charges perfectly fine with other chargers, including a third party WJOY USB C Charger 65W that I use.

    The problem is only with this Anker charger.

    I think the Anker charger is simply incompatible with the ZF3...
    1
    Simply disconnecting the charger from the mains, waiting 5mins, and then reconnecting everything seemed to do the trick - The ZF3 now Super Fast Charges. Seems like it was just a glitch with the Anker charger and it just needed a reset. Thanks for all your help