• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Check out the new XDA app! Let us know what you think [App rolling out now]

Search This thread

sd_shadow

Recognized Contributor
Sep 21, 2011
18,356
2
8,880
South Dakota
goo.gl
Motorola Droid X
Amazon Fire
Thread preview is off (remembered that). What's the correct search setting then ?
And thanks for your fast response!
The only other options are in
Preferences and notifications


Screenshot_20211127-091241_XDA_Developers~2.png


Your options are most recent and relevance

Screenshot_20211127-091201_XDA_Developers~2.png
 

Wolfcity

Recognized Contributor
Apr 26, 2013
4,397
2,813
Moto G 2014
Moto G5 Plus
The only other options are in
Preferences and notifications


View attachment 5469093

Your options are most recent and relevance

View attachment 5469095
Ok, so there's something strange happening on my side.
Screenshot 1: Searching for "options"
Screenshot 2: Searching for "shadow"
Screenshot 3: Preferences and notifications.
The results for both searches are the same and have nothing to do with the keyword.
Seems it's just searching for "#".......
 

Attachments

  • Screenshot_2021-11-27-23-10-11-376_com.xda.labs.play.jpg
    Screenshot_2021-11-27-23-10-11-376_com.xda.labs.play.jpg
    538.8 KB · Views: 31
  • Screenshot_2021-11-27-23-08-41-948_com.xda.labs.play.jpg
    Screenshot_2021-11-27-23-08-41-948_com.xda.labs.play.jpg
    539.2 KB · Views: 31
  • Screenshot_2021-11-27-23-06-47-841_com.xda.labs.play.jpg
    Screenshot_2021-11-27-23-06-47-841_com.xda.labs.play.jpg
    310.3 KB · Views: 32
  • Like
Reactions: IronTechmonkey

IronTechmonkey

Recognized Contributor
Feb 12, 2013
8,257
12,604
Ok, so there's something strange happening on my side.
Screenshot 1: Searching for "options"
Screenshot 2: Searching for "shadow"
Screenshot 3: Preferences and notifications.
The results for both searches are the same and have nothing to do with the keyword.
Seems it's just searching for "#".......

I think that even apart from the recent issues with the app crashing there's something wrong with the the search . In desktop browsers and in the app I get similar results to what you described. It almost seems like a universal wildcard search which finds the same posts each time. There is also a change in the behavior of the drop-downs that appear when typing criteria which is probably related if not causal.
 
Last edited:

Wolfcity

Recognized Contributor
Apr 26, 2013
4,397
2,813
Moto G 2014
Moto G5 Plus
I think that even apart from the recent issues with the app crashing there's something wrong with the the search . In desktop browsers and in the app I get similar results to what you described. It almost seems like a universal wildcard search which finds the same posts each time. There is also a change in the behavior of the drop-downs that appear when typing criteria which is probably related if not causal.
Thanks for your feedback, it seems it's not just my incomprehension.
The "*" seems to be a wildcard that makes any In-thread-search impossible.
So it may be a bug appearing after the latest back-end changes.
 

La_Globule

Senior Member
Nov 6, 2007
428
157
Hi,
The new release doesn't fix the bug I pointed out: after a fresh install, when launching the app, I'm stuck on the XDA logo and nothing happens after (no logon request) even after cleaning all the data.
Can you please transfer this info to the dev team?
Thanks
Hi,
The problem is still here with v2.15.41.
Is there any chance it will be fixed soon?
Thanks to the staff members for having a look.
 

lukval

Senior Member
Sep 29, 2015
210
30
Sony Xperia M
Honor 9
Hi,
The problem is still here with v2.15.41.
Is there any chance it will be fixed soon?
Thanks to the staff members for having a look.
The same here @ Oreo 8.0 - every app startup my account authorization is needed + sometimes my dark theme is spontaneously switching to white theme + sometimes xda app crashing without visible the reason.

EDIT:
After appdata wipe the account authorization is no longer required.
 
Last edited:

Wolfcity

Recognized Contributor
Apr 26, 2013
4,397
2,813
Moto G 2014
Moto G5 Plus
I think that even apart from the recent issues with the app crashing there's something wrong with the the search . In desktop browsers and in the app I get similar results to what you described. It almost seems like a universal wildcard search which finds the same posts each time. There is also a change in the behavior of the drop-downs that appear when typing criteria which is probably related if not causal.
So I'm still not able to use the in thread search, still the "*" as a wildcard in front.
It seems other users can use the search function.
Any news or anything I can do about it?
It's really annoying to not being able to use the search function. Here's another screenshot what happens when I try to search for any keyword in this thread, same happens when using XDA in a browser.
 

Attachments

  • IMG_20211205_204102.jpg
    IMG_20211205_204102.jpg
    410.4 KB · Views: 17
  • Like
Reactions: IronTechmonkey

IronTechmonkey

Recognized Contributor
Feb 12, 2013
8,257
12,604
So I'm still not able to use the in thread search, still the "*" as a wildcard in front.
It seems other users can use the search function.
Any news or anything I can do about it?
It's really annoying to not being able to use the search function. Here's another screenshot what happens when I try to search for any keyword in this thread, same happens when using XDA in a browser.

Still occurring here. I did not realize that some people were not experiencing it. I don't see how it could be as simple as an Android device setting because something similar happens in the web interface nor do I see how an account setting could cause it. That being said there must be a cause because it is occurring.
 
  • Like
Reactions: Wolfcity

eriol1

Senior Member
Feb 16, 2015
195
135
Still occurring here. I did not realize that some people were not experiencing it. I don't see how it could be as simple as an Android device setting because something similar happens in the web interface nor do I see how an account setting could cause it. That being said there must be a cause because it is occurring.
I am not affected.
I noticed however that if I search for an empty string I get results for "*", so maybe something is simply clearing your search string before sending it to the server? Maybe some security mechanism that's acting up?

I'd set up a proxy to catch the http request on its way out and see if there's anything in the search term.
If the search term is indeed empty it confirms the problem is not on the server side.
 

IronTechmonkey

Recognized Contributor
Feb 12, 2013
8,257
12,604
Cannot attached text files in web browsers or app, multiple devices, different network connections.

[EDIT] OK, it is a particular (not very large) log file that wont attache... but that is the most important. What could be the reasons why?
 

IronTechmonkey

Recognized Contributor
Feb 12, 2013
8,257
12,604
An offending character in the file name maybe?

Perhaps on the right track though not in the file name which I've tested for but maybe in the contents. I'll test a log from a different logging app but at this point sharing log on XDA has become the bigger project than testing and logging an app glitch. There should be an error message in response to an attachment that does not fully attache (the icon never goes black as it does on successful attempts). It is obvious from my continued and engaged presence that I take in stride various complaints which I share with others about XDA but for it to be this difficult to share logs is not good. There should at least be an informative error message in such cases - from the live web UI... not requiring yet another logging project.

Anyhow, pardon the rant and thanks for the tip. I'm trying a different logging app which might use different syntax.
 
  • Like
Reactions: eriol1

Oswald Boelcke

Senior Moderator / Moderator Committee
Staff member
Perhaps on the right track though not in the file name which I've tested for but maybe in the contents. I'll test a log from a different logging app but at this point sharing log on XDA has become the bigger project than testing and logging an app glitch. There should be an error message in response to an attachment that does not fully attache (the icon never goes black as it does on successful attempts). It is obvious from my continued and engaged presence that I take in stride various complaints which I share with others about XDA but for it to be this difficult to share logs is not good. There should at least be an informative error message in such cases - from the live web UI... not requiring yet another logging project.

Anyhow, pardon the rant and thanks for the tip. I'm trying a different logging app which might use different syntax.
I've mentioned this problem a few times in the BBS thread. Sometimes, I'm able to attach a txt-file, othertimes I need to zip it first. Seems that in few cases something in the txt-file doesn't pass a filter and won't be allowed to attached; however, that's obviously masked if you zip.
So far, I wasn't able to figure out the reason but I've to admit I didn't invest much time yet.
 
  • Like
Reactions: IronTechmonkey

IronTechmonkey

Recognized Contributor
Feb 12, 2013
8,257
12,604
I've mentioned this problem a few times in the BBS thread. Sometimes, I'm able to attach a txt-file, othertimes I need to zip it first. Seems that in few cases something in the txt-file doesn't pass a filter and won't be allowed to attached; however, that's obviously masked if you zip.
So far, I wasn't able to figure out the reason but I've to admit I didn't invest much time yet.

Thanks. That description seems consistent with with what I've seen today, it must be some characters or formatting in the file. Logs from different logging app and from ADB via PC experienced the same problem but after being opened in Wordpad (windows native app) then saved as unicode format instead of plan text they can be attached successful. I had tried renaming as zip but not actually zipping so I'll remember that as an option for next time. Both the acts of zipping and saving as unicode may delete or obscure the offending character or formatting. It would be nice to know what formatting or characters are not allowed. Thanks again!.
 

Oswald Boelcke

Senior Moderator / Moderator Committee
Staff member
Thanks. That description seems consistent with with what I've seen today, it must be some characters or formatting in the file. Logs from different logging app and from ADB via PC experienced the same problem but after being opened in Wordpad (windows native app) then saved as unicode format instead of plan text they can be attached successful. I had tried renaming as zip but not actually zipping so I'll remember that as an option for next time. Both the acts of zipping and saving as unicode may delete or obscure the offending character or formatting. It would be nice to know what formatting or characters are not allowed. Thanks again!.
@MikeChannon

Sir, may @IronTechmonkey's findings regarding the unicode format help to fix the occasional issues with attaching txt-files?
 

Thebear j koss

Senior Member
Cannot attached text files in web browsers or app, multiple devices, different network connections.

[EDIT] OK, it is a particular (not very large) log file that wont attache... but that is the most important. What could be the reasons why?
Pastebin broseph. Or any file share app. Unless I'm misunderstanding you.
 
  • Like
Reactions: IronTechmonkey

IronTechmonkey

Recognized Contributor
Feb 12, 2013
8,257
12,604
Pastebin broseph. Or any file share app. Unless I'm misunderstanding you.

I considered such but would rather post here. Saving the log in unicode format seems to work. I hope that does not render the log less useful to the developer, and since the item being blocked is something common in log files that get tossed around much on a dev focused site, I hope XDA can tweak filters to allow it ... once it is known what "it" is.
 
  • Like
Reactions: Thebear j koss

IronTechmonkey

Recognized Contributor
Feb 12, 2013
8,257
12,604
It may help... I've referred it for a look by those that have more expertize than me.

Mike

Would it help if I could isolate the offending character or section of formatting by attaching increasingly smaller chunks of the file until the specific culprit is revealed? Depending how the file is handled while being divided into sections for testing this might or might not work but I've done it before and think that might be possible in this case. Depending on where the culprit resides within the file this might go quickly or take some time but if you think having a much smaller section of file to look at would help I can do this.
 
  • Like
Reactions: Oswald Boelcke

Top Liked Posts

  • There are no posts matching your filters.
  • 95
    The new app is just an upgrade to the current XDA app, so you should be able to just go into Play and hit "Update"


    The app is rolling out now, and will take hours to get to everyone. For safety, we are doing a staged rollout at first at about 50%.

    Update 12/8: App is now at 100% rollout so everyone should get it soon. Thanks for testing and using it! :)
    Update 1/13/21: We are aware that for some, the app isn't working. We plan to release a fix ASAP.


    Fun things to try:

    - Login explore the app settings and gesture controls (hit the third button on the bottom).
    - Read the Tips and Tricks thread
    21
    So many are asking about the news section in the app---and yes, we intend to bring this back.
    18
    So far it's s long way short of the old app, in terms of functionality.
    For me the main things that could be fixed/implemented are
    . Easily select my device then have the main device subforum one click away. (No, it's not going to be good enough to bookmark/flag/watch/favourite/whatever the individual subforums of the device subforum. It would be nice to have the device forum in its own tab/link/etc. and not mixed in with the general watched threads section)
    . Go to the last read post when opening a thread
    . Selecting a thread, by default, opens that thread, not show some useless overview, requiring a second button tap to actually open it.
    . Bring back the swipe left and right, in a thread, to go to the previous next page in the thread.

    I've been lazy and haven't gone through this thread, so I assume there's nothing new here as these are all the staple needs of a forum app. So apologies if I'm repeating other thoughts, but the more often the basics are flagged, hopefully the higher up the fix list they'll go.
    OK, having spent a bit more time with it, here are more thoughts.
    . The current home page is mostly useless, the trending, new posts, and new threads are 99.9% device specific about a device you don't own and so is pointless. Move this to the last tab on the bottom (I'll leave it to someone else to suggest an icon for it) then make a useful home page. The most useful things are quick access to your own device subforums (This would be an expandable list, depending on how many devices you own/care about.), quick access to see new posts where you have direct replies, quotes or mentions and quick access to see new PM's. The rest of the home page could then be configurable so each user can choose what else is important to them. (e.g. New posts to threads you've previously participated in).
    . Bring back the functionality to automatically save a draft of a new post/reply. It was incredibly useful when you needed to add multiple links to other threads. It was also very useful when creating long guides, etc. to be able to compose it in stages if necessary.
    . Why are PM's (conversations in modern parlance) only accessible in the alerts tab?. I understand new messages should have alerts there, but surely the whole collection should have its own place. I guess somewhere in the account tab would make some sense.
    17
    I'm sorry to have to say this to the developper of this app, but I really don't like the new app. It's so less convenient than the previous XDA Labs app.

    Here in a list of key features I'm missing:
    - Going straight to the last unread post when clicking on a thread (instead, the new app opens the thread in the OP which is very frustrating as you can't really figure out where you last left the thread).
    - Navigating through thread pages by swiping left and right
    - The Newsfeed section
    - The XDA App section. Maybe it's because this is forbidden by Google, but then why don't you make a non playstore XDA+ app with this additional feature? Many XDA users are "expert" happy to install apps from other sources than the Play Store anyways
    - The "My Device" section, leading straight to our Device forum
    - The Subscribed Thread tab

    Other things that I find very frustrating with new app:
    - It's too cluttered, and despite the clutter, it is not only less convenient than the previous XDA Labs app, but it is also missing nice features/tabs/filters that can be found in the browser version
    - I'm getting the SSL error when using NextDNS private dns. The only way around this is to whitelist www.google-analytics.com and www.googletagmanger.com. This is unacceptable for me. I can't whitelist this google crap just for the sake of accessing the XDA app (especially XDA, of all apps, why would you mingle so deeply with google analytics?).

    I'm gonna stick to the web version for the time being (also a frustration), hoping for an improved XDA app, with a more user-friendly UI, less permission requests, and less dependancy on google-crap.

    Also, is there a web browser equivalent to the XDA Lab App Store?
    16
    well , title says "tell us what you think".
    firstly i'd like to say that i am not a developer. so i couldnt have done this. it is appreciated the time , effort , hours and knowledge that went into it.
    but i think it was @lfom who said it best for me ; "it killed the mobile user experience". i can learn new ways to navigate to where i want to go. i can find most everything i look for. but the overall experience has , well diminished quite a bit for me personally. i know you all are working diligently to fix the things that are broke which is again highly appreciated. but i can get kinda the same experience with my mobile browser and launcher just by logging in and clicking on "save to home screen".
    just my ¢.02 and do appreciate the effort.
    all the best for xda and its members/families in the new year.
    mrrocketdog , a.k.a. dave