Check out the new XDA app! Let us know what you think [App rolling out now]

Search This thread

MikeChannon

Forum Admin
Staff member
Would it help if I could isolate the offending character or section of formatting by attaching increasingly smaller chunks of the file until the specific culprit is revealed? Depending how the file is handled while being divided into sections for testing this might or might not work but I've done it before and think that might be possible in this case. Depending on where the culprit resides within the file this might go quickly or take some time but if you think having a much smaller section of file to look at would help I can do this.
If you have the time and patience to do it then it could well help.:)
It crosses my mind that there might be a few characters that are being blocked but still it would be good to identify at least one for reference.

Mike
 

IronTechmonkey

Recognized Contributor
Feb 12, 2013
8,513
13,309
If you have the time and patience to do it then it could well help.:)
It crosses my mind that there might be a few characters that are being blocked but still it would be good to identify at least one for reference.

Mike

If it is specific characters they should be easy to isolate but if the issue is paragraph or end file markers that are not visible it might be trickier especially if they relate to each other as paragraph markers might. IDK why there would be such markers in logs but think that's where I'm at now. .

Down to 62 lines of the log file being used for testing; until this point trimming off the bottom or the top would yield one section that was good and one section that was bad but now if a few lines are trimmed from the top or the bottom it goes from bad to good, so the bad stuff seems to be at the beginning and end of the 62 line chunk but deleting material from only beginning or end seems to rectify. If I cant narrow the scope further in a few hours or by tomorrow morning I'll share what I've got via a 3rd party site.
 

La_Globule

Senior Member
Nov 6, 2007
444
170
Hi,
The new release doesn't fix the bug I pointed out: after a fresh install, when launching the app, I'm stuck on the XDA logo and nothing happens after (no logon request) even after cleaning all the data.
Can you please transfer this info to the dev team?
Thanks
Hello,
@STAFF members around here: can you please have a look at my problem and pass it to the dev team?
Thanks for appreciated help.
 

yazzine

Member
May 19, 2018
7
0
Samsung Galaxy S20 FE
So, i have a few things to say. First of all, i think im not the only one to say that i really miss xda Labs. It was really nice to have a "app store" like experience to find all kinds of nice apps especially if youre rooted and want to toy around with the new features you just unlocked. For which sadly i couldnt find any alternatives to. The new XDA app on itself has a few small quirks that annoy me, like how some options in the settings menu make a small window pop up that cant be closed by tapping the background or pressing the back button, forcing you to just pick the same option that was already selected if you just wanted to see the options (its a very small issue, but however VERY frustrating when it does randomly happen). However other than that the XDA app has drastically improved but also kinda is just...well, a forum reader. I hope at some point we could get an update where people can browse apps of users with the same simplicity Labs offered.
 

bitpushr

XDA:Administrator
If it is specific characters they should be easy to isolate but if the issue is paragraph or end file markers that are not visible it might be trickier especially if they relate to each other as paragraph markers might. IDK why there would be such markers in logs but think that's where I'm at now. .

Down to 62 lines of the log file being used for testing; until this point trimming off the bottom or the top would yield one section that was good and one section that was bad but now if a few lines are trimmed from the top or the bottom it goes from bad to good, so the bad stuff seems to be at the beginning and end of the 62 line chunk but deleting material from only beginning or end seems to rectify. If I cant narrow the scope further in a few hours or by tomorrow morning I'll share what I've got via a 3rd party site.
Check this now. The text file attachment was triggeting a bunch of OWASP rules which put it above a limit and the request was blocked. The specific rules it was flagging (one will not deny the request, but enough of them will):

Code:
960024 · Meta-Character Anomaly Detection Alert - Repetative Non-Word Characters    OWASP Generic Attacks    Log
950005 · Remote File Access Attempt    OWASP Generic Attacks    Log
981260 · SQL Hex Encoding Identified    OWASP SQL Injection Attacks    Log
981319 · SQL Injection Attack: SQL Operator Detected    OWASP SQL Injection Attacks    Log
959073 · SQL Injection Attack    OWASP SQL Injection Attacks    Log
981257 · Detects MySQL comment-/space-obfuscated injections and backtick termination    OWASP SQL Injection Attacks    Log
981245 · Detects basic SQL authentication bypass attempts 2/3    OWASP SQL Injection Attacks    Log
981243 · Detects classic SQL injection probings 2/2    OWASP SQL Injection Attacks    Log
uri-981172 · Restricted SQL Character Anomaly Detection Alert - Total # of special characters exceeded    OWASP Uri SQL Injection Attacks    Log
uri-981173 · Restricted SQL Character Anomaly Detection Alert - Total # of special characters exceeded    OWASP Uri SQL Injection Attacks    Log
973335 · IE XSS Filters - Attack Detected    OWASP XSS Attacks    Log
973334 · IE XSS Filters - Attack Detected    OWASP XSS Attacks    Log
973333 · IE XSS Filters - Attack Detected    OWASP XSS Attacks    Log
973332 · IE XSS Filters - Attack Detected    OWASP XSS Attacks    Log

I added a rule that should fix it, in theory. If still having issues, let me know!
 

IronTechmonkey

Recognized Contributor
Feb 12, 2013
8,513
13,309
Check this now. The text file attachment was triggeting a bunch of OWASP rules which put it above a limit and the request was blocked. The specific rules it was flagging (one will not deny the request, but enough of them will):

Code:
960024 · Meta-Character Anomaly Detection Alert - Repetative Non-Word Characters    OWASP Generic Attacks    Log
950005 · Remote File Access Attempt    OWASP Generic Attacks    Log
981260 · SQL Hex Encoding Identified    OWASP SQL Injection Attacks    Log
981319 · SQL Injection Attack: SQL Operator Detected    OWASP SQL Injection Attacks    Log
959073 · SQL Injection Attack    OWASP SQL Injection Attacks    Log
981257 · Detects MySQL comment-/space-obfuscated injections and backtick termination    OWASP SQL Injection Attacks    Log
981245 · Detects basic SQL authentication bypass attempts 2/3    OWASP SQL Injection Attacks    Log
981243 · Detects classic SQL injection probings 2/2    OWASP SQL Injection Attacks    Log
uri-981172 · Restricted SQL Character Anomaly Detection Alert - Total # of special characters exceeded    OWASP Uri SQL Injection Attacks    Log
uri-981173 · Restricted SQL Character Anomaly Detection Alert - Total # of special characters exceeded    OWASP Uri SQL Injection Attacks    Log
973335 · IE XSS Filters - Attack Detected    OWASP XSS Attacks    Log
973334 · IE XSS Filters - Attack Detected    OWASP XSS Attacks    Log
973333 · IE XSS Filters - Attack Detected    OWASP XSS Attacks    Log
973332 · IE XSS Filters - Attack Detected    OWASP XSS Attacks    Log

I added a rule that should fix it, in theory. If still having issues, let me know!

A limit on special characters? But we are all special characters. Seriously some of those criteria seem a bit rough for technical log files.Thanks for adding the rule. With any luck it will cover whatever is the widely used syntax from log files that trips the filters. Thanks! I'll have a chance to test again in a few hours.

A remaining mystery is why a copy of the file saved in wordpad as unicode did not trip the filters but to your point maybe that action addressed one of several criteria which in toto caused the block, and with that one cleared up the others which appear in the log snippet that you shared don't cause the block.
 

pndwal

Senior Member
broken in-app Search This Thread function

I see that the broken in-app Search This Thread function has been reported here as I expected.

I am surprised that this has not been fixed as it hasn't worked ever since we got the new look preset 'Search This Thread' button.

Using the App has very little advantage for me without working search; I am forced to use browser which works fine. (Incidentally, so did in-app search when it functioned like in-browser.*)

To be clear, if I search for the word "hey" in this thread using browser 13 results are returned. Same search in-app returns 1000 results (every post up to 1000 max), and it seems "*" was actually used in place of "hey". ☹️

It seems most (all?) users, at least in Magisk General Support and Discussion thread, can't use in-app search either...

Hey guys! Is this seemingly simple issue really such a doozy? Has it been investigated at all? Do very few members actually use Search This Thread?? 😬

I'll just keep using browser for now I guess...

(* "If it ain't broke, WHY fix it?") PW
 
Last edited:
  • Like
Reactions: pocketrule

IronTechmonkey

Recognized Contributor
Feb 12, 2013
8,513
13,309
broken in-app Search This Thread function

I see that the broken in-app Search This Thread function has been reported here as I expected.

I am surprised that this has not been fixed as it hasn't worked ever since we got the new look preset 'Search This Thread' button.

Using the App has very little advantage for me without working search; I am forced to use browser which works fine. (Incidentally, so did in-app search when it functioned like in-browser.*)

To be clear, if I search for the word "hey" in this thread using browser 13 results are returned. Same search in-app returns 1000 results (every post up to 1000 max), and it seems "*" was actually used in place of "hey". ☹️

It seems most (all?) users, at least in Magisk General Support and Discussion thread, can't use in-app search either...

Hey guys! Is this seemingly simple issue really such a doozy? Has it been investigated at all? Do very few members actually use Search This Thread?? 😬

I'll just keep using browser for now I guess...

(* "If it ain't broke, WHY fix it?") PW

If you are experiencing what I think you are, the search isvat first being converted to a wildcard search and you probably can see an asterisk listed as the search criteria. That asterisk is a live link which when clicked takes you to a full search panel which functions properly. This has been working in desktop web browser and Android app. See here for more details and a screenshot: https://forum.xda-developers.com/t/...ssues-and-comments-here.4245677/post-86078287. Maybe that will work for you as well.
 

IronTechmonkey

Recognized Contributor
Feb 12, 2013
8,513
13,309
Regarding in thread search in both the Android app and desktop browsers I might as well repost this here instead of just link to the other thread

If in thread search is showing all posts in the results and changing your criteria to an asterisk (in other words a wild-card) try this:

After performing the search your criteria is replaced by an asterisk indicating a wild card. That asterisk is a live link to a full search which allows you to modify the criteria (see red box in attached image) If you click that link you should be taken to the full search panel with an asterisk in the search field. If you replace the asterisk with your search criteria you should be able to conduct a proper search and after you search you will see your search criteria in the place of the asterisk and post based on that criteria will be listed.

searchthis.png
 

pndwal

Senior Member
If you are experiencing what I think you are, the search isvat first being converted to a wildcard search and you probably can see an asterisk listed as the search criteria. That asterisk is a live link which when clicked takes you to a full search panel which functions properly. This has been working in desktop web browser and Android app. See here for more details and a screenshot: https://forum.xda-developers.com/t/...ssues-and-comments-here.4245677/post-86078287. Maybe that will work for you as well.
Ah, thanks, great find / tip / workaround / bug-bypass... I'll pass it on... I noticed orange * (ie. a link) but never thought to click it!

Clicking wildcard (*) I now get 15 results for This Thread "hey" search! 😜

Still, Search This Thread button itself (coding) is broken and needs to be bypassed with extra steps. Ironically it seems it was introduced to reduce steps. 🙄 Love to see it working as intended and intuitively. PW
 

pndwal

Senior Member
Bit further re.
Broken in-app Search This Thread function
workaround above:
Btw, in step (1) you might click Advanced instead of Search

Advance search will open and you could take the tab "Search threads"

Now you are directly in the search like in (2) above, but missing here the option to search THIS specific thread - hence unfortunately you must always go through the two steps as above
Actually, I agree that this find / tip / workaround / bug-bypass is quite limited in value, and by no means fully resolves search issues.

Perhaps it's not 'great', but it does work as advertised 🤪 ; and yes, 'Restrict search to specified thread' is missing after using 'Search threads' tab at any stage, not that a means to specify or the 'specified thread' was ever shown either...

This is, however, in keeping with XDA app's frustrating / broken functionality in general, eg inability to return to a previous page, including search result list page after checking one result (forces you to re-do whole tedious search process for each time you look at a result!), due to both back arrow and back button not doing / allowing this or even working as expected, and often landing you back in the dumb 'partial thread' view...

For now, I'll continue to do most XDA posting & searching in browser. For practical purposes, XDA app sadly only has advantages for notification functions and browsing posts for me... lends itself largely to those who don't bother either searching or posting much... ☹️ 😜

To those concerned, I am actually grateful for the app and to those who contributed to it 👍👏, but the comments above do reflect the true state of XDA's app as I / many other users see it... I hope this is taken as the constructive criticism intended. 😛 PW
 

notstpaul

Senior Member
May 2, 2016
73
55
Redmi Note 9 Pro
Any chance of simplifying the login procedure? I'm happy to login via the app and not via a browser and then authorising my phone again.

Every few weeks when I'm forced to login again (not sure why) I have to copy paste passwords, 2FA details etc just to use the app. It's quite discouraging.

Of course, I may be doing something wrong and hopefully someone can let me know a better way of doing things.
 

IronTechmonkey

Recognized Contributor
Feb 12, 2013
8,513
13,309
Suddenly Mr frosty blue! 😝 Yay!

Now I'm going to have to find that tiny orange search-link all over again in a different color but at least while I do it I'll know I'm an RC by the color of my username. :D

Bit seriously, I could not care less about color of links and care only a little about titles. Those things don't improve forum access (restore what was once possible) as would having links at top and bottom and ability to navigate back to where you were in thread. I will beat this drum any time it passes before me.
 
Last edited:
  • Like
Reactions: pndwal

IronTechmonkey

Recognized Contributor
Feb 12, 2013
8,513
13,309
Any chance of simplifying the login procedure? I'm happy to login via the app and not via a browser and then authorising my phone again.

Every few weeks when I'm forced to login again (not sure why) I have to copy paste passwords, 2FA details etc just to use the app. It's quite discouraging.

Of course, I may be doing something wrong and hopefully someone can let me know a better way of doing things.

If you have your default android browser configured to log in to XDA with remembered password the processes of logging back in when that happened should not require manually entering passwords; some annoying extra taps but no cutting and pasting unless the browser does not remember password.
 

pndwal

Senior Member
Now I'm going to have to find that tiny orange search-link all over again in a different color but at least while I do it I'll know I'm an RC by the color of my username. :D

Bit seriously, I could not care less about color of links and care only a little about titles. Those things don't improve forum access (restore what was once possible) as would having links at top and bottom and ability to navigate back to where you were in thread. I will beat this drum any time it passes before me.
I consider myself chastised for posting this in Magisk General Support / Discussion thread (it just got deleted along with other OT):
I am on the Magisk Canary and for some reason it screwed up XDA.
Where can I find the xda stable module?
So I can go back to amber. 😁
I'm on Alpha + Alpha XDA I believe... Is there a Stable XDA? Is this a regression or are we just being encouraged to aim for the sky?... Actually, I think someone just bumped the switch... PW
Thought I'd rescue it and post it here before refreshed page... Maybe it's more appropriate in this serious forum. 😝 PW
 

IamTheBRAVE

Senior Member
Xda app is being wonky again... This morning the alert page wouldn't load. Removed the app from recents list, then started again. Got ****d out and had to log in again. Now, Articles won't update (last update 17h ago) no alerts all day, and i just realized i Haven't recieved alerts on a couple watched threads for 2 weeks (magisk support thread and a oneplus 9 pro custom rom one)
It feels like server connection problem...
Anybody else?
 

guitardoc64

Senior Member
Sep 26, 2007
2,117
547
Lake Charles,LA
OnePlus 7 Pro
OnePlus 8T
Xda app is being wonky again... This morning the alert page wouldn't load. Removed the app from recents list, then started again. Got ****d out and had to log in again. Now, Articles won't update (last update 17h ago) no alerts all day, and i just realized i Haven't recieved alerts on a couple watched threads for 2 weeks (magisk support thread and a oneplus 9 pro custom rom one)
It feels like server connection problem...
Anybody else?
I just got an alert when you posted this, but I had to log back in to get to it.
 
  • Like
Reactions: Lz3807775t

Top Liked Posts

  • There are no posts matching your filters.
  • 10
    Does this help us?
    https://xenforo.com/community/threa...-users-choose-12-hour-or-24-hour-clock.25762/
    It's old, but maybe still relevant?

    It says clock format is linked to the language, so a new language preference could be created by the forum admins (say "English 24h clock" for example) which would allow users to select a clock format.

    That being said, I tried to find the language preference on the website and didn't find anything. Am I just being stupid not finding it or is there no language selection available?

    Thanks very much for further digging into this but it's not only beyond my paygrade. Moderators have no insight how the website is technically set up. So far I've never seen any possibility to set a preferred language, and if I correctly remember that wasn't the case under vBulletin either.

    Maybe @MikeChannon has more information or knows what the backroom webgurus are doing?
    Well for simplicity and server load etc we only have English (US) installed.
    I can suggest English (UK) as an addition which might give us alternative time formats.
    However, this is far from a promise that our technical guys will approve such an addition... we do have to be careful not to overload things here, I already see some slowness in the servers from time to time.

    Mike
    10
    Anyone heard any news on whether there's ever gonna be an update to fix the XDA app or better yet an entirely new one?

    Obviously everyone is aware of the fact the current XDA app is and has been a complete and total disaster since the day it was very first released in its beta ever worked properly since, an now completely unusable. Still makes absolutely no sense to me why they made the decision to just completely abandon the original "XDA Labs" app which was great. I understand the XDA Developers website was being completely rebuilt from the ground up at the same time the current XDA aosbut still doesn't explain why you'd abandon what was at the very least a very solid base for which a could of been a dimple uild the new app off instead of the unusable mess they decided to create and release. I'm a long time user and big fan of the XDA forums and really hope to one day see again some sort of an XDA Forums app that is usable and has some actual decent functionality like "XDA Labs" did. Hopefully this idea hasn't been completely given up on, if anyone has any knowledge on this please let me know, thanks ....🤔💩😕
    Developer of xda labs app stopped development on it. Nothing to do with XDA. XDA switched forum platforms, so app had to be completely rebuilt in the new platform. I don't have any more issues since they got rid of the awful ads that plagued the app originally. I don't hear or see many complaints anymore as the app functions fine, although with a search hiccup or 2. Most of the gripes are people preferred the Labs app which like I said was dropped by the Dev (not xda) and it would have needed to be changed to this platform anyway for it to work which basically means it would be exactly this app. I used Tapatalk for over 10+ years, basically from the 1st tapatalk app and because xda changed it's forum platform it stopped working on there as well. If the app is not your thing, you can always use web version and add a shortcut directly to that, or better yet, since this a development forum, one can learn to build and design their own app.
    6
    Does this help us?
    https://xenforo.com/community/threa...-users-choose-12-hour-or-24-hour-clock.25762/
    It's old, but maybe still relevant?

    It says clock format is linked to the language, so a new language preference could be created by the forum admins (say "English 24h clock" for example) which would allow users to select a clock format.

    That being said, I tried to find the language preference on the website and didn't find anything. Am I just being stupid not finding it or is there no language selection available?
    Thanks very much for further digging into this but it's not only beyond my paygrade. Moderators have no insight how the website is technically set up. So far I've never seen any possibility to set a preferred language, and if I correctly remember that wasn't the case under vBulletin either.

    Maybe @MikeChannon has more information or knows what the backroom webgurus are doing?
    6
    Seems OK,
    I'm a new user & just finding my way!
    Alan
    5
    Seems OK,
    I'm a new user & just finding my way!
    Alan
    Welcome to XDA!
    Hopefully soon we will have an update
  • 95
    The new app is just an upgrade to the current XDA app, so you should be able to just go into Play and hit "Update"


    The app is rolling out now, and will take hours to get to everyone. For safety, we are doing a staged rollout at first at about 50%.

    Update 12/8: App is now at 100% rollout so everyone should get it soon. Thanks for testing and using it! :)
    Update 1/13/21: We are aware that for some, the app isn't working. We plan to release a fix ASAP.


    Fun things to try:

    - Login explore the app settings and gesture controls (hit the third button on the bottom).
    - Read the Tips and Tricks thread
    21
    So many are asking about the news section in the app---and yes, we intend to bring this back.
    18
    So far it's s long way short of the old app, in terms of functionality.
    For me the main things that could be fixed/implemented are
    . Easily select my device then have the main device subforum one click away. (No, it's not going to be good enough to bookmark/flag/watch/favourite/whatever the individual subforums of the device subforum. It would be nice to have the device forum in its own tab/link/etc. and not mixed in with the general watched threads section)
    . Go to the last read post when opening a thread
    . Selecting a thread, by default, opens that thread, not show some useless overview, requiring a second button tap to actually open it.
    . Bring back the swipe left and right, in a thread, to go to the previous next page in the thread.

    I've been lazy and haven't gone through this thread, so I assume there's nothing new here as these are all the staple needs of a forum app. So apologies if I'm repeating other thoughts, but the more often the basics are flagged, hopefully the higher up the fix list they'll go.
    OK, having spent a bit more time with it, here are more thoughts.
    . The current home page is mostly useless, the trending, new posts, and new threads are 99.9% device specific about a device you don't own and so is pointless. Move this to the last tab on the bottom (I'll leave it to someone else to suggest an icon for it) then make a useful home page. The most useful things are quick access to your own device subforums (This would be an expandable list, depending on how many devices you own/care about.), quick access to see new posts where you have direct replies, quotes or mentions and quick access to see new PM's. The rest of the home page could then be configurable so each user can choose what else is important to them. (e.g. New posts to threads you've previously participated in).
    . Bring back the functionality to automatically save a draft of a new post/reply. It was incredibly useful when you needed to add multiple links to other threads. It was also very useful when creating long guides, etc. to be able to compose it in stages if necessary.
    . Why are PM's (conversations in modern parlance) only accessible in the alerts tab?. I understand new messages should have alerts there, but surely the whole collection should have its own place. I guess somewhere in the account tab would make some sense.
    17
    I'm sorry to have to say this to the developper of this app, but I really don't like the new app. It's so less convenient than the previous XDA Labs app.

    Here in a list of key features I'm missing:
    - Going straight to the last unread post when clicking on a thread (instead, the new app opens the thread in the OP which is very frustrating as you can't really figure out where you last left the thread).
    - Navigating through thread pages by swiping left and right
    - The Newsfeed section
    - The XDA App section. Maybe it's because this is forbidden by Google, but then why don't you make a non playstore XDA+ app with this additional feature? Many XDA users are "expert" happy to install apps from other sources than the Play Store anyways
    - The "My Device" section, leading straight to our Device forum
    - The Subscribed Thread tab

    Other things that I find very frustrating with new app:
    - It's too cluttered, and despite the clutter, it is not only less convenient than the previous XDA Labs app, but it is also missing nice features/tabs/filters that can be found in the browser version
    - I'm getting the SSL error when using NextDNS private dns. The only way around this is to whitelist www.google-analytics.com and www.googletagmanger.com. This is unacceptable for me. I can't whitelist this google crap just for the sake of accessing the XDA app (especially XDA, of all apps, why would you mingle so deeply with google analytics?).

    I'm gonna stick to the web version for the time being (also a frustration), hoping for an improved XDA app, with a more user-friendly UI, less permission requests, and less dependancy on google-crap.

    Also, is there a web browser equivalent to the XDA Lab App Store?
    16
    well , title says "tell us what you think".
    firstly i'd like to say that i am not a developer. so i couldnt have done this. it is appreciated the time , effort , hours and knowledge that went into it.
    but i think it was @lfom who said it best for me ; "it killed the mobile user experience". i can learn new ways to navigate to where i want to go. i can find most everything i look for. but the overall experience has , well diminished quite a bit for me personally. i know you all are working diligently to fix the things that are broke which is again highly appreciated. but i can get kinda the same experience with my mobile browser and launcher just by logging in and clicking on "save to home screen".
    just my ¢.02 and do appreciate the effort.
    all the best for xda and its members/families in the new year.
    mrrocketdog , a.k.a. dave