CHevron WP7 USB device connections problem FIX!

Search This thread

ilijan

Senior Member
Jul 21, 2008
290
40
Bratislava
1. Have Winphone developer tools installed. Download it for yourself
2. Connect Phone via USB
3. Wait till zune starts and sync completes
4. Verify that zune is not in a guest relationship
5. open a command prompt, type netstat -a to confirm that port 443 is not being used
6. open an admin command prompt, navigate to c:\windows\system32\drivers\etc\ then type notepad hosts and delete any references to windowsphone developer services
7. go to the settings on the phone and turn airplane mode on (so that the phone is forced to use internet via zune)
8. While the phone is still on the settings page, run Chevron with admin privileges

Attention: if port 443 is used (see on your list) stop IIS or exit Skype program
 
Last edited:

Lizzo

Senior Member
Jan 25, 2009
560
34
Trinidad
1. Have Winphone developer tools installed. Download it for yourself
2. Connect Phone via USB
3. Wait till zune starts and sync completes
4. Verify that zune is not in a guest relationship
5. open a command prompt, type netstat -a to confirm that port 443 is not being used
6. open an admin command prompt, navigate to c:\windows\system32\drivers\etc\ then type notepad hosts and delete any references to windowsphone developer services
7. go to the settings on the phone and turn airplane mode on (so that the phone is forced to use internet via zune)
8. While the phone is still on the settings page, run Chevron with admin privileges

Attention: if port 443 is used (see on your list) stop IIS or exit Skype program

eureka!!! it worked!!!!:D:D:D
 

DanielNTX

Senior Member
Aug 18, 2010
268
82
Austin, Texas
Now it just gets the error later

I mentioned this in the original thread:
I had the same connection problem as everybody and then out of desperation I set my computer and phone date to the 1/10/11 and tried and it worked!
Guys.. finally..atleast I had my phone unlocked by chevron..
change the date to a future date(as a post earlier suggested, thanks ) , for me it was 01/Oct/2011...it worked finally..dont know how everything else pans out....will update..

Set the time and date of the phone and computer back to like 1/10/2011 and it should work.

For some reason the spoof'ed developerservices.windowsphone.com address to your local machine rejects the HTTPS 443 request if the date is correct. I think it was a built in kill switch by the original devs of ChevronWP7. Because the program can tell whether if the phone is pin-locked or not and will display a message accordingly meaning it definitely has a connection.
 
Last edited:

maxpg

Member
Nov 22, 2009
39
0
Setting the date back seems to have no effect here. I changed the date of the computer and the phone to the 1st of january 2011. Reconnected the phone, waited until sync to zune finished and retried. Still the same problem.
 

DanMar

Member
Jan 27, 2010
13
0
1. Have Winphone developer tools installed. Download it for yourself
2. Connect Phone via USB
3. Wait till zune starts and sync completes
4. Verify that zune is not in a guest relationship
5. open a command prompt, type netstat -a to confirm that port 443 is not being used
6. open an admin command prompt, navigate to c:\windows\system32\drivers\etc\ then type notepad hosts and delete any references to windowsphone developer services
7. go to the settings on the phone and turn airplane mode on (so that the phone is forced to use internet via zune)
8. While the phone is still on the settings page, run Chevron with admin privileges

Attention: if port 443 is used (see on your list) stop IIS or exit Skype program

Thanks! Was the developer services in the HOSTS file that fixed for me.
 

ilijan

Senior Member
Jul 21, 2008
290
40
Bratislava
it work properly for me ... if you sync with zune its automatickly broke the chevron unlock... just go step by step and you can unlock your phone withou connection issus usb error...GL & HF
 

pinodrum

Member
Jun 21, 2010
8
0
Agrigento
yes....i do it....but...it's the same error...aaarrrhhhhh....
For two days the same error....I can not understand why, and I have done everything ... sure ...

please, help me...

P.S.
My os is a 64 bit, but i tried also a 32 bit so....windows 7 ultimate in both case...
 

ilijan

Senior Member
Jul 21, 2008
290
40
Bratislava
i think its enught try this step:
connect hd2 to pc via usb ,
zune start and sync.
you must have UNLOCKED SCREAN not black screen not lock screan!!
your devie must be on.
navigate to c:\windows\system32\drivers\etc\hosts double click and open with NOTEPAD...

look down and REMOVE!!!!!all this text from the host file:
192.168.1.102 developerservices.windowsphone.com
192.168.1.102 developerservices.windowsphone.com
192.168.1.102 developerservices.windowsphone.com
192.168.1.102 developerservices.windowsphone.com
192.168.1.102 developerservices.windowsphone.com
192.168.1.102 developerservices.windowsphone.com

if its removed put X to close the notepad, its open dialog windows and you click to yes save it.

after that go to chewron and run as administrator
and just unlock the device
 

nova hands

Senior Member
Jun 16, 2008
286
10
Springfield
Success!

My problem was that I had no internet connection in Zune.
I only use my Android phone to tether to the internet, and this whole time I wasn't tethered online.

It seems Zune MUST have an internet connection, and the phone MUST be in airplane mode for this to work.
 

wixxer

Senior Member
Jan 10, 2010
96
4
i think its enught try this step:
connect hd2 to pc via usb ,
zune start and sync.
you must have UNLOCKED SCREAN not black screen not lock screan!!
your devie must be on.
navigate to c:\windows\system32\drivers\etc\hosts double click and open with NOTEPAD...

look down and REMOVE!!!!!all this text from the host file:
192.168.1.102 developerservices.windowsphone.com
192.168.1.102 developerservices.windowsphone.com
192.168.1.102 developerservices.windowsphone.com
192.168.1.102 developerservices.windowsphone.com
192.168.1.102 developerservices.windowsphone.com
192.168.1.102 developerservices.windowsphone.com

if its removed put X to close the notepad, its open dialog windows and you click to yes save it.

after that go to chewron and run as administrator
and just unlock the device

I connect hd2 to pc via usb ,
I zune start and sync.
I have UNLOCKED SCREAN not black screen not lock screan!!
My device is be on.
I navigate to c:\windows\system32\drivers\etc\hosts double click and open with NOTEPAD...

look down and REMOVE!!!!!all this text from the host file:



169.254.194.227 developerservices.windowsphone.com

Close and save...

But still the problem
 

Top Liked Posts

  • There are no posts matching your filters.
  • 17
    1. Have Winphone developer tools installed. Download it for yourself
    2. Connect Phone via USB
    3. Wait till zune starts and sync completes
    4. Verify that zune is not in a guest relationship
    5. open a command prompt, type netstat -a to confirm that port 443 is not being used
    6. open an admin command prompt, navigate to c:\windows\system32\drivers\etc\ then type notepad hosts and delete any references to windowsphone developer services
    7. go to the settings on the phone and turn airplane mode on (so that the phone is forced to use internet via zune)
    8. While the phone is still on the settings page, run Chevron with admin privileges

    Attention: if port 443 is used (see on your list) stop IIS or exit Skype program
    1
    I also had the problem and port 443 was always open... go to start, right click computer -> manage, services and apps, services, stop "routing and RAS" (remote access), and you're good to go, port 443 will not show up in netstat.
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone