• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Chinese M9 bootlooping after OTA

Search This thread

misteral1970

Member
May 3, 2010
30
0
Hi All,

Really hoping someone can suggest a possible solution for this one, only had the phone a few months!

So, Chinese released M9. Unlocked. Stock recovery, not rooted. Gapps installled.
Everything perfect, then today I got the 5.1 update.
Seemed like a slightly iffy install process...looked a little like it failed a couple of times and tried again.
Finally finished, the phone shows the white screen with the one logo, takes a while, opens on the desktop and turns off, back to the white screen with the logo.

I have been able to boot into safe mode, which is stable
I have been able to get to download mode and bootloader. Neither of these offer a cache wipe or a factory reset.
I have not been able to get into recovery mode, it shows a phone with a red triangle and an exclamation point.

So for my (largely uneducated) part I have two theories for the cause:

1) Gapps is somehow proving a problem, either faulting the install or causing a fatal error on startup
2) Since the update was notified and downloaded while on a VPN via Hong Kong, I wonder if I accidentally ended up with the HK version in which case I suspect there may be hardware differences (at least the radio). This seems unlikely, I would hope there were enough checks in place to prevent this happening.

No solid idea where to go from here. I have not yet tried ADB access, but even if I can connect, what will I do? Flash a new ROM? I'd rather not. And surely I'd need to root in order to do that....

At a loss, any potential solutions welcomed whole heartedly!
Thanks...
 

iElvis

Senior Member
May 24, 2012
5,021
2,842
Modville
OnePlus 9 Pro
Booting into safe mode, but not booting otherwise, indicates a problem with some app or rom setting.

You're probably going to need to do a factory reset, but that's odd that it doesn't show up in bootloader or download mode. Have you tried the options in stock recovery (which is that screen with the red triangle)? Use the volume keys to change options.
 

misteral1970

Member
May 3, 2010
30
0
Hi iElvis - the screen with the red triangle - there's nothing other than the red triangle, no options, no text and nothing happens if I press any of the physical buttons.