Chrome started to have laggy page scroll in the latest update

Search This thread

BlackCommando

Senior Member
Feb 12, 2014
120
34
I am on MIUI 11 and after recent update of chrome, I notice laggy behaviour in Chrome, especially when scrolling. After uninstalling update lags are much lesser and then when I update again, issue comes up too.

Is anyone else experiencing same issue?
 

peter0010

Member
Sep 27, 2013
43
12
Don't really want to say that this is an solution. It's more like a workaround until it gets fixed.

You can put Chrome in your "game booster" under security app.
When I do that, the stutter is gone for me then.
 

Atomsk

Senior Member
Jan 29, 2007
121
9
I dont notice that behaviour, but chrome is eating my battery like a damn cookie monster! Its the main app that drains my battery
 

HuKoJla

New member
Dec 31, 2019
3
2
Under chrome://flags/ deactivate "use Android Servicecontrol" and scrolling becomes muuuuuuuch smoooootheeeer
The actual name is "Use Android SurfaceControl" and with it disabled UFO FPS Test started showing screen HZ values instead of something about 40 FPS with DC Dimming on, so it means Chrome now uses all screen HZ, thanks.
 
  • Like
Reactions: zgfg

flo90

Senior Member
Jan 3, 2010
180
7
I have updated chrome and This setting no longer appears. Please help. Chrome is very laggy...
 

MnMchill

Senior Member
May 3, 2016
508
315
I have updated chrome and This setting no longer appears. Please help. Chrome is very laggy...

I have the same issue. New version of Chrome doesn't have "Use Android SurfaceControl" option so I can't disable it. Does anyone know any other way to disable Android SurfaceControl in Chrome?
 

flo90

Senior Member
Jan 3, 2010
180
7
I have the same issue. New version of Chrome doesn't have "Use Android SurfaceControl" option so I can't disable it. Does anyone know any other way to disable Android SurfaceControl in Chrome?

Try to disable DC on display settings. It's working for me to make Chrome scrolling smooth !
 

gs.bence

New member
Sep 13, 2017
2
0
I reported the bug on Chromium bugs.
You can vote on it (star it) on the top left corner of the page.
Link: bugs.chromium.org/p/chromium/issues/detail?id=1057459
(copy -> paste the URL to your address bar, because I can't post links yet)
 

ntelas

Senior Member
Nov 17, 2013
136
19
The actual name is "Use Android SurfaceControl" and with it disabled UFO FPS Test started showing screen HZ values instead of something about 40 FPS with DC Dimming on, so it means Chrome now uses all screen HZ, thanks.
This worked wonders! I was so annoyed by the laggy chrome experience because everything else works fine on my 120Hz device. Only chrome looked so laggy. Do we know why does this happen in the first place?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    Try switching off DC dimming...
    :good:
    2
    Under chrome://flags/ deactivate "use Android Servicecontrol" and scrolling becomes muuuuuuuch smoooootheeeer
    1
    Under chrome://flags/ deactivate "use Android Servicecontrol" and scrolling becomes muuuuuuuch smoooootheeeer
    The actual name is "Use Android SurfaceControl" and with it disabled UFO FPS Test started showing screen HZ values instead of something about 40 FPS with DC Dimming on, so it means Chrome now uses all screen HZ, thanks.
    1
    Try to disable DC on display settings. It's working for me to make Chrome scrolling smooth !

    That's not solution because my eyes hurt when DC dimming is off.
    1
    I've scrolled through the long list of flags, cannot see that one.
    chrome://flags/
    Android SurfaceControl
    #enable-surface-control
    →DISABLED←
    Profit.
    IMG_20210402_120452.jpg

    Disabling this flag worked perfectly until it was removed from one of the previous versions of chrome, but, as I can see myself, it is back again for now.