CHUWI Hipad Root, TWRP, +Info, etc.

Search This thread

ramzes4_ua

New member
Jun 17, 2022
1
0
Official ROM

* 27th Mar 2019, Android: 8.0.0 custom build Hipad_v1.0_20190327: Download
- Kernel 3.18.60
- IMHO touch screen finally works good.

It seems that the touch screen a little bit more responsive than with Hipad_v1.1_20181107. But not overresponsive like with Hipad_v1.1_20190111 firmware.
I have the problem with phantom/ghost touches with Hipad_v1.1_20190111 firmware.
 

Budhistpeng1

New member
May 27, 2019
4
0
Anyone know anything about the new hipad x with build number
HiPad X_v1.0_ EEA _20220321 it has Android 11 preinstalled and switched from mediatek to t618-unisoc
 

Budhistpeng1

New member
May 27, 2019
4
0
Anyone know anything about the new hipad x with build number
HiPad X_v1.0_ EEA _20220321 it has Android 11 preinstalled and switched from mediatek to t618-unisoc

Screenshot_20220718-071525.png Screenshot_20220718-071238.png
 
Last edited by a moderator:

eliasildi

Member
Sep 1, 2014
20
1
hay ROM lineage para CHUWI-Tableta HiPad Air, Dispositivo de 10,3 Pulgadas con Resolución de 1920x 1200, Sistema Android 11, Unisoc T618, Octa Core, 6GB de RAM, 128G de ROM??
 

IJustRegisterToPost

New member
Aug 27, 2022
2
0
Official ROM

* 27th Mar 2019, Android: 8.0.0 custom build Hipad_v1.0_20190327: Download
- Kernel 3.18.60
- IMHO touch screen finally works good.

It seems that the touch screen a little bit more responsive than with Hipad_v1.1_20181107. But not overresponsive like with Hipad_v1.1_20190111 firmware.
I have the problem with phantom/ghost touches with Hipad_v1.1_20190111 firmware.
Thanks for the posting, however, it is not there, and will likely never be there. Not sure how many people still have this.

I bought it from Amazon, returned it for another one, same touch problem. I will never buy Chuwi again, thought of smashing it many times...

Without any knowledge or experience, personally, I'm suspecting the metal back cover might be the culprit. Been playing the word game on it for a while, when resuming the game, connecting letters, the first connecting point is somewhere on the edge of the screen, it will only happen first resuming and once.

Hoping someone has the ability and will to fix the touching problem. Chuwi doesn't care.

Without the touching issue, this IS the best deal tablet!

Good luck everyone still holding the dreaded Chuwi Hipad 10!
 

carl.mar.ll

New member
Nov 30, 2015
2
0
My Chuwi is a Hi9, with Android 8, and I bought it to use it to read books, like a Tinder.
The idea was that with the Chuwi I could do other things too, like viewing films or gaming.
Well, after some time, during which my wife used it for gaming, I'm trying to make it work for reading.
The main problem was to find a free reading program that I could use, and All PDF seems reasonable. If there's a better one please do tell me.
My first problem, as I'm quite ignorant on Android things, is how to manage the files. So I installed File Manager, but it seems different from PC's FM. I don't know how to open a folder to put the files in. Moving things around is a question mark.
The second is to enter the files into the tablet, as it doesn't seem to see the USB input. Also tried a BT interface with my laptop (my PC has no BT), but I don't seem to make it work. The most I could get with BT was to pair with my cell phone.
So I'm using a weird way to move the files, using Gmail. But now I need a folder to put the files in.
Any suggestions for some of these issues? Thanks!
 

IJustRegisterToPost

New member
Aug 27, 2022
2
0
Many, many thanks to the OP and XDA.

Chuwi Hipad 10 was a very tempting tablet, except the intermittent briefly lost touch response. There are many choices for tablets, except Chuwi.
 

bonoman

New member
Oct 24, 2007
4
0
I was able to get a HiPad X at a decent price on Amazon. I'm VERY impressed with the bang for the buck. However, the ONLY thing I can't get working (and why I bought it) is Youtube TV.

I've gone through all the regular stuff - clear cache, uninstall/reinstall, factory reset, added every place I could find to enter permissions (especially location and data), and tried watching YT TV in Chrome (no-go), but I'm constantly running into "There was a problem while playing" with a Video ID error. The tablet was meant to be used on Wifi only, but I've also inserted a SIM card with no change. There is a hint out there about changing the APN setting to IPv4 only, but I'm unable to make any changes to a VZW APN in settings.

For the life of me, I can't figure out what else to open or reset or grant permission to. I have an email into their tech support, but so far has been lackluster (as well as sending in reports to Google).

Has anyone come across this before? My laptop, Samsung S22 Ultra, and Samsung TV all stream just fine on my wifi. If any more info is needed, I'd be glad to provide it. Else I'm afraid I'm going to have to return it for another tablet solution. TIA!
 

Kaalgaai

New member
Jan 11, 2023
3
0
Anyone tryd to root the HiPad X? After Flash patched boot.img i always in a Boot loop :-/

After Flash original boot.img back all works fine (tryd magisk v22+v23)
Could you please share that original boot.img? Or maybe point to where I can find it? My Hipad X is currently in boot loop after trying to patch the boot file.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 12
    Little review and tablet issues:


    I've been waiting for this tablet for 1 month and it has finally arrived. I bought this tablet for two reasons:

    1. I was looking for a tablet with a Wifi AC chip for ~$100. None of the tablets around that price tag had this type of chip (best had Wifi N chips). Therefore after researching for a little while I found out that this was the only option available. The only alternative was Huawei Mediapad T5, with a worse battery (5K vs 7K mAh) and also a $100+ increment in price (~$100 for the Chuwi vs ~$200 for the Huawei).

    2. The tablet it clearly powerful, fast and way better in terms of power than other tablets I've been using (even Samsung Tabs). But there are some issues that may be a turnoff for some users and most of them won't be easily solvable by the company.

    After reading some reviews I can confirm several issues that won't be fully resolved:

    Screen issues

    1. The touch screen it's not the best (better with the latest ROM, see workarounds).
    They have made an overkill in the Tablet specs (decacore,...) with a cheap touch panel. The game experience is very poor despite they are selling it as a "Gaming Tablet".
    Chuwi seems to be more focused in selling at all costs than actually providing what people expect from their products. Probably they should have been selling this tablet for $50-100 more with a better screen, but this way they would have found other alternative products that may have provoked most people not buying this... difficult decission for Chuwi, ending obviously on a really bad experience (for most of the powerful games, like PUBG mobile)

    Here is a video comparing Pocophone F1 with Chuwi Hipad:
    https://vimeo.com/313134711
    There are clearly some lag issues (the stroke is behind the finger most of the time) and it's very imprecise, without the possibility of draw a perfect line, but a trail of individual dots recognized.

    Screen Issues Workarounds (WIP)

    - I'm going to test a capacitive pen to see if this makes the touch screen a lesser issue. When I test it will comment. With the latest November update, the touch screen performs a little bit better, but marginally better.
    - With the new kernel 3.18.60 (Rom 11th Jan 2019) it seems that the tablet it's a little bit more responsive.
    - It works worse with the capacitive pen than with the finger.

    Game Streaming Issues - Solved

    2. Personally I was not interested in playing games directly on the tablet, but streaming games from my PC. And also found some hindrances:
    - Steam Link Beta is not currently working: sound works, input works (touch controls) but video is not showing. Not sure where is the problem but when we start the app an error message says: Steam Link performance hasn't been verified on this device (Techain Hi9Air), so it may not perform well

    Game Streaming Issues Workarounds
    - I'm currently testing two apps: Remotr, KinoConsole. I like Steam Link because it's fully integrated and works extremely good. I've found some issues in Remotr (drag-n-drop not working) and in KinoConsole (issues with streaming image distorted). I don't find any value in Parsec atm at least for what I'm looking for (playing on the go without have to pre-setup anything).
    - I've solved the Issue with Steam Link Beta. Here is the solution: https://www.reddit.com/r/Steam_Link/comments/akz50n/troubleshooting_android_video_issues/?

    Wifi Issues

    3. WiFi chip is very poor: I've been testing with iperf2 tests and there is a 50% speed reduction vs a Pocophone F1. It's important to say that in the same spot Chuwi Hipad is getting around -70-75dBm while Poco F1 is around -60dBm

    If I find new issues I will comment them.

    Wifi Issues Workarounds (WIP)

    3. With the wifi thing there is nothing to do, if I could possibly return the tablet, I may do it, but since I bought it overseas I may forget about this.
    For me it's important to have a good Wifi signal, because as I said I'm using it for playing streamed games and with a bad signal games are unplayable.
    - Currently I've switched my AC router to a D-Link DIR 882 with a modded DD-WRT ROM to DHT80 and it's working fine. The chip seem to be really bad compared to other alternatives (like my Pocophone F1 Wifi chip), but I have to say that for under $150 I've not seen an alternative tablet with AC at all at the current moment (1Q 2019)

    Dissasembling Chuwi HIPAD for repairing (screen, battery, ...)


    One of the issues I've found is that opening the tablet it's extremely difficult compared to other alternatives. The tablets its extremely sealed without any screws and just left to open with pure pressure:
    nsXKbkf.jpg


    The BIG problem is that it's so hard to open the case that I've ended breaking the touch screen, so be extremely careful when pressuring the thing trying to not bend the tablet too much or press on any point of the screen. I changed the screen of a Chuwi Hi8 Pro 30 minutes before doing this, so I know what I'm talking about: I would say that the risk of breaking with this model is 8/10.
    ceMZzoh.jpg


    Why I've tried to open the case? Because in the last days I noticed that the tablet touch screen was not working. I expected that the cable was not adequatelly plugged, or maybe the touch screen was faulty (I think that the touch screen was faulty so I don't really care about breaking it).

    Here is an image of the PCB:
    aux8VPc.jpg


    UPDATE: 30/3/2019

    I started changing the screen and here is the result:
    Id6Ci2r.png


    Two mistakes:

    1. Ordering the new screen before being sure that I was able to extract it.
    2. Trying to extract it WITHOUT an adequate heat gun (just with a hair dryer)

    The screen is TOO big, and they only sell the screen replacement WITHOUT the touch panel. In the majority of the tablets they don't sell the touch panel with the screen replacement, BUT the difference is that the screen are rarely sticked to the panel with industrial glue. Therefore, if you don't have a really good heat gun, you won't be able to remove the panel from the screen and you will end breaking the panel. I've changed a lot of screens in other tablets without hassle just with my hairdryer, but this screen it's way harder. If you have never changed a screen the probability of breaking everything as I did is 100%. But for the cost of this tablet, I'm not sure that going for a service it's worth so If you cannot repair it yourself, i think this tablet is not worth at all.

    Development: Rooting, Recovery, ROMS

    I would like to create a comprehensive list of Rooting, recovery, possible ROMS, that may appear for this recent tablet in the future. The tablet is new and not very well known for most people yet, so we might have to wait a bit until other users start to find some value in this budget powerful tablet, depite of the caveats we have already found.

    Flashing Process with SP Flash Tool (no unlock needed)


    Remember: there is a risk of briking the tablet!
    This will do a full wipe to your Tablet so remember to backup your data before doing so

    This is the easy method to flash the tablet. All we need are some tools:
    1. The SP Flash Tool: (Download v5.1728 here)
    2. A ROM: (check in the bottom section for ROMs).
    3. Drivers: There are multiple options, but here are some working drivers for Windows:
    64bit: https://chuwiinnovationtechnologysh...jo5exkkrpmd350sicz4ae45yegp/file/337087008142
    32bit: https://chuwiinnovationtechnologysh...jo5exkkrpmd350sicz4ae45yegp/file/337086745908

    How to flash with SP Flash Tool:
    1. Extract ROM and SP Flash Tool in the same folder. Try to avoid special characters in the folders like chinese chars to avoid issues during flash
    2. Open flash_tool.exe
    3. In "Download Agent" select MTK_AllinOne_DA.bin
    4. In the "Scatter-loading-File" select MT6797_Android_scatter.txt
    5. In the "Download Only" dropdown select Firmware Upgrade
    6. Turn off the tablet and disconnect the Tablet from the USB cable
    7. Press the button "Download" in the top
    8. Connect the Tablet to the USB cable
    9. If everything it's right (including driver installation) it may appear a red line in the bottom that goes to 100%. Just wait until the process is complete with a green tick opening in a window.
    10. If it gets stuck at some point (for example at 72%) for some minutes, it will end failing the installation and you will have to start over. Remember that there is a risk of bricking the tablet.


    Rooting process


    Remember: there is a risk of briking the tablet!
    This will do a full wipe to your Tablet so remember to backup your data before doing so

    Last time I did the process was with: Android: 8.0.0 custom build Hipad_v1.1_20181107
    After updating to the new ROM (Android: 8.0.0 custom build Hipad_v1.1_20190111) tested root process again and worked flawlessly.

    1. First we need to install the USB drivers
    64bit: https://chuwiinnovationtechnologysh...jo5exkkrpmd350sicz4ae45yegp/file/337087008142
    32bit: https://chuwiinnovationtechnologysh...jo5exkkrpmd350sicz4ae45yegp/file/337086745908
    2. Install ADB like any other device. There are multiple tutorials out there.
    3. Activate the USB debugging option and the OEM unlocking option in the developers option menu (unlocking it by pressing 7 times in the Build number just like any other Android vanilla device)
    4. If we plug the USB to the computer and we do a "adb devices", we will see it listed after permitting in the device:
    fZIGBCt.png


    So far, everything exactly the same as rooting for any other Android device.

    5. Download the latest Magisk Manager APK from the site https://github.com/topjohnwu/Magisk/releases/ and install it
    6. Download the latest boot.img file (download your ROM to get the boot.img within) and place it somewhere you can find it in your phone (Downloads folder for example).
    7. We open Magisk Manager and press "Install"
    8. There we press: "Patch Boot Image File" and in the file explorer we select the boot.img file we have already downloaded and wait until it is patched.
    9. After it's patched we will see this message:
    Patched image is placed in:
    /storage/emulated/0/Download/patched_boot.img (or whatever route we have used for installation)
    10. Connect the Hipad with the PC and transfer that "patched_boot.img" file to the computer to a directory (for example C:/CHUWI we will use this for the example)
    11. Now it's time to flash

    Here goes the most risky moment. Because we have to enter the bootloader, unlock it and then flash the new "patched root boot image"

    12. We go into the console and type: adb reboot bootloader
    And it will automatically reboot into the Fastboot
    13. Now we unlock the bootloader with the command: fastboot oem unlock
    IMPORTANT: Remember that after OEM unlocking the system will wipe to factory default. Backup everything if you have anything important installed in the device
    We will see a message that says: "Unlock bootloader", press Volume up to unlock and Volume down to cancel: We press the volume up button.
    14. After this, we have an extended bootloader menu that permits going into fastboot, recovery and system fromt there. At this point we are ready to flash the rooted boot img.
    15. We type: fastboot flash boot patched_boot.img
    And we will see something like ths:
    $ fastboot flash boot patched_boot.img
    target reported max download size of 134217728 bytes
    sending 'boot' (10415 KB)...
    OKAY [ 0.348s]
    writing 'boot'...
    OKAY [ 0.141s]
    finished. total time: 0.489s

    16. Finally it's time to reboot to check results by typing: fastboot reboot
    17. After OEM unlocking we will see the orange Chuwi logo meaning that we have "unlocked it" and suggesting we are in an "untrusted state". That's fine.
    18. Be aware, that after doing this it will take a little bit more than usual to boot Android. Just wait for it.
    19. When device has rebooted Magisk Manager will be already installed but we will have to update because everything has been wiped as I warned before. If everything has gone right (maybe we will have to reboot again after the first boot for some updates to take in place) we will see this in Magisk Manager:
    psGLi1H.png

    20. And that's all folks! Root installed in our device:
    NuHt8mj.png



    TWRP process

    At this moment we don't have a TWRP or any other recovery compatible with this hardware, stay tunned.

    Official ROMs

    * 11th Jan 2019, Android: 8.0.0 custom build Hipad_v1.1_20190111: Download
    - Big improvement in the touch screen, It seems that the touch screen it's a little bit more responsive
    - New kernel 3.18.60
    * 6th Nov 2018, Android: 8.0.0 custom build Hipad_v1.1_20181107 Download
    - Slight improvement in the touch screen

    Other ROMS

    We don't have any custom ROMS available yet :(
    Let's see if some ROM devs want to test this and make a custom ROM like Resurrection Remix 6 (based on Oreo).

    Updates

    - This tablet will be updated mid-2019 to Android 9.0 Pie: https://forum.xda-developers.com/showpost.php?p=78278868&postcount=994
    2
    Big update today:

    1. There is a new ROM ready to install from 11th January. Touch screen is working way better than before. If you don't want to unlock the device you can flash it via SP Flash tool. Instructions and ROM in the first post.

    2. I've been able to flash a semi-functional TWRP
    PAknRAX.jpg


    The only problem is that I've not been able to enable the decrypt password prompt (I always use encryption for my /data). When I solve this issue I will upload the TWRP img in case anyone wants to test it.
    With TWRP on place this will be useful to install new test ROMs
    1
    So overall, the tablet it's awesome. A+ But the screen is completely ****. The worst element by far. The second worse: the Wifi AC Chipset, very poor power.
    But I was intending to buy a Huawei T5 10.1' to compare between both ($200). And I've ended renouncing to it, because I think that it's fine to go on with the Hipad. I think that for what I need it's more than sufficient.
    so i just ordered an alldocube tablet, similar x27 chipset and i've been doing some research before it arrive:

    apart from the random touchscreen issue, i think the main problem is with the helios x20 series chipset, is it struggles with responsiveness and "short burst" tasks. i am new user can't post links so just google and run "kraken javascript benchmark" in browser.

    the a72 cores in helios x20 should mean you score ~4000 here, but typically i see 9000-10000 in reviews for devices using this chipset. so the problem reported is it is not even utilizing these fast cores in these short bursty tasks. of course this is good for battery saving, but bad for performance/responsiveness.

    for longer running benchmarks like geekbench, antutu the cores become active and are OK

    so there have been some solutions, for example the meizu 6 got updated firmware that boosts the cores more aggressively, and anandtech review said benchmark results improved 2-2.5x, but they don't say how they do this

    some portion of the redmi note 4 phones also use the x20 chipset, it is more laggy than the snapdragon counterpart, and there have been a few tweaks in their forums, this one looks promising to me, google "Redmi note 4 (mtk) better gaming Learn how to get the most out of it (root)"

    it seems you first disable the mtk perfservice, so the system uses the default cpu governor. then you make some tweaks

    of course you need root and you do this at your own risk etc so make sure you read the miui thread and understand before using the code, also it is a good idea to note down the system default values before you change them, for when you want to revert back.

    from the thread here is some recommended code for light gaming and general use to improve response, comments are my interpretation of what it does:

    Code:
    #background "real time" priority task  0.01ms time allocation
    echo 10000 > /dev/cpuctl/bg_non_interactive/cpu.rt_runtime_us 
    
    #time between when scheduler reschedules 0.95ms for "real time" priority task
    echo 950000 > /dev/cpuctl/cpu.rt_runtime_us 
    
    #default time allocated by scheduler for "real time" priority task 1ms
    echo 1000000 > /dev/cpuctl/cpu.rt_period_us 
    
    #this is feature to take in to account number of cores for allotting time, turn it off to increase response time 
    echo 0 > /proc/sys/kernel/sched_tunable_scaling 
    
    #dynamic voltage frequency scheduler for gpu on
    echo 1 > /proc/mali/dvfs_enable 
    
    #ignore thermal for gpu on, since the cpu a72 cores 
    echo 1 > /proc/gpufreq/gpufreq_limited_thermal_ignore heat up and cause throttling
    
    # apparently this unlocks the a72 cores
    echo 0 > /proc/ppm/policy/hica_is_limit_big_freq

    i think this or some other code on that thread can help the system utilize the strong a72 cores, increasing performance but at expense of battery, if you can tweak it such that Kraken benchmark gets close to 4000 score with acceptable battery, i think it is big success.
    1
    To get the stock recovery is simple. For those that have already rooted with my method:
    1. Install the app Diskinfo
    2. Enable all partitions in the settings
    3. Theorically there should appear a partition like /dev/block/mmcblk0pXX (XX is two numbers)
    4. Download Terminal emualtor
    5. Run the command "su"
    6. Run the command "dd if=/dev/block/mmcblk0pXX of=/sdcard/stock-recovery.img" (remember to replace the XX with the number of the partition of the recovery)

    Also can be found in the log with Terminal emulator:
    1. Command: "cat /cache/recovery/last_log | grep recovery"
    And will get a line like:
    19 /recovery emmc /dev/block/...

    And then with the path (/dev/block/... ) just need to edit the dd if=/path/... of=/sdcard/stock-recovery.img

    L4CA1BH.png
    1
    Hi
    This is a official update? I don't have it in "definitions»Updates"...:confused:
    It's not an OTA update yet. But it's official by the Chuwi team. 100% recommended