[clark] Unofficial 18.1

Search This thread

Wheels564

Senior Member
Apr 13, 2019
172
100
Genoa, U.S.A.
Has anybody yet tried TWRP from 17.1 thread?

Advanced restart is missing from developer options.

I have not tried it and would not expect TWRP to work yet.

Advanced restart is under gestures/power menu. I had to search for it in settings.

MindTheGapps-11.0.0-arm64-20210212_144546
There's no Md5 with the download
 

Attachments

  • MindTheGapps-11.0.0-arm64-20210212_144546.zip
    160 MB · Views: 13
Last edited:

kb8no

Senior Member
Jan 29, 2012
1,186
294
Duluth MN
I have not tried it and would not expect TWRP to work yet.
I tried TWRP 3.4.0_9-0 from LOS 17. Weird. I was able to Backup beautifully. I rebooted into ROM and file managers cannot see the backup on the SD TWRP directory. I went into TWRP and the file manager can see the backup just fine. What's this?

So I dirty flashed the same ROM with TWRP and it flashed fine but now it could not find the SIM at all, "no SIM". What's this? So I restored the first ROM with TWRP just fine and SIM worked (but same LTE problem). That is, restored back up perfectly. So you can use TWRP to make a back up and restore anyway but something is not right with flashing. So I did a complete clean flash of the ROM with TWRP and same problem, "no SIM". Then I restored the original ROM and back to square one, just the same.

Do you think we need to flash back to Nougat before starting out on 18.1? The behavior when the firmware is not working is goofy SIM and data issues and this seem like deja vu.
 
Oct 15, 2019
16
0
Latest version 21.4 works.

.
Swipe down from top to see home button. Save to sd card did not work on 17.1 so he removed the icon. Thanks for helping me find new forum!

Link to gapps is not working here.

Sorry for partial reposting this from 17.1 forum. Seems very functional on WiFi. Phone does not read VZW SIM on boot and can't pick up APN. I had to choose VZWINTERNET APN. Then LTE works for 30 seconds. Data drops for maybe a minute, then falls back to 3G which works. If LTE worked I think we would be golden.

Also get "DM config update keeps stopping" error. Not sure if this is related to SIM. I used NikGapps but don't think it is related.

Photos can not access SD card but Files has no problem. Edit. My bad. Photos works fine.
yes magisk works, BUT Safetynet check doesn't work !!!
 

moviefirst

Senior Member
Nov 3, 2018
165
62
A little feedback on my side, using the rom from day one with all my daily apps. Like, whatsapp, viber, mobile data (4g), gmail, telegram, outlook, adobe, two banking apps, instagram, maps, google apps.........and more. My phone is not rooted, didn't tried safety net. All apps are functional, but I've noticed when using the phone more then say half hour it gets really hot and starting to freeze and takes ages to open apps again. Also when I was on 17.1 I put a new battery in my moto and battery life was oke. Now on 18.1 it drains more also at night in standby. Just wanted to share this information.:)
 

kb8no

Senior Member
Jan 29, 2012
1,186
294
Duluth MN
I have 5 working Clarks. One is for my wife on 17.1 clean flashed from Stock on Verizon SIM and works and I do not touch it. One is on 14.1 because it is stable, everything works (VoLTE etc) and I use it to stream music. The other 3 I just play with and I have a Verizon and an ATT SIM for testing. I clean flashed one from 17.1 to 18.1 (2/20 update) using LOS Recovery. It seemed good. Then I placed the Verizon SIM and as I described, it would start in LTE and drop back to 3G and "DM Config Update" error shortly after boot. Then it started to deteriorate and became laggy and erratic to the point of being unusable. So I began to wonder if I should try to start over with stock with the SIM in place.

I wondered if the SIM was corrupted as well so I put it in my "old faithful" 14.1 phone. It worked as it should and fixed the SIM problem. I then put the SIM back in my play phone and started over. I tried it - flashed stock and booted it and and SIM worked fine. I then did a clean flash of 18.1 with LOS Recovery. It started up perfectly other than same "DM Config Update" error. LTE started up and stayed working. ROM worked perfectly and not erratic, like a different phone.

I then decided to try my Verizon SIM in one of my other play phones on 18.1 and same problem, LTE started up and quit and then dropped down to 3G. So I put the SIM back in the previously working perfect phone and, guess what? SIM was corrupted and it would not stick on LTE any longer.

So I thought either I was going crazy or I had discovered something weird. So I started all over. Put the newly corrupted Verizon SIM into my 14.1 phone and it worked. Then I repeated the same process with the 18.1 phone, put in the SIM, flashed and booted stock (worked), and clean flashed 18.1 with LOS Recovery. LTE worked perfectly again, did not drop down to 3G, and works like a bomb.

Then I have a play phone on 17.1 using my ATT SIM with no problem. I tried that SIM in a 18.1 phone. It came up as "ATT" but no data. I put it back in the 17.1 and it was corrupted, same problem and it did not work. I put it in the "Old Faithful" 14.1 and still corrupted. Geez. I gotta go get a new ATT SIM now. I gotta believe if I take a phone back to stock with a working ATT SIM and then clean flash 18.1 it will work but I am worried.

So something is not right with the way the SIM initiates on 18.1. If you want 18.1 to work with a SIM I suggest you flash back to stock and bring it up to 18.1 with the SIM in it. Then don't let your SIM's cohabitate with other phones. I also felt the phone worked dramatically better after flashing back to stock. It might be good just to flash back to stock and clean flash to 18.1 on general principles.

Addendum: Well Well Well. My ATT SIM was "suspended" because it was not a "supported" phone on 18.1. I can't say that 17.1 worked either because I haven't tried it for months and it stopped working immediately after I tested it first. VoLTE doesn't work on 17.1 either. All the providers are doing away with OS's that do not support LTE or VoLTE .

The ATT SIM was an easy fix for the technician to "restore", just like starting a new SIM card. Now I am guessing that the problem with the Verizon SIM may have been a variation on the same problem but rather than suspending it they dumbed it down from LTE to 3G rather than suspending it. Flashing the SIM back to stock and immediately to 18.1 may have just been a workaround.
 
Last edited:

shylikov

Member
Mar 18, 2020
11
0
Добрый день форумчане!Скажу своё мнение по поводу 10 и 11 андроида на наш аппарат.Чуть не допилены они,у обоих фото не сохраняет на внешнюю карту памяти,нет индикации зарядки,у 11 версии тупит камера.В целом конечно не плохо на борту иметь такое ПО,но чуть чуть бы доработать и 👍👍👍.Сейчас стоит 17.1,каждодневный ресурс.справляется отлично,батарею держит шикарно,ни греется при просмотре Ютуб и т.д
 

shylikov

Member
Mar 18, 2020
11
0
Good afternoon, members of the forum! I will tell you my opinion about the 10 and 11 androids on our device. They are almost finished, both photos do not save to an external memory card, there is no charging indication, the 11 version has a dull camera. In general, of course, it's not bad to have on board such software, but just a little bit to modify and. Now it costs 17.1, everyday resource. It is being corrected perfectly, the battery is gorgeous, it does not get warm when watching YouTube, etc.
 

Wheels564

Senior Member
Apr 13, 2019
172
100
Genoa, U.S.A.
Just for testing purposes I put the phone in airplane mode, set it face down on a table so it didn't sense movement and let it sit. After 10 days I expected it to be dead but to my suprise it was still at 42% charge. Not bad for early development.
 

kb8no

Senior Member
Jan 29, 2012
1,186
294
Duluth MN
@Wheels564 @shylikov Indeed battery life is very good for this phone. With light use the battery lasts 1.5 days on a phone which has never been notable for good battery life.

@shylikov no ability to save photos from LOS camera to ext SD card. I do not find this to be major issue in my usage and easy enough to move photos from internal to external memory. This is a nice but missing feature of the camera.

The notification light is now working. The battery charge light does not work.

VoLTE is not working. This is a big problem because ATT now deactivates any SIM cards without VoLTE and requires a phone call to initiate the SIM care again. Certainly all cellular providers will eventually block this ROM. If VoLTE was working this would be my DD and I see this as the biggest limitation.
 

Wheels564

Senior Member
Apr 13, 2019
172
100
Genoa, U.S.A.
@Wheels564 @shylikov Indeed battery life is very good for this phone. With light use the battery lasts 1.5 days on a phone which has never been notable for good battery life.

@shylikov no ability to save photos from LOS camera to ext SD card. I do not find this to be major issue in my usage and easy enough to move photos from internal to external memory. This is a nice but missing feature of the camera.

The notification light is now working. The battery charge light does not work.

VoLTE is not working. This is a big problem because ATT now deactivates any SIM cards without VoLTE and requires a phone call to initiate the SIM care again. Certainly all cellular providers will eventually block this ROM. If VoLTE was working this would be my DD and I see this as the biggest limitation.

I'm with you on that. Calling with VoLTE is like having the person standing right next to you. By chance did you see the option in settings (Advanced Calling)? Do a search in settings and you'll find it. I haven't tried it because I only have one sim card active and need it for my business phone. It would be curious to see if he left it active.
 

kb8no

Senior Member
Jan 29, 2012
1,186
294
Duluth MN
I'm with you on that. Calling with VoLTE is like having the person standing right next to you. By chance did you see the option in settings (Advanced Calling)? Do a search in settings and you'll find it. I haven't tried it because I only have one sim card active and need it for my business phone. It would be curious to see if he left it active.
I can't find it. Can you be more specific where Advanced Calling is?
 

Wheels564

Senior Member
Apr 13, 2019
172
100
Genoa, U.S.A.
I can't find it. Can you be more specific where Advanced Calling is?

Go to settings, When the search bar comes up start typing in Advanced Calling it will show up.
 

Attachments

  • Screenshot_20210304-083850_Settings[1].png
    Screenshot_20210304-083850_Settings[1].png
    188.1 KB · Views: 16

Wheels564

Senior Member
Apr 13, 2019
172
100
Genoa, U.S.A.
Ok. It is part of mobile network settings but they are missing so no luck. :(

I've been searching the difference in the device trees between 14.1 and 18.1 for the VoLTE settings but haven't been able to find them. If Chris would enable it or show where the change was made I could build and try it. I'm sure we could provide the logcats necessary for him to fix the bugs if any.
 
  • Like
Reactions: kb8no

Top Liked Posts

Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone